BSOD Microsoft-Windows-WMI 0x80041003

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by tinaosw, Jul 22, 2010.

  1. tinaosw

    tinaosw Senior Member

    Joined:
    Jul 22, 2010
    Messages:
    4
    I see this error posted all over the internet, yet no real solution!
    Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.
    WIN 7 64 bit
     
  2. Captain Jack

    Captain Jack Windows Forum Team Staff Member Premium Supporter Microsoft MVP

    Joined:
    Mar 6, 2010
    Messages:
    1,984
    Hello and Welcome !

    You have mentioned an Event viewer error and also BSOD. Regarding the WMI there are few things that you could do to fix it. The error 0x80041003 it happen when the user does not have permission to perform the operation in WMI. This could happen when you query certain classes as a low-rights user, but most often happens when you attempt to invoke methods or change WMI instances as a low rights user. The namespace you are connecting to is encrypted, and the user is attempting to connect with an unencrypted connection.

    Follow these steps:

    Code:
    @echo on 
    cd /d c:\temp 
    if not exist %windir%\system32\wbem goto TryInstall 
    cd /d %windir%\system32\wbem 
    net stop winmgmt 
    winmgmt /kill 
    if exist Rep_bak rd Rep_bak /s /q 
    rename Repository Rep_bak 
    for %%i in (*.dll) do RegSvr32 -s %%i 
    for %%i in (*.exe) do call :FixSrv %%i 
    for %%i in (*.mof,*.mfl) do Mofcomp %%i 
    net start winmgmt 
    goto End 
     
    :FixSrv 
    if /I (%1) == (wbemcntl.exe) goto SkipSrv 
    if /I (%1) == (wbemtest.exe) goto SkipSrv 
    if /I (%1) == (mofcomp.exe) goto SkipSrv 
    %1 /Regserver 
    :SkipSrv 
    goto End 
    :TryInstall 
    if not exist wmicore.exe goto End 
    wmicore /s 
    net start winmgmt 
    :End 
    Copy these to a Notepad and save it as WMI.bat then Right Click and run as administrator. This will rebuild the WMI values.

    1, Right-click your Computer icon on the desktop, and then click Manage from the shortcut menu. The Computer Management panel launches.
    2, Double- click Computer Management (Local) from the left pane to expand (if necessary), click Services and Applications to expand (if necessary), click WMI Control to select it, right-click WMI Control, and then click Properties from the shortcut menu. The WMI Control Properties dialog box appears.
    3, Under the Security tab click the Root folder from the Namespace navigation allows you to set namespace specific security box, and then click the Security button. The Security for Root dialog box appears.
    4, Ensure that the logged in user is listed and the Allow option is enable for all available permissions. Also
    5, Click Apply (if available), and then OK to close the Security for Root dialog box. The WMI Control Properties dialog box reappears.
    6, Click Apply (if available), and then OK to close the WMI Control Properties dialog box.
    Close the Computer Management panel and reboot the System once.

    For BSOD Help Click here for instructions

    Good Luck,
    Captain
     
    Trouble and (deleted member) like this.
  3. tinaosw

    tinaosw Senior Member

    Joined:
    Jul 22, 2010
    Messages:
    4
    Your fix seems to have worked. Thank you for your time.
     

Share This Page