COM Surrogate Windows 7 64bit

Discussion in 'Windows 7 Help and Support' started by azulblueaoi, Jan 7, 2011.

  1. azulblueaoi

    azulblueaoi New Member

    Joined:
    Jan 7, 2011
    Messages:
    4
    I have installed Windows 7 Ulimate 64 bit three times, and its the same thing all the time. I try to open a picture to preview it, it says COM Surrogate has stopped responding. Also I have tried installing programs like google crome which works the first time i opened it, but now it just says it stopped working and won't open or uninstall, the only I can pretty much do is go on IE and use ccleaner, speccy :/ What could I do to fix this. The computer specs are:
    OS:
    MS Windows 7 Ultimate 64-bit
    CPU:
    AMD Turion X2 RM-72 Griffin 65nm Technology
    RAM:
    3.0GB DDR2 @ 336MHz (5-5-5-15)
    Motherboard:
    Gateway (Socket M2/S1G1)
    Video Card:
    ATI Radeon HD 3200 Graphics
    Hard Drive:
    244GB Hitachi Hitachi HTS543225L9A300 ATA Device (SATA)

    I really have no idea what to do, I can see reinstalling windows doesn't help, so if someone could shed some light on my situation. Thanks so much.
  2. Captain Jack

    Captain Jack Windows Forum Team Staff Member Premium Supporter Microsoft MVP

    Joined:
    Mar 6, 2010
    Messages:
    1,983
    Hello and Welcome to W7F !

    I believe I gave you suggestion in the other forum. But still tell us what is the DEP settings set to.
  3. azulblueaoi

    azulblueaoi New Member

    Joined:
    Jan 7, 2011
    Messages:
    4
    Ok well i tried this and well it didn't work, still getting COM Surrogate error, I also tried DEP settings, i try to add the dllhost.exe, but i am getting the error "You can not set DEP attributes on 64-bit executables" I don't get how I would turn DEP off though, there is only two options for turn on for essential widows programs and services or turn on for all programs and services....

    Is there any other hope?? Also IE 32bit doesn't work on here no more only 64-bit one?? Google still won't load. I can watch videos and listen to music, but I can't look at photos, photos give me the COM Surrogate error :/

    (This is what i posted at other forum)
  4. Captain Jack

    Captain Jack Windows Forum Team Staff Member Premium Supporter Microsoft MVP

    Joined:
    Mar 6, 2010
    Messages:
    1,983
    Change the DEP setting to "Turn on for essential widows programs and services" and reboot the System. Then from View Panel go to "Folder Option" there select "Always show icons never thumbnail" then test it.
  5. Trombomaniac

    Trombomaniac New Member

    Joined:
    Dec 30, 2010
    Messages:
    2
    For Windows 7 64 Bit go to the directory Syswow64 for adding the dllhost.exe to the DEP-list. Worked for me. Greetings

Share This Page