1. Microsoft has announced the release of the Windows 10 Technical Preview today. Read more...

Windows 7 does not save my Network Drive Credentials

Discussion in 'Windows 7 Networking' started by chad, Aug 5, 2009.

  1. chad

    chad New Member

    Joined:
    Aug 5, 2009
    Messages:
    8
    I currently am doing file sharing through Samba. My Samba server is running on Fedora Core 8, and I am trying to access the network drive through Windows 7. I can map a network drive to Samba, and I can view and share my files fine.

    The problem I am having is that I always ask it to save my login credentials (which are different than my Windows 7 login credentials), and it never does. I have to map the network drive each time I boot up my computer again.

    Does anyone know how to permanently keep these settings so I do not have to map this each time I start the computer?
     
  2. pclerimus

    pclerimus New Member

    Joined:
    Nov 9, 2009
    Messages:
    2
    I have the same problem. My Samba is running on Ubuntu and works fine with name+passwort security level (no domain level). But Windows 7 can't remember my samba user credentials (neither name nor password) after a reboot of the windows machine.

    I dont' know any solution for this problem. I hope that someone else reading this thread do know.

    Regards
    pclerimus
     
  3. Monkey

    Monkey Well-Known Member

    Joined:
    Feb 27, 2010
    Messages:
    4
    Same here, I've been looking all over for a solution to this. But no luck so far :(
     
  4. Monkey

    Monkey Well-Known Member

    Joined:
    Feb 27, 2010
    Messages:
    4
    I've been thinking about it some more and (in my case) it seems logical.
    The problem was that I used the same username on samba and on windows, but they didn't share the same password.
    I created a new user on samba, and created the same user on windows 7.
    On windows 7 I made the user hidden like this(it's just for samba-sharing purposes, not to log in):

    * Create the registrykey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList\

    * In UserList, create a DWORD (32bit) value, and give it exactly the same name as the user u want to hide.

    * Make sure the value is 0 to hide it from the logon screen.

    Mapped it again with this user, and the map was still available after reboot.
     
  5. sogoodtobe

    sogoodtobe New Member

    Joined:
    Mar 11, 2010
    Messages:
    70
    or you use the prompt to establish the map: net use X: \\path\share /user:username

    /savecred will force caching your creds in Win7 safe so that it stays after a reboot.

    If that fails, the last option is to create a batch containing the above command and run it at boot time.

    Hth.
     
  6. nailujk

    nailujk New Member

    Joined:
    Jun 24, 2010
    Messages:
    2
    What worked for me was to enter DOMAIN\username as the username when first being asked for logon details for the mapped share. Make sure the DOMAIN is the same workgroup or domain the computer is a part of. Otherwise the credentials get lost on reboot.
     
  7. john415a

    john415a New Member

    Joined:
    Mar 14, 2012
    Messages:
    2
    Try going to the Control Panel\Credential Manager and edit the credentials for the networked drives that are not reconnecting at
    logon.
     
    1 person likes this.
  8. R4NS0M

    R4NS0M New Member

    Joined:
    Oct 27, 2012
    Messages:
    2
    This Worked PERFECTLY For Me. Thank you to John415a. What I did basically is follow the directions given above:

    I navigated to: "Control Panel\User Accounts and Family Safety\Credential Manager" I then minimized this window and opened a new window and navigated to the exact directory on the network drive (the share drive) that I wanted Win7 to permanently map to. I then, within this same Windows explorer window, at the top portion of the screen, right-clicked on the current "Address Bar" and selected "Copy Address". I then closed the window, and Maximized the Credential Manager window that I had originally minimized. In this window I did 2 things.

    1) First I selected the link that reads: "Add A Windows Credential". This link brings you to a page with 3 form fields. "Right-clicking" in the "Internet or Network Address" form-field I then "Pasted" the address that I had copied previously. I then finished this step by typing the "User name" and "Password" that I use to access my network drive into their respective form fields and then clicking the "OK" button.

    2) Secondly, I selected the link that reads: "Add A Generic Credential". This link takes you to a similar form as before, and therefore repeat the same process as in step 1.

    Done. Done. Reboot to verify that the credentials are in fact preserved.

    I know this post may have been a bit over articulated and redundant but I figure there are those out there, like myself, who may find that a more detailed explanation/instruction can be a bonus. Original credit belongs to John415a's post for solving this problem. Thank you again.
     

Share This Page