Search results

  1. C

    Windows 7 Need for speed Most Wanted

    I can't install NFS most wanted on W7 RC 64bit, it say that Dx9 or higher is require :( but I am sure that Dx9c (the lastest one) was install in my PC.
Top