100Mbps speeds on 1000Mbps network

Problem: Can't get file transfer speeds over 12MB/sec...avg is around 7-8MB/sec..this happens system to system, or system to NAS, or NAS to system

The setup:

I have a 24 port linksys gigabit swith, 6 computers, 5 NAS devices....all gigabit

every system on the network, other than the nas, is running windows 7

the switch is registering gigabit connections, indicated by the link lights
Jumbo frame is ON and is supported by all systems

What has been tried:
i have turned remote differential compression OFF, from what few articles i read on the web

tried different cables

tried other ports

cycled everything

updated drivers

tried a separate switch

DHCP on/off

Jumbo Frame on/off

anybody have any insight as to what to try? i have been looking all over the web and only found the concept of turning remote differential compression off

NAS is a iomega ix4


It was the NAS itself

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.