4GB DDR3 only 1.99GB

#1
I've just upgraded my computer from a DDR2 2x2GB+ASUS M2N32+AMD 5200+ to 2x2GB DDR3(!)+ ASUS P7P55D PRO+Core i5 750. It's the same Win7 x64 ultimate on both configs, but now at system info it says: 4,00GB RAM (1,99 usable). What is with the other 2?? In my old PC it had access to the full 4GB. The modules are brand new and working, I checked them with memtest86, only the windows can't use them. Please help!!!!
 


#2
Are the ram sticks of the same brand, are their bios timings correctly configured ?

What is the total ram shown in windows task manager > performance tab ?

Is any system RAM dedicated to other tasks by the BIOS (BIOS cache, graphics, etc.)?

You may need to upgrade bios and/or reinstall windows.
 


#3
In task manager there is only 2 GB, the RAMs are identical (dual kit), and bios is on default except for boot priority. I've just reinstalled windows, so I don't think it'll help. And BIOS must be the newest version, cause P55 boards just came out 1-2 months ago.
 


Highwayman

Extraordinary Member
#4
Have you tried swapping banks around and testing each stick?
 


Digerati

Fantastic Member
Microsoft MVP
#5
I agree with Highwayman - try swapping the modules around. What does CPUz say? Note that many new graphics cards "share" memory. I suspect that is where yours went.
 


#6
I experienced the same problem after an upgrade from 2 GB (2x1 GB) to 4 GB (4x1 GB). Only 1.99 GB usable.
I solved it by removing the mobo battery for 2-3 minutes. After reinserting the cell and restarting, everything was OK. All 4GB seen by Windows and the experience index went from 5.5 to 7.5.
Hope it will work for you too.
 


#7
another idea - clean the ram contacts and make sure sticks are seated properly - sometimes it needs a little push to make it snap in
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.