A patch is preventing the system from starting - Error code = 0 x 490

#1
I recently had to replace some bad memory which caused my home built system to fail to boot into Windows. I have a dual-boot (XP on one HD, and Win7 on a separate HD). The system has been running smoothly for more than a year until the failed RAM module. I can boot into XP, but not into Win7, not even Safe Mode.

On startup, it fails to boot into Windows 7. I get "Windows Error Recovery" with 2 options: Launch Startup Repair (recommended) and Start Windows Normally

When I choose Launch Setup Repair, it says it cannot repair this computer automatically. The Problem Details are:

Problem Even Name: StartupRepairOffline
Problem Signature 01: 6.1.7600.16385
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: Unknown
Problem Signature 04: 21200566
Problem Signatuer 05: AutoFailover
Problem Signature 06: 19
Problem Signature 07: BadPatch
OS Version: 6.1.7600.2.0.0.256.1
Locale ID 1033

I hit Finish, then it shuts down.

Then I boot into the system DVD, and selected Repair your computer, which gives me the System Recovery Options:

I selected Startup Repair, and every test was completed successfully with a 0 x 0, except one, and it said:

Root cause found:
A patch is preventing the system from starting
Repair action: System files integrity check and repair
Result: Failed. Error code = 0 x 490

The odd thing is, when I repeat this test, this same error code appears, but later on it also says:
Root cause found:
Startup repair has tried several times but still cannot determine the cause of the problem

I tried "bootrec /fixmbr" and "bootrec /fixboot" and got "The operation completed successfully messages" for both, but they didn't work.

I also tried "bootsect /nt60 SYS /mbr" and got the message: "Successfully updated NTFS filesystem bootcode. Successfully updated disk bootcode."

I also ran"bootrec /scanos" and "bootrec /rebuildbcd" from the command prompt and got the message: "Total identified Windows installations: 0"

Could this be my problem? That even though Windows 7 is listed above as "(recovered)" in the Windows RE, that maybe Windows 7 is just corrupted beyond repair? I'm hoping that's not the case.

In addition, this issue has wiped all my restore points as well as system images. Any held would be greatly appreciated!
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Do you normally boot the drives separately or do you get a boot menu?

I would probably disconnect the XP drive until Windows 7 was working.

Do you have the same memory configuration now as you did earlier?

It may take several attempts using a Startup Repair for it to work. Have it done it several times with reboots in between?
 


#3
I boot seperately from the Boot Manager. Each OS is on its own HD. I installed XP first, then Win7. I made it so XP can't see the Win7 partitions because XP was wiping Win7's restore points. Same RAM configuration (2 x 4 GB Corsair DDR3 1866); but old RAM was 1600. I have tried Startup Repair between 20-30 times. Disconnecting the XP drive sounds interesting...This is my current Disk Mgt. Setup.

Disk Management.jpeg

I did a Win7 system backup using EaseUS Todo Backup to a USB external HD. I didn't create a boot disk with this software, but I did create another option in the Boot Manager - an EaseUS Todo Backup Linux boot option. When I boot into this, and attach my USB external HD, I do have an option for restoring the system image I made 2 weeks ago. I guess this would be my last option.

Another thread told me that the Win7 partition is probably corrupted in some fashion, and it may be cleaner to restore the image from two weeks ago before my RAM failed. Any thoughts? Continue to debug, or just restore the old image?
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
One Command you have not run yet is the Bcdboot command. It replaces the current BCDstore with the one on the drive.

You can look it up, but basically you need to run the command from the partition with the Windows 7 OS. But since you do not have the special partition, you would be putting the boot files back in the Windows OS partition. So, if you boot to the Install DVD and go to the command prompt, whichever partition the OS is on (let's use X: ) you would type this:

Bcdboot X:\Windows /s X:

I have not tried running it from a Command Window in XP, but as long as you know the path to the utility, it might work. Just make sure you know which partition is which.

Because of the situation with the "patch", this may not work, but I do not know for sure what it is referring to.

If the Windows 7 partition is corrupted, running Chkdsk and then SFC /scannow (which you can run from offline) might help.
 


Last edited:
#5
"So, if you boot to the Install DVD and go to the command prompt, whichever partition the OS is on (let's use X: ) you would type this:

Bcdboot X:\Windows /s X:

I have not tried running it from a Command Window in XP, but as long as you know the path to the utility, it might work. Just make sure you know which partition is which."

So you're saying to boot into the command prompt of the Win7 DVD, and use D: (the label for the Win7 partition on my system), correct? By doing this, I wouldn't be running it from a "Command Window in XP", correct?

Thanks again!
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
I am saying, if you do boot to the DVD, which is the best way, make sure the drive letter you use is the Windows 7 partition. Since you need to go there anyway, just do a dir command and make sure. Then you can run the command from that partition.

Drive letters change depending on how you boot. Because it says D: in the Disk Management when booted into XP, does not mean it will be that same letter if you boot to the DVD.
 


#7
Roger that, I'll give it a try. Thanks!
 


#8
I did as you suggested. I got the "Boot files successfully created" message. I still can't boot into Win7. However, it did change the OS recognized in System Recovery Options from "(recovered)" to "Windows 7". So I tried "bootrec /fixmbr", "bootrec /fixboot", and "bootsect /nt60 SYS /mbr" again. They all said they were successful - but they didn't work.

I did a chkdsk again, and no problems were noted. Also, when I do a "sfc /scannow", I get "There is a system rerpair pending which requires reboot to complete. Restart Windows and run sfc again." I do this, but I get the same message. Do you know why this is occurring?

Disk Management.jpeg Disk Mgt..JPG

As you can see from the Partition Wizard snapshot, it says that the Windows XP partition is also Active. If I make this inactive, would that change things? I wanted to ask before doing it; I don't want to make matters worse.

Thanks again for the input!
 


Last edited:
#9
None of the above suggestions worked, so I restored a system backup that I made two weeks before this issue began using EaseUS Todo Backup. This great bit of software installed a boot option that permitted me to recover my system...and so far it is stable (keeping my fingers crossed!). Thanks again for all your help! Cheers!! :wink_smile:
 


#10
I had the same problem but in my case we had a short power failure just bufore i started to get this 0x490 errors. Tried every possible solutions i could find but none of them worked. Then suddendly i discovered that because of the power failure my BIOS had loaded the default values and the SATA controller was set to IDE mode. Changed it back to AHCI mode and Windows booted up normally once again :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.