A USB device no longer works on a Windows 7

#1
Hello everybody,


My USB Keyboard doesn't work on Windows RC, the issue is exactly same as Vista KB948643 "A USB device no longer works on a Windows Vista-based computer after you resume the computer from standby (S3) or from hibernation (S4)", is anybody know how to fix it in Windows 7? Many Thanks!
 


reghakr

Essential Member
#2
Hello,

Welcome to the Windows7forums,

Dud this occur immediately after installing Windows 7?

Did you download the official RC from MS?

Did you do a "clean" install or an upgrade?

Are you using th 32-bit or 64-bit edition?
 


#3
Hello,

Welcome to the Windows7forums,

Dud this occur immediately after installing Windows 7?

Did you download the official RC from MS?

Did you do a \"clean\" install or an upgrade?

Are you using th 32-bit or 64-bit edition?
Thanks reply dude.

I'm dame sure this occurring after install Windows 7.

The Windows 7 RC is download from official Microsoft website.

This is clean direct installation on a blank harddisk.

I'm using 32-bit edition.

p.s. this problem is what a exactly same as the KB said, it is just copy the problem from Vista to Windows 7... Anyway, the download patch doesn't work on Windows 7, may response error message "The update is not applicable to your computer."
You could download the patch file from http://www.daskeyboard.com/images/Windows6.0-KB948643-v2-x86.msu, which is provide from my keyboard manufacture website site. You could try to extract the patch for modification, Thank you for your kindly help.
 


Last edited:

reghakr

Essential Member
#4
iamgozilla

In order to troubleshoot your problem we need to know more detailed specs of your system hardware.

1. Go to Start > Run, and type msinfo32. then expand the Components tree and choose a device
2. Go to Control Panel > Device Manager and look for any entry that has a yellow flag beside it.
3. Download System Information Viewer
4. Download PC WIZARD 2008
5 Please fill out your computers specs in the User Control Panel here on the site as well. It will then appear next to your name. look at my posting and you'll see the drop-down arrow.

Have you tried switching the USB cable to a different port?
 


#5
iamgozilla

In order to troubleshoot your problem we need to know more detailed specs of your system hardware.

1. Go to Start > Run, and type msinfo32. then expand the Components tree and choose a device
2. Go to Control Panel > Device Manager and look for any entry that has a yellow flag beside it.
3. Download System Information Viewer
4. Download PC WIZARD 2008
5 Please fill out your computers specs in the User Control Panel here on the site as well. It will then appear next to your name. look at my posting and you'll see the drop-down arrow.

Have you tried switching the USB cable to a different port?
Thank your for your super quick response. I need take some times to gather the information's you need.

Just to let you know that if I change plug it to other normal speed usb port it is work very well, but still no response after recovery from hibernate mode. If I plug it to high speed usb port, windows 7 cannot identify it or said cannot install driver for it. Anyway, I'll post more details for you guy easy to resolve.
 


#6
DVB-T Stick won't work after hibernation

Hello,

I have a similar problem, it was the same in Win 7 Beta as in Win 7 RC.
I did a clean Win7 RC install x64.
After hibernation my USB-DVB-T stick won't work.
Hardware manager recognises it, there are no flags but winsows media center cannot get any signal.
if you reboot the system, or unplug plug the stick everything works fine.
First i thought it was a bad driver from the USB stick, but i tried it with two different ones from different brands, it's always the same.
All other USB devices work without any problem.
It is the same problem documented above in this post: usb device won't work after hibernation.

Any clue?

EVGA 680i SLI
q6600
4 GB corsair 1066
3 Seagte 7200.11 500 gb
2x geforce 8800GT
Win7 RC x64
 


reghakr

Essential Member
#7
Hello and welcome,

Is it a AVerMedia A302?

You might find more details here:

Go to Start > Run, and type msinfo32, look under the Components section for hardware identification
Go to Control Panel > Device Manager and look for any entry that has a yellow flag beside it
 


#8
Hello,
its a cinergy USB xxs,
the other device was a genius tvgo DVB-T02pro.
no yellow flags.
Problem is also on different USB ports.

Mike
 


reghakr

Essential Member
#9
Hello mechtils,

Sorry for the delayed responce

I found Vista drivers and software here

Cinergy T USB XXS
 


#10
Hi,

this is the drivewr i am using.

It is definately nott a driver or usb device problem, because the problem persists with another stick from another manufacturer with other drivers.

Other ideas?

Mike
 


#12
Hello All,

For my cases of USB problems as titled, I have found a solution to let it works, which is disbale the USB 2.0 high speed option under motherboard BIOS, so means that whole system will only work USB under full speed after disable this options...

My DasKeyboard is work very well after this changes, but the USB could not work high speed USB anymore...

Hope that there are hotfix release could fix the problems, just like the Vista hotfix as my first post...
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top