“The Windows Installer Service could not be accessed"

Discussion in 'Windows 7 Help and Support' started by Chaurigol, Jan 1, 2010.

  1. Chaurigol

    Chaurigol New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    Windows 7 Ultimate x64
    Windows Installer 5.0.7600.16385

    View attachment 4537

    Hello everyone, I just joined this forum in desperate need for a solution. I recently started receiving this error message whenever I try to install a *.msi program. I have tried every single fix I've found on the net with no luck, these include:

    - Unregistering/registering msiexec (in normal and safe mode)
    - Exporting [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msiserver] registry value from a working OS and import it in mine.
    - Copying MSI files (such as msiexec.exe, msi.dll, msisip.dll and others) from other Windows 7 OS and replacing them with mine.
    - System restore to a previous point.

    And many others I don't remember right now.

    Unfortunately there's no Windows Installer 5.0 available to download and try reinstallation.

    Reinstalling the OS isn't really an alternative right now.

    I attached my [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msiserver] key in case someone wishes to analyze it.

    I would greatly appreciate any other suggestion.

    Thanks in advance!

    P.S.: Any additional information you need just ask for it, I will provide it as soon as possible.
     
  2. Chaurigol

    Chaurigol New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    I went further on my research and found a way to enable debug logging for Windows Installer. So I did that and here I brought the results. I don't have the enough knowledge to interpret and get something out of this, but I'm sure it must be useful.

    I tried to install Win7codecs (just picked a random MSI installer) and got the usual error, here's the log:

    === Verbose logging started: 01-01-2010 1:32:52 Build type: SHIP UNICODE 5.00.7600.00 Calling process: C:\Windows\SysWOW64\MSIEXEC.EXE ===
    MSI (c) (C4:78) [01:32:52:316]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

    MSI (c) (C4:78) [01:32:52:316]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

    MSI (c) (C4:74) [01:32:52:331]: Resetting cached policy values
    MSI (c) (C4:74) [01:32:52:331]: Machine policy value 'Debug' is 0
    MSI (c) (C4:74) [01:32:52:331]: ******* RunEngine:
    ******* Product: C:\ProgramData\Win7codecs\{1FDFDF6A-AFBD-41F6-82E6-266AF57F12AB}\Win7codecs.msi
    ******* Action:
    ******* CommandLine: **********
    MSI (c) (C4:74) [01:32:52:347]: Machine policy value 'DisableUserInstalls' is 0
    MSI (c) (C4:74) [01:32:52:363]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'C:\ProgramData\Win7codecs\{1FDFDF6A-AFBD-41F6-82E6-266AF57F12AB}\Win7codecs.msi' against software restriction policy
    MSI (c) (C4:74) [01:32:52:363]: Note: 1: 2262 2: DigitalSignature 3: -2147287038
    MSI (c) (C4:74) [01:32:52:363]: SOFTWARE RESTRICTION POLICY: C:\ProgramData\Win7codecs\{1FDFDF6A-AFBD-41F6-82E6-266AF57F12AB}\Win7codecs.msi is not digitally signed
    MSI (c) (C4:74) [01:32:52:363]: SOFTWARE RESTRICTION POLICY: C:\ProgramData\Win7codecs\{1FDFDF6A-AFBD-41F6-82E6-266AF57F12AB}\Win7codecs.msi is permitted to run at the 'unrestricted' authorization level.
    MSI (c) (C4:74) [01:33:22:408]: Failed to connect to server. Error: 0x80080005

    MSI (c) (C4:74) [01:33:22:408]: MainEngineThread is returning 1601
    === Verbose logging stopped: 01-01-2010 1:33:22 ===


    Also, checked the Event Viewer after the error prompted:

    Event ID: 1015
    Source: MsiInstaller


    Hope this contributes.
     
  3. Chaurigol

    Chaurigol New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    I have visited and tried the solutions posted in this KB also: How to resolve Common "Windows Installer" Problems

    Unfortunately none of them worked.

    Method 1: First one I tried, didn't work.
    Method 2: Version 5.0 not available for download.
    Method 3: Can't install the utility, since it's a MSI file too...
    Method 4: Installer service is set to Manual as it should be.
    Method 5: Tried emptying Temp folder too, no luck.
    Method 6: I just posted the debug log on one of my previous posts, hope someone can make something useful out of it.
    Method 7: Not applicable to Windows 7, but checked some of the options listed there and they're OK.
    Method 8: Not applicable.
    Method 9: Didn't understand, but doesn't seem very useful at all.
    Method 10: Not applicable.
    Method 11: Key not present on my registry.
    Method 12: Not possible as there's no MSI 5.0 to attempt a reinstallation.

    Also, read the following article: Ask the Performance Team : Troubleshooting a Windows Installer Issue

    After I did, I checked the registry permissions. It all seems fine, System and Admin have full control over the registry.

    Regarding Process Monitor, I downloaded and opened it, applied the filter in order to monitor only msiexec.exe activity and tried to install the *.msi once again. I saved the log file (attached together with Process Monitor) in case somebody wants to have a look at it.

    Appart from that, can't think of anything else to extract from that article.

    Then tried enabling the default Administrator account (originally disabled) and executing the *.msi from it, but no luck at all, same error message.
     
    #3 Chaurigol, Jan 1, 2010
    Last edited: Jan 1, 2010
  4. Chaurigol

    Chaurigol New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    Anyone alive here? :(
     

Share This Page

Loading...