Access denied to all HDD! All work arounds fail.

Discussion in 'Windows 7 Help and Support' started by gbambo, Jun 27, 2009.

  1. gbambo

    gbambo New Member

    Joined:
    Jun 27, 2009
    Messages:
    6
    Likes Received:
    0
    I have been running build 7100 x86 for a while now. This morning it started announcing "access denied" to both my hard drives and all their partitions. I had not made any changes to settings of any kind recently nor installed any hardware or software recently. The only account on the PC is set up as an administrator.

    I have tried changing security settings so I could take ownership and grant myself permission, but "access denied"

    I have tried the same from the command line, but "access denied." I cannot execute the Dos Prompt as administrator (despite being an administrator) because "access denied."

    I have tried disabling UAC, but the system just blinks and does nothing.

    I have tried logging in as Admin or Administrator, but there seems to be no way to do this.

    I have tried reinstalling Windows from scratch, but "access denied." In setup the drives display their volume names (I think) and correct sizes, but incorrectly display zero free space.

    From explorer within Win 7, the drives do not display their volume names and show no free space.

    I have lost access to more than half of all my work product (I have a second PC that is not experiencing problems of this sort).

    This is completely unacceptable and infuriating. In smaller ways, this has always been a problem, the issue of denials due insufficient authority.

    I am the sole owner of my hardware and the sole user. There is no reason I should ever be wrestling for authority.

    I really need help. I have Googled and tried several things, but none of them work in my situation. Have I just lost my data? Is there anyway around this?
     
  2. pkley

    pkley New Member

    Joined:
    Jun 28, 2009
    Messages:
    8
    Likes Received:
    0
    Wow, someone else with the same problem!

    Something very similar just happened to me, although mine isn't as extreme as yours. I do have access to my documents, but little else - access denied.
    I was able to determine that somehow my only account has been switched to a Guest Account and I haven't found a way around it.
    I'm using the x64, Homegroup and it happened in the last several days. I posted in the TechNet forums the following:
    Completely baffled as I didn't experience this with the beta.
    Installed RC1 as a HomeGroup, only 1 PC in the group, only one user. I went to migrate some templates from my beta x86 folder backup and paste them into my RC1 x86 folder. "You need permission from an Administrator to do this". I checked my Account type and it says GUEST??? I selected Administrator but it won't take.
    I tried accessing the Administrator account but don't have rights to even make it show up in the User Accounts.

    I also tried creating a new account but it kept saying "The specified account name is invalid. It must not contain ;:'/ blah blah" but the name is 123 or Robert or...

    Just determined that it was not this way for about the last month, this is something that happened within the last few days. The only change I can think of is that I changed the login to not require a password. I'd change it back to requiring a password but it WON'T SAVE THE CHANGE! GRRRR.
     
  3. pkley

    pkley New Member

    Joined:
    Jun 28, 2009
    Messages:
    8
    Likes Received:
    0
    Are you certain you are STILL an administrator?

    My account glitched and was restricted to Guest. I was able to get into safe mode by pressing F8 during boot, then log out and log into the built-in administrator account. At that point, my account was not listed in the User Accounts, nor could I create a new account with the same name. I ended up creating a new account and copying everything over from the old account.
     
  4. gbambo

    gbambo New Member

    Joined:
    Jun 27, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks for replies but ...

    The first thing I checked (and checked more than once) was that my account was still listed as administrator. It was.

    I had not changed my password ever and did have a password.

    I found I could gain access to the data by booting from a Kubuntu 9 DVD, as the "lock" is merely a logical attribute enforced only by Windows. Kubuntu's NTFS access just ignores it. This solved nothing though, as I had too much data to off load it to removable media and no spare drives.

    So, hypothesizing that it was a bug in RC1, I loaded Server 2008 R2 RC2. It was able to unlock them using ordinary ownership/permission grants. Using Kubuntu, I had cleared data from the small system drive and then reformatted it, so it would allow installation of Server.

    After using Server to unlock the large data drives (partitions on 1 separate drive actually), I installed Vista on the system drive.

    And what do you know, but I am locked out of the data drives again! What really upsets me about this, is that I stopped storing data on system partitions (and especially My Docs) because I was sick of the permissions problem that always ensued when I reinstalled Windows.

    And about that. How does one delete \Windows.old etc. from a drive that one does a clean install to without reformatting? I tried using Kubuntu and it appeared to work, but they look to have "sprung" back from the grave upon rebooting into a MS OS. WTF!

    Its my PC and I want and expect COMPLETE unfettered control.
     
  5. Kari

    Kari New Member

    Joined:
    Jun 11, 2009
    Messages:
    20
    Likes Received:
    0
    Sorry guys, this has nothing to do with your problem, but it reminds me of my old friend, IT-specialist in a bit bigger company. After a couple of beers he always tells that to fully understand Windows and all of its features, you have to have a master´s degree in Parapsychology. ;)
     
  6. Deathaze

    Deathaze New Member

    Joined:
    Jun 16, 2009
    Messages:
    78
    Likes Received:
    0
    Wow, I honestly don't know what could have caused this. The only thing I can say is to boot in to safe mode and try fiddling around in there with the command prompt net user and stuff like that...thats all I can say sorry :(


    Perhaps try to contact Microsoft directly as they may be able to help you.
     
  7. gbambo

    gbambo New Member

    Joined:
    Jun 27, 2009
    Messages:
    6
    Likes Received:
    0
    Probable workarounds

    Thanks everyone!

    I am not familiar with Net User via the command prompt. but I assume it is like Sudo in Linux?

    I do know that Safemode via the GUI was exactly the same as upon a regular boot - no help there.

    I appear to have found workarounds. The access denied issue is owing to Windows Access Conrol Lists complications. This is the heart of the windows file permissions system. It can be turned off by reverting to Simple File Sharing! Then Windows just ignores any lack of permission. Weird that what is presented as a Network security protocol has such profound implications for a local user.

    Inability to delete old Windows installs, is, I suspect, a consequence of Windows File Protection (in XP) or Windows Resource Protection (in Vista). Not sure how to turn these off, but most obvious solution would seem to be to use Kunbuntu to do the deleting (perhaps my impression this failed previously was an error). The underlying mechaniism would seem to be frustrated by such a collateral attack.
     

Share This Page

Loading...