Access denied to my files on another PC

Discussion in 'Windows 7 Help and Support' started by haggis999, Nov 23, 2010.

  1. haggis999

    haggis999 Senior Member

    Joined:
    Nov 23, 2010
    Messages:
    15
    Likes Received:
    0
    I have tried to find an answer to my file access problem but they all seem to refer to access issues on a single Windows 7 PC. My problem is different as I am trying to copy files from my old Win XP Pro PC to my new Win 7 PC, via my home network.

    Out of about 60,000 files only 42 are causing me difficulties. Just as an example, I have a folder on my old PC that contains 5 pdf files. The 'owner' of these files is 'administrator', who has Full Control permissions. I am also logged in to this PC as administrator.

    Despite this, when I try to run a file synchronisation program (running as administrator) on my Win 7 PC it fails to copy these 5 files over the network and gives me the error message "API call error, Access is denied". When I use Windows Explorer on my Win 7 PC and try to copy these same files manually, I get the error "You need permission to perform this action. You require permission from the computer's administrator to make changes to this file".

    As two computers are involved in this copy process, it is unclear which machine requires what changes from whom. I would be grateful for some guidance.

    David
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If after going thru the processes described in the link that cybercore has provided you are still having issues. Try reverseing what you are attempting. If the attempts to pull the files are unsuccessful try pushing them instead. Create a new folder on the Win7 machine where you would like to put the pdf files. Make sure that the user on the XP machine has the proper share permissions as well as ntfs permissions (security tab in folder properties) to the folder and then push the files from the XP machine to the Win7 machine rather that pulling them from the Win7 machine. It may help expose which machine is actually having the problems. Also reading the following article may further help you understand how both share permissions and ntfs permissions impact what you are trying to do.
    Combining Shared Folder and NTFS Permissions
    Hope this helps
    Randy
     
    #3 Trouble, Nov 23, 2010
    Last edited: Nov 23, 2010
  4. haggis999

    haggis999 Senior Member

    Joined:
    Nov 23, 2010
    Messages:
    15
    Likes Received:
    0
    I have checked everything in cybercore's link and confirmed that my current security settings meet all the requirements.

    Randy's link ref the combined effect of shared folder and NTFS permissions is interesting but, again, not the source of any guidance on my problem as both types of permission are already as high as they can be for the administrator account on my Windows XP PC.

    I will make an attempt at 'push' copying of my files but I would still like to understand why my attempts at 'pull' copying are failing for a small number of my files. There has to be a logical explanation and I don't like errors I can't fix!

    David
     
  5. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    Are any of these files password protected? Can you copy the file on the PC it's on then transfer the copy? Sharing can be a real pain.
    Joe
     
  6. haggis999

    haggis999 Senior Member

    Joined:
    Nov 23, 2010
    Messages:
    15
    Likes Received:
    0
    There is no password protection in force.

    I can bypass the problem by copying the problem files to a USB flash drive and then copying them from the flash drive to my new Windows 7 PC but I don't want to have to do this every time I try to synchronise files between my two PCs over the network.

    David
     
  7. haggis999

    haggis999 Senior Member

    Joined:
    Nov 23, 2010
    Messages:
    15
    Likes Received:
    0
    I have now tried a 'push' synchronisation of files between my two PCs using exactly the same security configuration as for my previous attempts at a 'pull' process. This time it worked perfectly, with no errors or warnings.

    Can anyone explain why it works in one direction but not the other?

    David
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    On the surface it would appear that the username and password you are using on the source machine (XP) has more permissions to the files you are attempting to transfer than the username and password you are using on the destination machine (Win7) this can happen even if you are using the same username and password on both machines because of conflicting group memberships on either machine. Sometimes it might help if you remove any potential group conflicts from the user account and just maintain its' membership in the administrators local group on both machines.
    Other than that, because you keep referring to "synchronization" and because your original error referred to an API error, the problem may possibly be with the software you are using for file synchronization. It may simply work better when initialized on the source machine using a "put" rather than "get" scenario.
     
  9. haggis999

    haggis999 Senior Member

    Joined:
    Nov 23, 2010
    Messages:
    15
    Likes Received:
    0
    Both the use of a commercial synch program and attempts to do a simple file copy via Windows Explorer fail when run from the target machine. Both these processes work from the source machine.

    I am also seeking guidance from the tech support people for the synch software but the fact that it also fails with Windows Explorer suggests that it is a Windows security issue, not a problem with that program.

    David
     

Share This Page

Loading...