Administrator Permissions not working on Administator Account

Discussion in 'Windows 7 Help and Support' started by Chamenas, Sep 13, 2010.

  1. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    [SOLVED] Administrator Permissions not working on Administator Account

    Alright, so I did some looking through similar threads but couldn't find any with this exact issue. Hopefully this is not a repeat thread, I don't think it is.

    SOLUTION
    It turns out that some of the files in the folder were "locked" (a little padlock icon appeared over the normal icon). In order to unlock the folders, I only needed to double click and confirm I wanted to continue. To unlock the files I needed to do the following:
    Right+Click -> Properties -> Security -> Edit (Under Permissions Field) -> Add (Type in your Username) -> Ok

    The Main Issue:
    I'm unable to delete folders in my "Program Files", even as the Administrator (and in fact only account) account on my computer.

    Details:
    Here's what happens:
    1) I click on the folder, then hit delete.
    2) I get a pop up which asks if I want to delete the folder, I click Yes
    3) I get a pop-up which says "You'll need to provide administrator permission to delete this folder" I click Continue (with the little shield next to it)
    4) I get a pop-up which says "You need permission to perform this action" "You require permission from Administrators to make changes to this folder" <folder details" and I click Try Again but the pop-up just repeats.

    What I've Tried:
    1) I went back to the Local C: Directory and right-clicked on the Program Files folder, looking for a "Run As Administrator" option, but it wasn't there. So I clicked on properties.
    2) In properties I clicked on the "Security" tab, which listed the following as Groups or User Names:

    • CREATOR OWNER
    • SYSTEM
    • Administrators (BleaSD1\Administrators)
    • Users (BleaSD1\Users)
    • TrustedInstaller
    3) I clicked on "Users (BleaSD1\Users)" and clicked on "Advanced" for permissions, making BleaS2 (my account) the Owner. But that didn't work.
    4) I came to the forums and looked for similar threads, one of them mentioned opening Local User Manager in the System32 files. However, opening the lusrmgr.msc file opened a window which gave this error in the middle pane of the window (which had 3 panes) "This computer is running Windows 7 Home Premium. This snapin may not be used with this version of Windows. To manage user accounts for this computer, use the User Accounts tool in the Control Panel."

    Info:
    I'm using Windows 7 64-bit Home Premium
    My User Account is "BleaS2" I can't remember exactly why I made BleaS2, it had originally been BleaS, but I did have my reasons at the time (originally it was connected to a network at the college I attended, and there was an account on the network named BleaS for my laptop, I think that's why I changed it to that, but the install on the machine was for the User Account BleaS)
    Despite having the account BleaS2, there are, in fact, no other accounts on the computer. The account is set to an Administrator and password protected.

    What confuses me is that it doesn't give me the ability to give permissions as an Admin or to run the folder as an Administrator. Even though the account is an Administrator, I'm not able to act like one, even though I can give Administrator permissions in all sorts of other places (it's always asking me before I run various programs, etc... I haven't had problems with any installs that I know of).

    The folder I'm trying to delete specifically is a World of Warcraft Test Realm folder, so I can reinstall it. There is no uninstall in the Programs menu, to my knowledge, as the only uninstall in the menu is for the whole World of Warcraft program. Hopefully I'll be able to learn from this and gain a better understanding of the UAC in general. It's very frustrating to deal with at times, since I don't fully understand its workings and why it says I'm not an Admin at times when I am one, but I understand, at least, that the tight controls ensure that programs can't randomly install things behind my back, so I keep it up even if it frustrates at times.
     
    #1 Chamenas, Sep 13, 2010
    Last edited: Sep 14, 2010
  2. Agent Data

    Agent Data Banned

    Joined:
    Jan 9, 2010
    Messages:
    918
    Likes Received:
    42
    Yes, 7 seems to ignore when you are admin - it still requires to confirm with the admin password before doing something.

    Program Files is especially problematic if you are not the owner of the subfolder and even then when there is one single file in it you do not own you can not delete that folder. Call it security gone nuts!

    To me 7 security looks like an unfinished job - maybe SP1 brings some improvements?
     
  3. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Ya Think? Win7's security is a total nightmare, especially for programmers...

    The "program files" folder is protected territory. I suspect the only access to that folder is through the uninstall feature, and we all know how many uninstallers leave folders behind...

    Best bet, go into c:\ right click on Program Files then -> Properties -> Security -> Advanced -> Owner and give yourself ownership of the folder and all sub folders. You should then be able to manipulate them.

    However... I should note that you do this with an abundance of caution. Deleting active programs or folders will cause system problems. You should use the uninstaller (add remove programs dialog) whenever possible.
     
  4. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Would love to use an uninstaller, but, as mentioned, with this specific problem, the uninstaller would uninstall two programs, not just the one I want to uninstall, and I'm not keen on having to reinstall WoW plus all of its patches in addition to the PTR.

    I did make myself owner of the folder, but I'll try again and see if I can get it to work.
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Have you tried deleting the contents of the folder, then try then delete the folder itself?
     
  6. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Thanks Reghakr. I tried that and all but one folder deleted. The one folder gives the same message I got when trying to delete the whole folder, and, unfortunately, the whole folder needs to be deleted for it to be effective, however, I am somewhat closer now to maybe figuring this out.

    Edit: Further info:
    I tried restarting the computer, but, despite being an owner of the folder, I cannot remove the one stubborn sub folder. This folder is the "Interface" folder in the before mentioned World of Warcraft Public Test Realm folder. In it is the AddOns folder. I entered the AddOns folder and tried deleting all the AddOns. Three folders remained behind: Recount, SatrinaBuffFrame, SBFOptions, the last one is actually just an extension of the second. In any case, for those not familiar with WoW, the AddOns folder should, in theory, have some of the least restrictions on it, as it allows for the user to add or delete folders in order to add or delete AddOns they might want in it to affect their UI. Not being able to delete these folders is actually a bit more disturbing than not being able to delete the main folder in general as I'm supposed to be able to alter these folders in order to add or remove parts to my UI, and I cannot see any reason why any of these folders would deny my full Administrative account its Admin privileges for any reason.
     
    #6 Chamenas, Sep 13, 2010
    Last edited: Sep 13, 2010
  7. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Alright, interesting update:

    I examined the questionable folders and, upon entering them, found that all of their sub-folders and files had little "lock" icons on them. Double clicking on the folders asked for Administrative permission before entering, which I gave and then it went into the folder and the folder was unlocked so I could delete it.

    I'm unaware of how I might unlock the files.
     
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Could you tell us what program was installed there?
     
  9. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    The files belong to AddOns which are like plug-ins for the World of Warcraft program. The specific program I am trying to delete is the World of Warcraft public Test Realm, which is a similar, but different version of World of Warcraft which contains future patch data for testing on their own PTR servers. The Addons to which this belongs are the ones mentioned in the above post: Recount and Satrina Buff Frames
     
  10. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Thank you,

    Have you tried Safe Mode or by the command prompt after hitting F8 while starting Windows?
     
  11. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Hmm, I was told Windows 7 didn't have a safe mode. I will try that and get back to you.
     
  12. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Did you check for hidden files in these stubborn folders?
     
  13. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    I visited Safe Mode, but the files were still locked. I did figure out a way to unlock the files individually, and then delete them. Unfortunately, there are a LOT of files. If there's any way to unlock them on a non-individual level, that would be far more useful. Unfortunately, as you can see here, what I have to do is give permission to my user account to have full control over them, as none of the files have been given permission to access by any account. If I check their containing folder though, I have full permission to its contents, which means I can't change something (that I know of) in the folder to unlock all of the files in it. Selecting more than one file means that I no longer have access to the Security tab in Properties.

    The video below shows me accessing the folder and unlocking an individual file. I tried to show that some of the files have me as their owner but remain locked, unfortunately, those files now seem to have no owner and can thus be unlocked by the above steps so that point is irrelevant.

    Click on the img in order to link to the video
    [​IMG]
     
  14. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    I haven't, but it's most definitely these locked files that are causing the problem. I first noticed when reading the specific file names which were giving the permissions error. That's when I entered into the folders and found the locked files.
     
  15. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Well, I managed to unlock them all individually. I'll post the solution in the main post if I can, otherwise people will just have to look through the thread.

    Thanks for all the help guys!
     

Share This Page

Loading...