Aero not working


New Member
Hi, since I upgraded to windows 7 a while ago I could never get aero working. When I install my graphics card drivers aero turns on. The problem is when I enter into an application, for example a game, aero switches off. Also upon restarting my computer after installling the graphics card drivers aero switches off.
I've ran the windows experience test and all my components get 7.5 or 7.0 rating. Ive also gone into the troubleshooting in the personalize section and it can't find an explanation?
This really bugs me because I've only just upgraded my system and spent over £900 on components. If anyone can help me gets aero working it would be really appreciated. Thanks in advance.
my system is:

Intel Core i7 920 D0 Stepping (SLBEJ) 2.66Ghz (Nehalem) (Socket LGA1366)
Fitted with Titan cooler.
Gigabyte GA-EX58-UD5 Intel X58 (Socket 1366) PCI-Express DDR3 Motherboard
Asus ATI Radeon HD 4890 1GB GDDR5
Patriot Viper 6GB (3x2GB) DDR3 PC3-12800 (1600MHz) Low Latency Tri-Channel (PVT36G1600LLK)
OCZ ModXStream Pro 700w Silent SLI Ready ATX2 Modular Power Supply
LG GGC-H20L Blu-Ray Reader & HD-DVD ROM Serial ATA Drive
Western Digital Caviar Black 500GB SATA-II 32MB Cache
Samsung Spinpoint F3 1TB
Dell Ultrasharp 2407WFP A04

Troubleshoot problems with Windows Aero

This is normal behavior to have some games/3d applications turn off Aero. Also sometimes Aero switches off after you install a new video driver. As long as you can turn it back on, it's quite normal.

Does Aero get back on after you exit the game?


New Member
The only time I ever get Aero to work is when I first install my graphics card drivers. Immediatly after I restart my computer or enter a 3d application it turns off. I can never get Aero back on unless I completely reinstall my drivers, then the same thing happens again.

I suggest you run that diagnostic tool first. If it doesn't identify any problems, try the latest Catalyst+Driver. If it doesn't help either, try the drivers from your ATI support CD.


Reinstall drivers:

1. Uninstall ATI software and driver completely
2. Reboot
3. Install ATI software and driver
4. Reboot


New Member
Thanks for the replies. I've tried all of this though and nothing seems to work. The diagnostic tool finds nothing wrong, and the latest drivers don't seem to do anything either. However when I first install the driver, like I said before Aero seems to come on but then will deactivate after I enter a 3d application or restart my computer. I try the experience tests to get Aero back on but nothing seems to work. Its a shame, because the 3d interface is one of the main reasons why I bought windows 7.

Aero seems to come on but then will deactivate after I enter a 3d application or restart my computer.
Can you manually turn it on, is it available in Personalize ?

When Aero off, do you find dwm.exe running in task manager > processes ?

Can you list (or make a screenshot of) your start > regedit:

HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM ?


I suspect it's an upgrade issue, you may need to do a clean install of Vista > Activate Vista > Do not install anything on Vista > Upgrade to 7.


When Aero disabled, try cmd > net stop uxsms> Enter > net start uxsms > Enter.


New Member
Nope, for some reason I can only view the windows 7 basic settings.

Hi, yes the dwm.exe is running in the task menu. I did a clean install on a new hard drive, from previously using XP on a seperate hard drive. Is this the screen shot you wanted?


Yes, thank you for the screenshot. Is Composition Policy always 0 in your registry? If you set Composition Policy 2, does the same problem persist ?

Thanks for the reply, how can I see my Composition Policy in my registry?

Your screenshot shows that your Composition Policy is 0. So I wonder if you have this value = 0 all the time, or do you have it so only when Aero is disabled?

Windows Registry Editor Version 5.00

I suggest you copy this to your notepad, then save it as Aero.reg. Double-click Aero.reg, confirm and apply. Reboot your pc and see if the problem is gone.

Thanks, I tried saving that to notepad and ran the program and restarted my computer, and still no change. Here's a screen shot of the regedit:


Quite a puzzle. This is probably caused by the video card driver or by a plugin such as java.

Control Panel > Administraive > Services > Theme service, see if it's running, make sure its startup is set to Auto.


Could also be worth doing:

- check if there is any software running which may be causing this
- update software like java
- try a different video card driver

Comes to mind WEI score?

make sure you got a performance rating from W7 as this is the key to enable aero reliably provided the graphics score is high enough

Defiantly not a performance problem, my scores are:

Processor: 7.5
Memory: 7.8
Graphics: 6.0
Gaming Graphics: 6.0
Primary Hard Disk: 5.9

This is what I could find:

I've tried before rolling back to the drivers off my CD which came with my gfx card but no effect.

Defiantly not a performance problem, my scores are:

Processor: 7.5
Memory: 7.8
Graphics: 6.0
Gaming Graphics: 6.0
Primary Hard Disk: 5.9

Hmm, actually I have a 4850/1GB card here and it scores 7.4 - I wonder why your graphics score is so distinctly low for your card?

Should my card be scoring higher for a Asus ATI Radeon HD 4890 1GB GDDR5? At the end of the day can't aero run on a much lower scoring system?

The score is definitely too low!

Your graphics score should be well 7+ and what I read on the internet it's usually 7.5/6 for this card. Somehow you gotta problem here and that might translate into the difficulties you have.

Sure you got all 7 drivers updated and have all hardware drivers current?

do you overclock?

have a look into the performance log in the action center

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.