After update from this morning......

It appears that windows 7 had updates happening last night (8-12-2010) since when I woke up, I woke to a log in screen, and that normally means the computer was restarted.
I logged in with no issues, but then I noticed that my network cards were red Xed out in the task bar, which is strange since I never have seen it before.
I have a GB network across my house, my router is a GB router, and so are my switches.
My network ports are on a EVGA motherboard, which is a 780i series (EVGA nForce 780i SLI FTW to be exact), and there are two of them.
Both of them were red Xed out this morning.
After 30 min of troubleshooting, looking at my network on the notebook etc. I noticed that under the Device Manager the cards had a yellow ! point on both network cards.
When I opened the Device the error was "Device can not start Code 10", which is a very unhelpful and such a generic message.
At any rate, I decided just for the heck of it to Disable and Enable the device. And that got my network cards to work again.
Then I went to EVGAs website and downloaded the latest drivers and installed them.
It appears that had no affect on the problem, which is that each time I restart the PC the NICs are red Xed out and I have to manually do the Disable and Enable part.
All of this worked for months upon months (after installing Windows 7 Ultimate 64bit fresh right after it came out). This problem started after last nights system update.
And what even more strange is that it did not make a restore point for me, otherwise I would revert it to previous point.

At any rate, if anyone has any ideas, they are greatly appreciated.

I am running Windows 7 Ultimate 64bit
EVGA Motherboard
Core2Quad 2.83 CPU
8 GB of OC Ram (all same paired RAM)
Geforce GTX 275 video card with 197.45 drivers

Hello and welcome to the forums.

Have you tried a) system restore, and b) re-establishing your network ?


Noob Whisperer
Additionally you may want to check to see how your settings for updates are set for Device Installation.
Right click computer, choose properties.
EDIT: Added.... Select Advanced system settings.
Select the hardware tab at the top and click the Device Installation Settings button.
You may want to choose the radio button that says No, let me choose what to do
and then check the radio button that says Never install driver software from Windows Update
This may prevent this from happening in the future.
Also check device manager, expand network adapters, select and right click the problem adapter(s) choose properties, then select the driver tab at the top and see if you have the option to roll back the driver.
Just another thought for a possible option.

Last edited:
And people wonder why I disable Automatic Updates....

Best bet... system restore get it working... change updates to either manual install or disabled.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.