AMD Athalon 64 X2 Running on One Core

#1
I have a Dell C521 with AMD Athalon 64 X2 4600 processor. I loaded Windows Beta 7 32 bit and it won't recognize the second core processor. Any ideas? When I run Device Manager both processors are shown but I have run a number of CPU performance testers that show the second core with zero activity. I also ran Passmark Benchmark test and CPU performance seems to be about half what it should be. Notice the System Information summary below where it reports 1 processor.

OS Name Microsoft Windows 7 Ultimate
Version 6.1.7000 Build 7000
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DELLDESKTOP
System Manufacturer Dell Inc
System Model Dimension C521
System Type X86-based PC
Processor AMD Athlon(tm) 64 X2 Dual Core Processor 4600+, 2405 Mhz, 1 Core(s), 1 Logical Processor(s)
BIOS Version/Date Dell Inc 1.1.11, 8/2/2007
SMBIOS Version 2.4
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume3
Locale United States
Hardware Abstraction Layer Version = "6.1.7000.0"
User Name DELLDESKTOP\Steve
Time Zone Central Standard Time
Installed Physical Memory (RAM) 2.00 GB
Total Physical Memory 2.00 GB
Available Physical Memory 1.06 GB
Total Virtual Memory 4.29 GB
Available Virtual Memory 2.93 GB
Page File Space 2.29 GB
Page File C:\pagefile.sys
 


#2
Here is the answer I found on the MS TechNet forums, second post from the bottom:

TechNet Link

Or read here:

Run 'msconfig' with admin rights. Click on the 'Boot' tab. Click on the 'Advanced Options\" tab. Make sure \"Number of processors\" is unchecked (counter-intuitive, I know) and make sure a check mark is by \"Detect HAL\". I suspect the single CPU/core ACPI HAL is loaded when the multiCPU/core HAL should be loaded. If that doesn't make a difference after reboot, try forcing the number by specifying the number processors in the same area. I try to use that as a last resort because sometimes it can more harm than good.
I haven't tried this yet, but I will tonight when I get home.

UPDATE

I tried this at home last night and it worked. For me, all I had to do was check the "Detect HAL" box. I couldn't manually enter the number of processors. I would venture to guess that happens because I only have 1 processor - it just happens to be a quad core. I went from having a single processor detected in CPU-z and Task Manager along with sluggish performance to having all the cores appear and much better performance.

For example: when using Firefox on a flash heavy site along with Automatic Updates and OpenOffice, my CPU usage was hitting 90-100%. Now, it barely hits 20%. Sites like Ebaums, with its mess of flash ads that normally choke my system, was running all the flash at real-time speeds. A very noticeable improvement.
 


Last edited:
#3
Thank you sadosubliminal. I posted back in January and I too found this solution. I clicked on the Detect HAL check-box and Windows 7 detected the fact that I had two processors. Thanks for the post. I should have updated my question. What a pain it was to find the solution!
 


#4
Indeed, google search kept bringing up dead links and problems with nVidia cards. Took a lot of searching. Glad things worked out for you too.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top