Another ICS problem...

Discussion in 'Windows Vista Networking' started by tMrz, Aug 16, 2008.

  1. tMrz

    tMrz New Member

    Aug 16, 2008
    Likes Received:
    Hi, I'm having a desktop PC using XP Pro sp2 and a laptop with Vista Home Premium [32Bit]. They are connected by only a RJ-45 cable, means I'm not using any kind of router for networking. My problem is only internet sharing. Desktop PC with XP is my host and trying to share internet to my laptop. The thing is, I've read a loads of stuff about networking and until this time I've managed to see my both computers on network. I'm using an usb adsl modem named after Huawei SmartAX MT810. I'm sure of that opened the sharing of internet from the host but I'm not able to connect to internet somehow from my laptop :( What shall I do?
  2. superbill

    superbill New Member

    Feb 6, 2008
    Likes Received:
    Hi tMrz

    Have a look at the Microsoft take on Internet Connection Sharing see

    After you configure Internet Connection Sharing in Windows Vista, the network connection stops working after one-to-two hours -for Vista

    Troubleshooting Internet Connection Sharing in Windows XP - forXP

    If you get no joy from this, there is a work- round that can solve the problem in some cases. You might need to seek help to try.
    Networking different windows versions is very tricky

    Each OS adopts a slightly different method to networking; especially with the automation.

    The only real way to ensure that everything works fine, is to manually configure each setting to ensure that the OS doesn't assign anything automatically, which is usually where the problem resides.

    Follow this procedure to manually configure your network:

    1.] View Network Connections
    2.] Select the LAN network connection and open its properties.
    3.] Open the properties TCP/IP connection
    4.] Set the IP in this range: 192.168.0.? where ? = a valid integer between 1 and 255.
    5.] Keep the default setting for subnet mask.
    6.] Set your Gateway for the main computer and put its IP address in the Default Gateway value.
    7.] Put the IP address of the computer that is directly linked to the internet into the DNS server value

    Repeat all steps on other computers ensuring that you change the IP addresses value by 1 or 2 etc.

    Go to the advanced tab of the connection and enable ICS.

    Note: you cannot enable ICS if you have bridge the selected connection with another. Also you can't set up your computer as an ICS server if it's not connected to the Internet or to a LAN. It also doesn't work if another computer is already acting as the Internet gateway for the LAN, running a DHCP server, or is using the IP address
    One important thing was to disable DHCP in the router and to set its address to 192.168.0.x (x can be any number not already used. Also, to make it work, you had to turn off ICS in the host, re-boot the host, turn on ICS in the host, and then re-boot both the host and client. After that, the Icon for the shared connection showed up in the clent's network connections and everything worked.

Share This Page