Another"USB stopped working suddenly" Help please.

#1
Hi..firstly many apologies if this has been aired before..but Im really concerned..got a tosh c650 laptop and just tried putting a cruser blade 16gb stick into one of its 2 usb ports.Now both ports dont do anything .Tried deleting all drivere and re installing (inc safe mode) but no joy...Have I damaged the MB?
Any help greatly appreciated in advance.
Regards
Norm
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
I wouldn't think using such a device would ruin your USB ports, but there is always a possibility.

What drivers have you replaced, and what is showing in the Device Manager for USB with the unit plugged in or not?

Other items will not work either?
 


#3
I wouldn't think using such a device would ruin your USB ports, but there is always a possibility.

What drivers have you replaced, and what is showing in the Device Manager for USB with the unit plugged in or not?

Other items will not work either?
Hi Thanks for the reply..
The device manager shows the following..


It remains the same when I plug a device in...

What I did was to uninstall all the above and the W7 did an auto reinstall on boot up?
 


Attachments

Saltgrass

Excellent Member
Microsoft Community Contributor
#4
So other devices are not working?

If you plug in the USB drive, it will show up in another area. Do you get any messages when you plug it in? Do you know if it installs any of its own software?
 


#5
No whanever I plug anything in the device manager does not change ..I use a wireless mouse and thats not working also..
The PC used to make a sound to acknowledge a plugged in device..but no more!The USB ports are really "disconnected"/not recognised.
Thanks for response
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
I can't really think of anything to suggest to get it working. Perhaps there was some type of damage involved and probably a chipset situation on the motherboard as you suspected.

Not really sure how plugging in a flash drive would have done such damage, but I suppose static electricity is always a possibility. I would probably inspect the ports to make sure I didn't see any damage and then call the manufacturer or find some type of maintenance.
 


#7
Have dropped it off at local pc shop..The guy said he would look and tell me if it can be repaired..Will post results..
 


Joe S

Excellent Member
#8
Norm did you take that USB stick with the computer too? I wonder if there could be some problem with the stick itself.
Joe
 


#9
Joe..Immediately after having prob with tosh ..I plugged it into another lappy..no probs ...stick up and running????
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top