Apple Airport Extreme and Win 7

Discussion in 'Windows 7 Help and Support' started by TFlan, Nov 13, 2009.

  1. TFlan

    TFlan New Member

    Joined:
    Nov 13, 2009
    Messages:
    2
    Likes Received:
    0
    I just got a Win 7 machine. I have an Airport Extreme Router. I loaded the router software, loaded the latest updates from Apple, and Win 7 doesn't want to recognize the router. I'm using it only to connect to a remote printer. No ethernet and no internet connection. Only from this computer to the printer.

    So, are there any magic tricks to make this combo work? Thanks

    TFlan
     
  2. adejanon

    adejanon New Member

    Joined:
    Mar 28, 2010
    Messages:
    2
    Likes Received:
    0
    I have the same problem, any suggestions from anyone?
     
  3. DJ67

    DJ67 New Member

    Joined:
    Dec 21, 2010
    Messages:
    14
    Likes Received:
    0
    I have bought a new Dell XPS laptop with Windows 7. My son was using an Airport Extreme with his Macbook Pro, but he is now in Canada and has left the Airport here for me. I am going to try to hook it up tonight.
    Wish me luck!
     
  4. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
  5. DJ67

    DJ67 New Member

    Joined:
    Dec 21, 2010
    Messages:
    14
    Likes Received:
    0
    Zvit, thanks for your kind offer. After several hours spent trying to set up the Airport Extreme, I finally succeeded! I checked many requests and responses in Windows7Forums regarding the issue, as well as references in Apple Support. The Airport managed to find a connection when wired to my Netgear router, as well as when wired to my new Dell XPS laptop, but no wireless connection could be found. The Airport Utility was not much help either. It found the Airport when wired to it, and I was able to do a factory reset and then go through the set up procedures as instructed by the Airport Utility. When it came to making a wireless connection, however, The Airport Utility kept saying it could not find the Airport! I spent further frustrating hours searching for a solution.
    I decided to rule out anything internal, so I went to my Control Panel (Windows 7 Home Premium), and checked potential sources. I looked at Hardware & Sound/View Devices and also Add Device. I wired the Airport to my Dell, added it, disconnected the cable and then tried Network & Internet/View Network Status to see if it showed. Hey presto, there it was! Marvellous! Green light showing on the Airport, even when wireless, thus "proving" the connection. I then went back to Airport Utility, and it once more refused to “see” the Airport. Since I knew it was actually connected, I disregarded the Airport Utility and simply tried opening Firefox/Google and made a wireless internet connection no problem.

    I tried opening Airport Utility again just now, 1 day later, and Airport Utility has “found” the Airport and says I have a wireless network. Well I am surprised!
    The moral of the story is that there is sometimes a simple solution that no-one has encountered before. Also, do not give up, there must be a solution, even if you haven’t found it yet!
     
  6. Kevins Toshiba

    Kevins Toshiba New Member

    Joined:
    Nov 19, 2011
    Messages:
    2
    Likes Received:
    0
    TFlan

    I have just worked through this issue on my Toshiba M300 after updating with clean install from Vista to Windows 7. Nothing doing when trying to connect to my existing Airport Extreme network wirelessly which worked a dream with Vista. I loaded the Airport Utility on the PC and still it wouldn't connect. I eventually turned the Wireless Security off on the iMac and reset Airport. Then the PC would log on. Not a good outcome not having the WPA/WPA2 Personal security, which the PC wouldn't accept. I used the PC installed Airport Utility to manually set up the connection to the network and added the correct WPA/WPA2 Personal Security and reset the iMac, PC and Airport. All works well now. I went through the stages of the PC Network Centre stuff with no result, except with Wireless security turned off. Working with the Airport Utility all worked.

    Hope this is a help.
     

Share This Page

Loading...