AR9285 Wireless Network Adapter Lag

#1
I am hoping that someone else may have run into this problem and found a solution. I have a AR9285 Wireless Network Adapter installed in my Asus Eee PC. Whenever I wake up the computer from hibernate or sleep, the wireless adapter takes a full minute or more before it will actually connect to a network. Once it is awake and connected, I have no issues, and I have no problems connecting to different networks. So it is working as intended most of the time. When starting up the computer from "off," it is usually fine as well, since the amount of time it takes to fully start up the computer is usually about enough time for the adapter to get going (though not always).

It is not a huge problem, simply more of an inconvenience, since I cannot ever "quickly" look something up on the computer, as I have to wait a few minutes in order to be connected to the internet. Has anyone had or heard of this problem? I checked and the driver is up to date. I also tried to roll it back, and that did not solve the problem either.
 


Captain Jack

Extraordinary Member
#2
I think it's normal depending upon the Network card and Router. Because the computer will be the same state which it's supposed to be, but it disconnects the network adapter when you put the Laptop to sleep. My take around 30 seconds. Few things you can try,

Try to update your Routers Firmware
Try to update/reinstall the Wireless card drivers
Connect using a LAN cable and see if take the same amount of time
Reboot in Selective Startup Run Selective Startup using System Configuration

Report us back with the results.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.