Arduino - Com port - errors

Discussion in 'Windows 7 Help and Support' started by mlomanno, Mar 15, 2013.

  1. mlomanno

    mlomanno New Member

    Joined:
    Mar 15, 2013
    Messages:
    8
    Likes Received:
    0
    Hello all,

    I have been using an arduino ethernet for a few days and everything worked well. While uploading a sketch (arduino code) i received an error stating that the arduino was no longer connected to COM 4. I opened up the device manager, the arduino wasn't connected was there even though there was a USB connecting the arduino to the computer. Confused, I unplugged and replugged the USB cable to the arduino. The arduino showed up under COM and LPT devices. However, there was not a COM port associated with it (instead of "Arduino (COM 4)" it just stated "Arduino"). I tried manually setting one (Properties -> Port Settings -> advanced), but every time I click the okay button under advanced settings to make the arduino COM 4 (which is not being used by other programs), I get a windows error stating "Microsoft Management Console has stopped working", and nothing gets changed.

    I've been trying to Google my problem, but searching COM port leads to TCP/IP port settings (even with "" marks around COM port) and I can't find anything.

    I have also tried uninstalling the drivers and re installing with the latest drivers. The device manager states that everything is working fine and the "This device is working properly".

    I searched on this site and found this post (http://windows7forums.com/windows-7-hardware/55376-serial-port-problem-cant-see-assignments.html). It is related but not exactly what I am looking for. Plus, the arduino is visible, it just doesn't have a COM port assigned

    Can someone please help me get my arduino communicating with windows again?

    Thanks,
    Matt
     
  2. mlomanno

    mlomanno New Member

    Joined:
    Mar 15, 2013
    Messages:
    8
    Likes Received:
    0
    Update:
    I have still been trying to fix this issue. I went to the event logger and found this error when trying to manually change the COM port of the arduino.

    Faulting application name: mmc.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc3f1
    Faulting module name: MsPorts.dll, version: 6.1.7600.16385, time stamp: 0x4a5bc616
    Exception code: 0xc0000005
    Fault offset: 0x00006e87
    Faulting process id: 0x12d8
    Faulting application start time: 0x01ce24bc8918ccbc
    Faulting application path: C:\Windows\system32\mmc.exe
    Faulting module path: C:\Windows\system32\MsPorts.dll
    Report Id: b53029e2-90b9-11e2-8f55-90fba6e581b8

    Maybe its a registry thing? I know when I updated the arduino from 1.0.3 to 1.0.4 drivers, Windows would recognize that the arduino.exe file located in the 1.0.4 folder was there. Meaning, windows no longer associated the .ino file (Arduino project) with the IDE. I had to go into the registry and manually change the path location to the new 1.0.4 folder. This fixed the arduino .ino file problem.
     
  3. mlomanno

    mlomanno New Member

    Joined:
    Mar 15, 2013
    Messages:
    8
    Likes Received:
    0
    Update:

    I found out that the Exceptiom code 0xc000005 is a memory access violation error. I'm assuming the MsPorts.dll is messed up. However, I have tried "scf /scannow" command but it says everything is fine.

    Does anyone know what the fault offset 0x00006e87 means? Like i said, I believe my problem is the MsPorts.dll


    Matt
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, since no one else has responded, I might ask a couple of questions. But I have no experience with your situation concerning that software.

    But the message says the mmc.exe, msports.dll is where the error is occurring. When I open the console, there are no snap-ins listed. Have you or the software added some?

    I will assume the software is Windows 7 compatible, or you are running it in some type of compatibility mode? Considered reinstalling the software, and possibly removing it first?

    Have you heard about SysInternals, a Microsoft component, and a utility called Process Explorer? Using the utility in combination possibly with some of the others, you might be able to track down your problem. For instance, Process Monitor watches your system and will give you a log on what is happening. When the problem occurs, it might point you to a registry location or some other culprit.

    But good luck, and I hope you get it straightened out.
     
  5. mlomanno

    mlomanno New Member

    Joined:
    Mar 15, 2013
    Messages:
    8
    Likes Received:
    0
    Thanks for the response.

    1) I also do not see any snap ins added to mmc.exe. To my knowledge, there has been nothing added to it.

    2) The software is Win7 32 bit compatible. Many Arduino users run their software on Win7, looks like I'm just the 1 in 1000000. I've tried uninstalling and reinstalling everything and have had no luck.

    3) I have never heard of SysInternals. I took a quick look and it seems to monitors all you computer's actions at all time. Is this a correct guess?

    Thanks,
    Matt
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    SysInternals has several utilities in its Suite that can be used to monitor your system, if you need.

    Process Explorer and be started to see what is running. Process Monitor can be started and stopped when you want to capture computer activity for a specific event.

    The site has tutorials and example scenarios for the different utilities. If you were to start Process Monitor just before you got the error, it would show what had happened and what had been accessed, such as registry or file locations.

    Anyway, check into it if you like.
     

Share This Page

Loading...