Attempting Windows 7 install in multiboot system

Discussion in 'Windows 7 Installation' started by paulfxh, Jan 11, 2009.

  1. paulfxh

    paulfxh New Member

    Joined:
    Jan 11, 2009
    Messages:
    12
    Likes Received:
    0
    I downloaded the Windows 7 Build 7000 Beta today with the product key and I'm trying to install it on a Dell E520 desktop.
    Just to complicate matters, this machine already has Windows XP (installed on a primary partition) and Ubuntu Linux (installed on an extended partition).
    I created a 75 GB primary partition for Windows 7 formatted to ntfs.
    When the Windows 7 installer asks me where to install Windows 7, I point it to the empty Disk0 Partition 2 (WinXP is on Disk0 Partition 1).
    However, when I press Next expecting this long-awaited install to go ahead, I get this message:
    ...........and that's as far as I can get with this. :confused:
    I should mention that I'm using Grub (Linux) as my bootloader in this dual-boot system and Grub rather than the Windows bootloader is in the MBR. Grub boots Windows XP by chainloading the WinXP bootloader.
    Any clues how I can overcome this?
     
  2. de Silentio

    de Silentio New Member

    Joined:
    Jan 11, 2009
    Messages:
    40
    Likes Received:
    2
    You could try making the Win7 partition unallocated space before doing the install, that is what I did when I installed my dual boot with Vista. Granted I am not messing with Linux or anything.

    My guess is, though, you are having a conflict with Win7 finding the MBR. This is a fairly uneducated guess however.

    Just a thought.
     
  3. paulfxh

    paulfxh New Member

    Joined:
    Jan 11, 2009
    Messages:
    12
    Likes Received:
    0
    Thanks for the reply.
    During the attempted install, after I first got the error message, I did actually delete the 75 GB partition I had assigned to Windows 7 which made an unallocated space. I then created a new partition and formatted it to ntfs using the Windows 7 installer.
    However, I still get the same error message which stops everything in its tracks.
    You also say
    I believe this is extremely unlikely as the error message I get occurs about 3-4 seconds after initiating the install. However, were it actually true that because Windows 7 saw Grub in the MBR and therefore refused to create the new System Partition (which I understand I don't even need), I can very easily use fixmbr to put ntldr back to the MBR until Windows 7 is installed and then re-install Grub.
    However, before trying this it would be great if you or anybody else can confirm that this is a real possibility.
     
  4. de Silentio

    de Silentio New Member

    Joined:
    Jan 11, 2009
    Messages:
    40
    Likes Received:
    2
    I see. I would suspect that if you can install Vista on that partition in the same way you are trying to install Win7, then Win7 should work. However, if Vista cannot be installed the same way, then you probably have an issue with the Grub setup. An easy thing to try if you have a Vista disc sitting around.

    After you reply, it doesn't seem like an MBR thing. Since it involves Linux, it is a little beyond me.
     
  5. crazy_cjenkins

    crazy_cjenkins New Member

    Joined:
    Jan 11, 2009
    Messages:
    68
    Likes Received:
    5
    With all my dual and tri boot systems I have always have installed windows first then Ubuntu last. The reasoning behind this is sometimes the windows installer will completely skip over the Ubuntu partition, even thought it sees the partion it doesn't recognize it as bootable. Another reason is window likes to be the fist primary partion on the disk and somtimes won't install if it's not. Also its a good Idea to put ubuntu on a primary parition and then it's swap on an extended partion. I think your main problem is the installer is looking for a Primary partion at the begining of the disk, It can't find it therefore It gives you that error. I guarentee If you use partion magic or If you can boot back into xp and use disk management to make the windows 7 partion at the beginning it will install no problem. Just speaking from experience.:cool:
     
  6. paulfxh

    paulfxh New Member

    Joined:
    Jan 11, 2009
    Messages:
    12
    Likes Received:
    0
    @crazy_cjenkins
    Thanks for your thoughts.
    Actually, I'm not worried about the Windows 7 bootloader seeing Ubuntu or not as, once I get Windows 7 installed, I'm going to go back to Grub as my "universal" bootloader and boot everything, including XP and Windows 7 with that.
    Your idea to put Windows 7 at the very start of the disk sounds good. I'm going to repartition my driver overnight to arrange it like this. So, I'll see if this works tomorrow.
    Nevertheless, in the Windows notes for installation of Windows 7, they talk about installing W7 as part of a multiboot system and even installing to a logical partition and I never saw any mention of W7 having to be installed to the very first partition on the disk.
    Anyway, only one way to find out. :)
     
  7. crazy_cjenkins

    crazy_cjenkins New Member

    Joined:
    Jan 11, 2009
    Messages:
    68
    Likes Received:
    5
    Ya Grub is all I use it's a lot better than widows and I haven't played too much with LILO. I'm not sure what the documentation says but I Know that is what has always fixed that issue for me. Good luck!:D
     
  8. paulfxh

    paulfxh New Member

    Joined:
    Jan 11, 2009
    Messages:
    12
    Likes Received:
    0
    Well, installing W7 on the first partition (primary) didn't make any difference. Still got the same error message. :frown:
    So, the only thing left was some kind of incompatibility with Grub. I tried "fixmbr" (after booting to the WinXP install disk and choosing Repair) but nothing changed.
    Next I tried the following:
    Code:
    C:\WINDOWS 
    CD .. 
    FIXBOOT C: 
    FIXMBR 
    BOOTCFG /rebuild
    However, even after this the Grub menu still showed up on boot and W7 still wouldn't install for the same reason.
    The computer I was using is a spare computer with nothing of importance on it. So, I used Parted Magic to completely delete all partitions. But, even with this, W7 install still gave the same error.
    Strangely, when I booted without a CD/DVD in the drive and nothing at all on the HDD, not even a partition, I still got some comments about Grub stage 1.5 and Grub stage 2.
    So, it seemed that Grub stage 1 was still in the MBR.
    OK, nothing for it now but to use
    Code:
    dd if=/dev/zero of=/dev/sda bs=512 count=1
    to completely remove Grub from the mbr.
    And finally, W7 installed :)
    Seems that W7 has some aversion to Grub :rolleyes: However, it's going to have to get used to it as I'm going to re-install both Ubuntu and Windows XP and use Grub (from Ubuntu) in the MBR.
     
  9. paulfxh

    paulfxh New Member

    Joined:
    Jan 11, 2009
    Messages:
    12
    Likes Received:
    0
    Just an update to what I wrote in my last post.
    I blogged about my success in getting W7 installed and mentioned about the problems I had. Somebody kindly commented that they had exactly the same problem and overcame it by unplugging an external usb HDD.
    Now, as it happens, I have a 500 GB usb HDD on my computer which I also had unplugged (basically to prevent a large number of partitions showing up during the W7 install).
    So, maybe it was this rather than the Grub uninstall that allowed me to get W7 on my computer.
    Now, while I was setting up my multi-boot (Ubuntu, XP, W7 and Grub), I had to re-install W7 while Grub was in the MBR (but Ext HDD still unplugged).
    This time W7 installed without any problem.
    The evidence therefore suggests that the true reason for my problem was having the USB HDD plugged in. Well, I never would have guessed this would cause such an error. :eek:
    In any event, I now have a pretty nice multi-boot setup. :D
    As for W7, for a Linux user I'm reasonably impressed. However, I doubt if it has sufficient novelties to draw me away from Linux.
     
  10. Phaeton

    Phaeton New Member

    Joined:
    Jan 13, 2009
    Messages:
    2
    Likes Received:
    0
    USB external HDD

    I thought I had found here the solution of my problem. I'm trying to install w7 on my computer which has Ubunto 8.10 already installed.
    I have the same problem than you:
    I noticed that my USB external HD was plugged during my install attempts, so I tried another time with this HDD unplugged. But I still get the same error message.
    I tried to create the NTFS partition with gparted, but also to leave an unallocated space. Both methods lead to the same point.
    I don't feel like moving my partitions to allow W7 to install on the primary partition, and since I only have one HDD (of 1 TB), I'm stucked. Any idea?

    edit: my compuer is a Quad core 9300, 4GB DDR2, 1TB HD, with Ubuntu 8.10 and Grub.
     
    #10 Phaeton, Jan 13, 2009
    Last edited: Jan 13, 2009
  11. paulfxh

    paulfxh New Member

    Joined:
    Jan 11, 2009
    Messages:
    12
    Likes Received:
    0
    Yeah, that error is a real pain as it is soooo persistent! Also, it doesn't seem to give any clue as to how to resolve it.
    I'm really not a Windows user at all so I'm not sure if I can really help. However, a few things come to mind:
    When you said
    were you really saying that you are trying to install W7 on a logical partition? Although that shouldn't give rise to the error you got, I don't believe that Windows OSes will readily boot from a logical partition so this may not be a good idea even if you manage to get it to install.
    OTOH, perhaps you meant the FIRST partition? Personally, after this brief experience I don't believe you need W7 to go onto the first partition.
    However, were you aware that when you install W7 another small "system" partition is created? (See here). This is only 200 MB but as you can only have a maximum of four primary partitions, this might create problems. So, if in your Ubuntu install you have partitions for Ubuntu root, home and something else (IDK, maybe boot or something), then you no longer have enough available primary partitions for W7 to install.
    If you're not sure about this, you can post your partition table and I can maybe comment.
     
  12. satauros

    satauros New Member

    Joined:
    Feb 19, 2009
    Messages:
    2
    Likes Received:
    0
    Solution

    Disconnect ALL other hard drives! Worked for me doing the exact same thing.
     

Share This Page

Loading...