Autoplay - LG SATA Super Multi

DirtRider

Well-Known Member
#1
Win7 Pro 32 bit

For some reason I am unable to get my Autoplay to function on my LG SATA Super Multi DVD drive. I have tried various setting but feel that maybe I have missed something. I have attached a screen shot of my Autoplay settings. I have also tried specifying what must open for each disk but this also did not seem to work
 


Attachments

zvit

Honorable Member
#2
First, you can try Microsoft's Fix:
Download details: Autoplay Repair Wizard


There are several reasons for this problem. AutoPlay might be restricted by Group Policy, it could be canceled by a program that is running, or the service that AutoPlay needs to start might not be running.
Here are some things to try:

  • Ask your network administrator if AutoPlay is restricted by Group Policy, and if so, what to do instead.
  • Close other programs that might be interfering.
  • Follow these steps:
    • Click the Start button
      , click All Programs, click Accessories, and then right-click Command Prompt.
    • Click Run as administrator.
    • At the command prompt, type net start shellhwdetection, and then press ENTER.
    • Restart your computer.
    Troubleshoot AutoPlay problems
Other thing you may check:

1. Go to Control Panel/Administrative Tools/Services/Shell Hardware Detection - Return this service to Automatic.

2. Check out the following registry key: HKLM\SYSTEM\CurrentControlSet\Services\Cdrom The value for "Autorun" needs to be dword: 1... .

3. Check out registry key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveAutoRun if it's set to 255 that means disable all. Set it to 145 (decimal), log off and back onto windows, and AutoPlay should work again.

4. For some, autoplay quit working after installing VMware Workstation, If you have this installed, try uninstalling it.

5. Some more solutions: AutoPlay/AutoRun Not Working or Missing Not Open in Windows Vista

Tell us how it went.
 


DirtRider

Well-Known Member
#3
Thanks for such a detailed reply, this is what I got

First, you can try Microsoft's Fix:
Download details: Autoplay Repair Wizard
Downloaded the fix ran it and when I cam to the select drive once I selected teh CD drive the program stopped working

  • Click the Start button
    , click All Programs, click Accessories, and then right-click Command Prompt.
  • Click Run as administrator.
  • At the command prompt, type net start shellhwdetection, and then press ENTER.
  • Restart your computer.
This is my home PC so it is not on a network as to say. Any way tried this and got back "the service name is invalid"

Other thing you may check:

1. Go to Control Panel/Administrative Tools/Services/Shell Hardware Detection - Return this service to Automatic.

2. Check out the following registry key: HKLM\SYSTEM\CurrentControlSet\Services\Cdrom The value for "Autorun" needs to be dword: 1... .

3. Check out registry key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\Policies\Explorer\NoDriveAutoRun if it's set to 255 that means disable all. Set it to 145 (decimal), log off and back onto windows, and AutoPlay should work again.
Did a search in my registry for both strings and found nothing like this

Had a look in my services and the "Shell Hardware Detection" is running.

My IDE CD Rom used to Autorun however now I cannot remember if this was on Win 7 or My Vista setup
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Do you have any other software that uses the DVD drive like Nero or something similar?

There is a AutoplayHandlers entry in the registry that has a DisableAutoplay entry in the right pane. You might check that to make sure it is 0x00000000 and not 1. Search for DisableAutoplay in the HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer. I am not suggesting you change it.

Does the drive show up normally during boot and in the Computer window in Win 7?

Things I might try.
Click the Reset Default button on the bottom of the AutoPlay options. Reboot
Uncheck the Use Autoplay for all media option and reboot. Recheck the option and reboot.
Uninstall the DVD in Device Manager and let Windows find it again.
 


DirtRider

Well-Known Member
#5
I don't have Nero installed. I do have a card reader but I cannot see that being the problem. Other stuff that may be an issue but I have always had it working and Autoplay did run on Vista.

Daemon Tools (It is not set to load on startup)
Corel Paint Shop Pro Photo X2 - Now this does give me an error (see attached) when I open the DVD drive but it has always done this. I did enquire about this some time back and I was told it is normal. I cannot remember the whole story now. Also had it running before

There is a AutoplayHandlers entry in the registry that has a DisableAutoplay entry in the right pane. You might check that to make sure it is 0x00000000 and not 1.
Checked this and it is set to 0x00000000, did not change it :p

Update

I turned off the CorelIOMonitor.exe and restarted so now I don't have the error when I eject the disk but Autoplay still does not work
 


Attachments

Last edited:

zvit

Honorable Member
#6
Try to manually input settings instead of choosing "use autoplay for all media":
How to Configure AutoPlay Settings in Windows 7 - Windows 7

Are you running in administrator account? If not, inf files will not automatically run because they are considered system files


Check if the Group Policy Setting has been disabled for the Autoplay feature.

Note: Changing Group Policy Setting applies to only Windows 7 Ultimate and Windows Enterprise editions.

1. Click Start and in the Search box, type gpedit.msc and press Enter.
Now browse to Computer Configuration\ Administrative Templates\ Windows Components\ Autoplay Policies\ Turn off Autoplay.

2. To Enable:
Change the value of Turn off Autoplay to Disabled.

Note: This will enable the Autoplay feature.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#7
It looks like if you hold down the Shift key when you insert a disc, the autoplay feature should work regardless of default settings, so you might try that.

If you can't find a reason for Autoplay not working, I would have to suspect the Daemon Tools. I have not been able to find any reference to such a thing, but it might be related. I also saw that uninstalling the software does not always remove the virtual drives, so you may want to check how to remove all of it if you decide to try. Just for the heck of it, if you mount an image with a virtual drive, does it autoplay?
 


#8
Ok, this is going to sound a little off the wall... but I've seen this before; quite a few times, in fact.

Look in device manager at your DVD drive... is it a GH22NS50 model?

If so, did you by chance install the update from the CD-ROM that came with it?
The update on the disk is a VIRUS. (a fired employee's parting gift)

This is easy to check...
With no disk in the drive click on the drive's icon in Computer .
Instead of the window asking you to insert a disk you will get an explorer window showing a couple of files...
Among them "Bluebird.exe"...
YES, even with no disk in the drive.

There were a whole whack of these drives sold with the buggered CD-ROMS (thousands of them).
If you have this going on, you will need to replace the drive... I like Pioneer drives, fwiw.

Then, I'm betting autoplay will work as well.
 


DirtRider

Well-Known Member
#9
Try to manually input settings instead of choosing "use autoplay for all media":
How to Configure AutoPlay Settings in Windows 7 - Windows 7

Are you running in administrator account? If not, inf files will not automatically run because they are considered system files


Check if the Group Policy Setting has been disabled for the Autoplay feature.

Note: Changing Group Policy Setting applies to only Windows 7 Ultimate and Windows Enterprise editions.
Yes I am running in Admin mode but I have Win7 Pro so the Group Policy would not apply to me.

It looks like if you hold down the Shift key when you insert a disc, the autoplay feature should work regardless of default settings, so you might try that.

If you can't find a reason for Autoplay not working, I would have to suspect the Daemon Tools. I have not been able to find any reference to such a thing, but it might be related. I also saw that uninstalling the software does not always remove the virtual drives, so you may want to check how to remove all of it if you decide to try. Just for the heck of it, if you mount an image with a virtual drive, does it autoplay?
Tried the shift option but it did nothing on my side. I have always used Daemon Tools and it did work on my old drive (Not sure if this was W7 or Vista). I did however disable it but I suppose that is not really the same. Also tried mounting an image also no autoplay

Ok, this is going to sound a little off the wall... but I've seen this before; quite a few times, in fact.

Look in device manager at your DVD drive... is it a GH22NS50 model?
I checked this and I have the GH22NS20 model
 


Last edited:

DirtRider

Well-Known Member
#10
Update to above

Ok I uninstalled deamon Tool as well using Absolute Uninstaller as it is supposed to be very good and remove all of the install. This also has not changed the situation at all. Just one other thing I have just noticed I have two CD showing up. First time I have noticed this and am not sure if this is correct or is relevant to my problem at all
 


Attachments

#11
Ok, one more suggestion, then I'll let the others get on with helping you...

Assuming you don't actually have two optical drives...

Open Control Panel -> Device Manager -> CD-Rom drives

Right click on each of the drives in turn and <b>uninstall</b> them.

Once both are uninstalled, reboot your system and let it re-install the drivers.
(This is a clever way to get your defaults back with clean driver installs).

Once the drive shows up in Device Manager again, open Control Panel -> Autoplay
and run through the settings there.

If it doesn't work after that --unless someone has a far better suggestion-- you may
have to replace the drive.
 


#12
Ok... one last suggestion....

LG Product Support for GH22NS50

There is a Bluebirds removal tool there plus a new firmware that supports win 7....

As always, exercise great caution when installing firmware (or BIOS) updates. An update gone wrong
can render your device or computer useless.

Once you have this done...
Go to Control Panel -> Device manager -> CD-Rom drives
Right click on each drive and uninstall them all.
Now reboot your computer and let win7 reinstall the drivers for you.

That should leave you with just the one drive (assuming you only have 1 drive).

Now go to Control Panel -> Auto Play and run through the settings there.

If that doesn't work, you may have to replace the drive.
 


Last edited:

DirtRider

Well-Known Member
#13
I think this maybe my issue. In the registry I should have the following apparently

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer Here you will find a key called "NoDriveTypeAutoRun" and probably set to 255 and this should be change this to 145.

The thing is I did not find this in my one but when I did a search on NoDriveTypeAutoRun I found **del.NoDriveTypeAutoRun so I can only think it was deleted by the looks of it. Now the thing is I am not sure how to fix this. Should I just rename it and change the value or does it not work like this in the registry

Ok, one more suggestion, then I'll let the others get on with helping you...

Assuming you don't actually have two optical drives...

Open Control Panel -> Device Manager -> CD-Rom drives

Right click on each of the drives in turn and <b>uninstall</b> them.

Once both are uninstalled, reboot your system and let it re-install the drivers.
(This is a clever way to get your defaults back with clean driver installs).

Once the drive shows up in Device Manager again, open Control Panel -> Autoplay
and run through the settings there.

If it doesn't work after that --unless someone has a far better suggestion-- you may
have to replace the drive.
I had already tried this with no results

Ok... one last suggestion....

LG Product Support for GH22NS50

There is a Bluebirds removal tool there plus a new firmware that supports win 7....

As always, exercise great caution when installing firmware (or BIOS) updates. An update gone wrong
can render your device or computer useless.

Once you have this done...
Go to Control Panel -> Device manager -> CD-Rom drives
Right click on each drive and uninstall them all.
Now reboot your computer and let win7 reinstall the drivers for you.

That should leave you with just the one drive (assuming you only have 1 drive).

Now go to Control Panel -> Auto Play and run through the settings there.

If that doesn't work, you may have to replace the drive.
This one does not seem to recognize my drive. This is also a new drive I just replaced and it did this from day one
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#14
I would like to try to duplicate your situation with a Super Multi IDE drive. What version of Daemon Tools did you install, and did you install any other software for the drive?

Did you find out what the BD designation on your drive means? Are you using the Securdisc option?

I do not show a key such are you reference in either of my Win 7 installs.
 


#15
Dirt Rider... sorry about the double posting, earlier... I'm still getting used to this BBS.
 


DirtRider

Well-Known Member
#16
I would like to try to duplicate your situation with a Super Multi IDE drive. What version of Daemon Tools did you install, and did you install any other software for the drive?

Did you find out what the BD designation on your drive means? Are you using the Securdisc option?

I do not show a key such are you reference in either of my Win 7 installs.
I was using DAEMON Tools Lite 4.35.6 Downloads :: DAEMON-Tools.cc but I have not installed it again. No still don't know what the BD is all about it just reappeared again once I installed the drive. I also could not really find any drivers for my drive on the net either :(
 


Last edited:

DirtRider

Well-Known Member
#17
Finally I have it working, load the attached registry fix :razz: :razz:
 


Attachments

zvit

Honorable Member
#18
The registry fix has the exact fix I posted in one of my first replies. You replied there that you couldn't find the registry key, but if the fix fixed it, that means you DID have those registry keys but just weren't able to find them. Glad it worked out though.
 


DirtRider

Well-Known Member
#19
I did a search on all those keys and found nothing only that one that seemed to be deleted. I wonder why that was or what caused this. Boy I am also glad it worked as I have been trying everything I could find on the net :razz: Thanks a TON for all your help with this one
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#20
Just a little more info in case it might help later. I installed Daemon Tools and made note of some changes. The AutoPlay function continued to work after the install and a reboot. I cannot, however, duplicate the SecureDisc (Nero application) your DVD drive seems to be capable of.

I did see some additional registry entries in the Policies\Explorer key which were not there before.

I do not know what the Registry Autofix does, so I cannot comment on that.

I did see the addition of a BD-ROM as seen in the attachment, as well as another CD Drive and Storage controller seen in Device Management.

Glad to see a registry fix did restore the AutoPlay.

Edit: I do now see what the Registry Fix does and it applies to 5 registry entries, which have been mentioned previously.
 


Attachments

Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.