Backspace works ONLY in administrator user!

Discussion in 'Windows 7 Help and Support' started by rainbringer, Mar 26, 2012.

  1. rainbringer

    rainbringer New Member

    Joined:
    Jun 6, 2009
    Messages:
    20
    Likes Received:
    0
    Hi,


    I have a very weird problem: my backspace key works in a program only if it ran as administrator! It has started suddenly, don't remember any changes I'd done before that, including widows update.
    I've Windows 7 x64, MS Curve 2000 keyboard.


    Any help will be appreciated!
    Thanks!
     
  2. rainbringer

    rainbringer New Member

    Joined:
    Jun 6, 2009
    Messages:
    20
    Likes Received:
    0
    Anyone?!
    I'll accept any crazy suggestion, since the problem itself is crazy at all.
     
  3. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    Did you have to load a driver for the KB? Maybe it's corrupted or a new version of the drive caused the problem.

    Grabbing at straws here.
     
  4. rainbringer

    rainbringer New Member

    Joined:
    Jun 6, 2009
    Messages:
    20
    Likes Received:
    0
    I have news:
    backspace works in any other account except mine. I've created a temporary account (standard user) and the key works there. Hence, some application/update has screwed keys definitions/bindings in my windows profile.
    Is there any way to fix that, to restore keyboard default definitions? Can keyboard profile (if there is such a thing) be imported from a different account?
    Again, uninstalling/re-installing drivers doesn't fix this issue.

    Thanks!
     
  5. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    Not sure about copying a profile.
    How about creating a adminuser for yourself and then deleating the one that does not work.
    Wait awhile before you do this maybe someone more knowledgable can provide a better solution.
     
  6. rainbringer

    rainbringer New Member

    Joined:
    Jun 6, 2009
    Messages:
    20
    Likes Received:
    0
    Yeah, I guess I'll do that if a simplier solution won't be found.
    Thanks
     
  7. rainbringer

    rainbringer New Member

    Joined:
    Jun 6, 2009
    Messages:
    20
    Likes Received:
    0
    Solved.
    At first, I've found out that the key works in all other users, except mine.
    Then, I've booted to safe mode and the key worked.
    Then, I've disabled all start-up programs and it worked.
    By turning on start-up programs one-by-one, I've found the problematic one: it was ClipX. I've accidentally assigned Backspace as a hotkey for Google Search :-/
     

Share This Page

Loading...