'Bad block' installation error with MS Office Professional 2007 in Windows 7

Discussion in 'Windows 7 Software' started by Ebenezercm, Feb 2, 2011.

  1. Ebenezercm

    Ebenezercm New Member

    Joined:
    Feb 2, 2011
    Messages:
    2
    Likes Received:
    0
    MS Office 2007 Professional will not install. It does not get past the
    splash screen 'Setup is preparing the necessary files', but hangs. The summary error message in Event Viewer is as follows:

    The device, \Device\CDRom0, has a bad block.

    The detail is:

    + System

    - Provider

    [ Name] cdrom

    - EventID 7

    [ Qualifiers] 49156

    Level 2

    Task 0

    Keywords 0x80000000000000

    - TimeCreated

    [ SystemTime] 2011-01-30T22:29:07.719785100Z

    EventRecordID 1594

    Channel System

    Computer PC_main

    Security

    - EventData

    \Device\CdRom0
    030A80000100000000000000070004C0000100000000000000000000000000000090FC1D00000000FCE1010000000000FFFFFFFF02000000580000C40200010000200A124802000000000000040100000050C007A0F8FFFF2072050580FAFFFF0000000000000000102E4B0480FAFFFF107CC50680FAFFFF000000000000000028000003BF9200000100000000000000F000030003BF920A00000000020000000000000000000000

    The program installed quite happily on my old Windows XP Pro computer, and the DVD drive is able to read other installation discs, so it doesn't seem to be a hardware problem.

    Any ideas? I am getting desperate!
     
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Could be the disk itself or the drive. A few things to try - try cleaning the disk and running again, try copying the entire disk to a hard drive and installing from there, try copying the disk on another pc.
     

Share This Page

Loading...