Bad pool caller

Discussion in 'Windows 7 Help and Support' started by phantomhunter, Mar 10, 2010.

  1. phantomhunter

    phantomhunter New Member

    Joined:
    Mar 8, 2010
    Messages:
    16
    Likes Received:
    2
    Hello I am new to the site and not a computer wiz by any means. I upgraded from vista to windows 7 ultimate 64. I am using a gateway laptop with 4 gb memory and 320 gb hard drive and here's my problem. When I first upgraded to 7 a friend of a friend said he could do it all for 100 bucks, after 3 months of using windows 7 ult with no problems what so ever I found out it was a pirated copy, so I went out and bought a legit windows 7 ult. I re installed vista to get the pirated copy totally off my cpu then installed win7 again. after I finished re installing all my software I started to get blue screen saying bad pool caller and my cpu would restart. I noticed this after I re installed paint.net, so I removed that. Still getting blue screen, so I got a reg cleaner as advised, it found 144 fixes, but after I would fix them and run it again the same fixes would come back up. So I manually went through my drivers by simply searching for drivers and making sure all were updated, no problems there. So then just started un stalling stuff to see if it was a program causing the problems. It seems to be fine when just surfing the net etc but when I start using programs or install new ones like paint.net or if I use utorrent for anything after about 10-15 minutes I get the blue screen. I believe this to be a software issue and not hardware due to the pirated copy working perfectly(go figure) and my laptop being less then 1 yr old and is never mishandled or dropped. And not sure if this has anything to do with it but I have a built in web cam that is now useless since installing windows 7 as well. Tried to contact Microsoft and the website told me there would be a charge, I was upset because I just bought win7 last week. Any suggestions would be great, and if you need to see any specific logs, please speak to me like 10 yr old and tell me how to get the logs you need. Thank you all in advance.
     
  2. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    Hello,

    Follow this link and post us the Dump file http://windows7forums.com/tweaks-guides-howtos/38837-how-asked-help-bsod.html

    - Captain
     
  3. phantomhunter

    phantomhunter New Member

    Joined:
    Mar 8, 2010
    Messages:
    16
    Likes Received:
    2
    Ok thank you, I did as the link requested and created a zip file of the most recent dmp file from today, but I don't see how how to insert that file here and when I go to open it I cannot, it does give me a listed of programs to download off the net, do you have a suggestion of a good one to use
     
  4. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    If you right click on it .. It will give you an option ot Send to Compress folder then attach it here !!

    - Captain
     
  5. phantomhunter

    phantomhunter New Member

    Joined:
    Mar 8, 2010
    Messages:
    16
    Likes Received:
    2
    zippedfile:///C:/Users/Ryan/Desktop/minidump.zip
     
  6. phantomhunter

    phantomhunter New Member

    Joined:
    Mar 8, 2010
    Messages:
    16
    Likes Received:
    2
    ok, now i have another tool bar, sorry for the confusion
     

    Attached Files:

    #6 phantomhunter, Mar 10, 2010
    Last edited: Mar 10, 2010
  7. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    Hello,

    I guess its an issue with your Network Card (RTL8187Se.sys). Remove the driver and Download the driver from the vendors website and NOT from Windows Update. Uninstall any third party Antivirus / Firewall installed. Make sure you have the latest BIOS firmware installed.

    Run the Memory Diagnostic & HD Diagnostic

    Update the following Drivers

    Code:
    RimSerial_AMD64.sys Mon Nov 24 22:31:01 2008
    atikmdag.sys Tue Dec 02 02:34:09 2008
    agrsm64.sys  Mon Nov 10 20:31:35 2008
    
    Bugcheck Analysis

    Code:
    BAD_POOL_CALLER (c2)
    The current thread is making a bad pool request.  Typically this is at a bad IRQL level or double freeing the same allocation, etc.
    Arguments:
    Arg1: 0000000000000007, Attempt to free pool which was already freed
    Arg2: 0000000000001097, (reserved)
    Arg3: 0000000004b970f4, Memory contents of the pool block
    Arg4: fffff88002f1b7d0, Address of the block of pool being deallocated
    Debugging Details:
    ------------------
    GetUlongFromAddress: unable to read from fffff80002c761b0
    POOL_ADDRESS:  fffff88002f1b7d0 
    BUGCHECK_STR:  0xc2_7
    CUSTOMER_CRASH_COUNT:  1
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    CURRENT_IRQL:  2
    LAST_CONTROL_TRANSFER:  from fffff80002c0360e to fffff80002ad1f00
    STACK_TEXT:  
    fffff880`02f1b668 fffff800`02c0360e : 00000000`000000c2 00000000`00000007 00000000`00001097 00000000`04b970f4 : nt!KeBugCheckEx
    fffff880`02f1b670 fffff880`01459695 : 00000000`00000030 00000000`00000000 fffffa80`064bc900 fffffa80`04b970f4 : nt!ExFreePool+0xccb
    fffff880`02f1b720 fffff880`0412cfd5 : 00000000`00000002 fffffa80`05d83c60 fffffa80`04d52000 00000000`00000030 : ndis!NdisFreeMemory+0x15
    fffff880`02f1b750 00000000`00000002 : fffffa80`05d83c60 fffffa80`04d52000 00000000`00000030 d180ab88`00000002 : RTL8187Se+0x14fd5
    fffff880`02f1b758 fffffa80`05d83c60 : fffffa80`04d52000 00000000`00000030 d180ab88`00000002 00000000`000002cd : 0x2
    fffff880`02f1b760 fffffa80`04d52000 : 00000000`00000030 d180ab88`00000002 00000000`000002cd ffff0000`06e62f11 : 0xfffffa80`05d83c60
    fffff880`02f1b768 00000000`00000030 : d180ab88`00000002 00000000`000002cd ffff0000`06e62f11 fffffa80`04aef010 : 0xfffffa80`04d52000
    fffff880`02f1b770 d180ab88`00000002 : 00000000`000002cd ffff0000`06e62f11 fffffa80`04aef010 00000000`00000000 : 0x30
    fffff880`02f1b778 00000000`000002cd : ffff0000`06e62f11 fffffa80`04aef010 00000000`00000000 00000000`00000000 : 0xd180ab88`00000002
    fffff880`02f1b780 ffff0000`06e62f11 : fffffa80`04aef010 00000000`00000000 00000000`00000000 fffffa80`04b11000 : 0x2cd
    fffff880`02f1b788 fffffa80`04aef010 : 00000000`00000000 00000000`00000000 fffffa80`04b11000 fffffa80`04d52000 : 0xffff0000`06e62f11
    fffff880`02f1b790 00000000`00000000 : 00000000`00000000 fffffa80`04b11000 fffffa80`04d52000 fffff880`02e1c000 : 0xfffffa80`04aef010
    
    STACK_COMMAND:  kb
    FOLLOWUP_IP: 
    RTL8187Se+14fd5
    fffff880`0412cfd5 ??              ???
    SYMBOL_STACK_INDEX:  3
    SYMBOL_NAME:  RTL8187Se+14fd5
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: RTL8187Se
    IMAGE_NAME:  [B][COLOR=red]RTL8187Se.sys[/COLOR][/B]
    DEBUG_FLR_IMAGE_TIMESTAMP:  49a5ff11
    FAILURE_BUCKET_ID:  X64_0xc2_7_RTL8187Se+14fd5
    BUCKET_ID:  X64_0xc2_7_RTL8187Se+14fd5
    
    
    Hope this helps,
    Captain
     
  8. phantomhunter

    phantomhunter New Member

    Joined:
    Mar 8, 2010
    Messages:
    16
    Likes Received:
    2
    Cap, thank you for your effort but here's were I am, deleted anti virus, deleted realtek driver and re installed driver from vendor website, driver description stated was correct driver, during installation got an error saying was not correct driver for OS but then installed and worked, during running the memory test you supplied me computer would just shut down about 20-30% of run 1, but showed no errors up to that point so I do not believe I will able to complete that. I just don't understand why would it work fine with an bootleg copy and then when I install a legit copy I get these problems and only when I run certain programs.
     
  9. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    IF it shutdown then it might be an issue with RAM is PSU if you can get a spare piece of RAM test it and see whether it works. Also make sure you have sufficient Power that also could be the issue. Ensure that the machine is adequately cooled. If there is any doubt, open up the side of the PC case (be mindful of any relevant warranty conditions!) and point a mains fan squarely at the motherboard. That will rule out most (lack of) cooling issues

    Hope this helps,
    Captain
     
  10. phantomhunter

    phantomhunter New Member

    Joined:
    Mar 8, 2010
    Messages:
    16
    Likes Received:
    2
    Thanks again Cap. Im very confident its not the cooling system, I have a 3 fan cooling pad. It's just confusing to me, I can leave my laptop on all night and no issues, I can be online for hours and its fine, I can use all programs like office, nero etc and have no issues, but as soon as I run paint.net or utorrent and within minutes I get the blue screen.
     
  11. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    OK I guess its time to Run the Driver Verifier. It nothing but we are forcing to happen the crash so Driver Verifier can catch the exact problem and report it in Dump file. Here is the instructions Using Driver Verifier to identify issues with Drivers - Windows 7 Forums

    Hope this helps,
    Captain
     
  12. phantomhunter

    phantomhunter New Member

    Joined:
    Mar 8, 2010
    Messages:
    16
    Likes Received:
    2
    Hey Cap, I looked up the driver verification info, then one of my friends told me he had a similar issues, he advised me that it was utorrent program causing this issue so I I switched to bittorrent a few days ago and re installed paint.net and no more issues have occurred. This is odd to me but as long as no more blue screens then I guess I will just leave it alone, but thank you for all your assistance in this matter
     

Share This Page

Loading...