BCD broken

Discussion in 'Windows 7 Help and Support' started by AbraKdabra, Jan 1, 2010.

  1. AbraKdabra

    AbraKdabra New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    Hi everyone! I've got a problem with my BCD file. I have two Hard Disks, one (500GB) with Ubuntu 9.10, Windows XP and Windows 7 and another with 80GB.
    Every OS is installed on the 500GB HD, but "magically" (and I still don't know why) Win7 have installed the boot sector (or whatever it is) on the 80GB HD, if I disconnect this one, I can't boot Win7.
    Now for the problem, yesterday, again "magically" when I select Win7 in my GRUB2 it goes to WinXP after an underscore flashes on my upper left corner. I managed to repair GRUB2, to boot from Win7 but and error appears telling me that my Boot/BCD is broken.
    Now for what I need:

    -First, I need to repair my BCD, I tried with my Win7 DVD, repairing the boot manager, but it tells me that it's not capable of doing that...
    -Then, I really need to change my "boot sector" from my 80GB to my real partition of Win7.


    Thanks!
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You might start with a couple of things. A snipit of the Disk Management window and a snipit of the bcdedit screen after you run an administrative command prompt and type:

    bcdedit

    Just attach them so we can check. Make sure the partitions are identifible as to OS, and if not, identify them somehow. Also state which hard drive is listed first in the drive priortiy (not boot priority) in the bios.
     
  3. AbraKdabra

    AbraKdabra New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    I attached the Disk Managment Tool screen, I can't give you the BCDEdit one because... I can't boot from Win7, thats the problem.

    Drive priority in BIOS:

    SATA Nº3 socket: 500GB HD
    SATA Nº4 socket: 80GB HD

    In the screen, it says "...I thinG it is", it should be "I thinK it is".
     
    #3 AbraKdabra, Jan 1, 2010
    Last edited: Jan 1, 2010
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    To find where the Windows 7 boot files are, look for a bootmgr file and a Boot folder. It should be in the root directory (hidden, system files) of one of your partitions. If you are correct about it being on the 80 G drive, they should be there.

    Maybe we should start with how you want the system to work when you get it all fixed. Do you want to continue to use GRUB?

    Why is there a partition on you large drive that shows active with no drive letter or information?

    You know better than I do about setting up GRUB. What did you point it to for the Windows boot?
     
  5. AbraKdabra

    AbraKdabra New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    Boot folder and bootmgr file are in the Win7 drive, OK, thats good.
    That large partition has Ubuntu 9.04, forgot to mention it.

    ...An hour or more later...

    I solved my problem, I'm on Win7, I've got GRUB installed, almost everything OK.
    Now, I was looking around GRUB, and to boot, it is required to tell GRUB where (HD and partition) the OS is hosted on.
    The 500GB HD is hd0 and the 80GB is hd1. My Win7 installation is installed on a partition at the 500GB drive, but in GRUB, my Win7 option is hd1, 0 (80GB drive partition 0), and THATS weird, because W7 isn't installed on hd1, but on hd0, and I need to have the 80GB drive connected to boot Win7...

    Strange, but true.

    Anyway to change that? And HOW did that happen? I'm really confused.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would say when you booted without the 80 G drive installed, you automatically changed the order in the bios and made the larger drive the primary drive. The SATA connections seem to determine if a drive is Drive 0 or Drive 1, but the disk priority in the bios determines which drive is the primary, or at least that is the way it looks to me.

    I am guessing that GRUB should be pointed at hd0,2 but the Win 7 partition does not appear to be active. Something to try, but I do not know if it will work, is to make the Win 7 partition active. Maybe it will boot to that partition. But once again, I do not know how GRUB works so don't do something that might mess up your boot.

    I suppose the one thing is having an empty partition set to active is a little strange. So you might want to try at least making the boot partiton active, and in this case, probably Win 7. If you need to change it later, you could always use another command line utility to change it. If there are some type of boot files in that empty partition, like ntldr or some linux stuff, be careful.

    If you can get Win 7 to boot normally without needing the 80 G drive, then we can work the rest out.

    If you are in Win 7, can you get a copy of the bcdedit listing?
     
    #6 Saltgrass, Jan 1, 2010
    Last edited: Jan 1, 2010

Share This Page

Loading...