Black Screen On heavier games startup

Discussion in 'Windows 7 Graphics' started by 7piiiiiiin, Jun 8, 2010.

  1. 7piiiiiiin

    7piiiiiiin New Member

    Joined:
    Jun 8, 2010
    Messages:
    8
    Likes Received:
    0
    No Dump file, no peculiar events in Event Viewer.

    Acer TravelMate 5720, 3GB ram, Core2 Duo 2GHz, Windows 7 Professional. (Clean install)

    The bloody VGA:
    Ati mobility radeon "X2500" 256MB, you know, the one without a decent driver since its non-existence didn't begin. (as its x1700 in fact or something)

    A couple of days ago I started to get the black screen of death when launching Half-Life Episode 2, Launch the game, loads for a few seconds, i loose the cursor and the kbd doesnt "work" (no caps lock/ctrl alt del etc). Music stops (that im playing in the background with foobar). I have to power it off manually.

    I thought It was only HL2 the issue, since i can still play Counter Strike Source (same engine but indeed HL2 has more advanced stuff). So I tried with Starcraft 2 Beta, I see the loading screen and even the screen after that which is all 3D, with a spinning planet, game music goes on, a few seconds later - Black Screen. BUT music keeps playing, kbd again unresponsive and have to power it down manually (holding the button).

    Peculiar things/coincidental facts:
    - The first time it happened I was seeking through a XviD video file using Media player classic home cinema with the k-lite codec packs, played other files like that dozens of times before that problem free.
    - I think it started happening the day some Silverlight update was proposed to me via WU and i installed it.
    - When i get the Black screen, the next boot Foobar doesn't want to start (crashes on startup, no prompts, sound devices problem??) have to reinstall it every time.

    Dxdiag shows my DX is 11 and right now;
    8.561.0.0 for the driver version (x1700, since I still hadn't managed to find the driver that will make it look like "X2500" in the "fantastic" acer support website)

    Tried "reinstalling" the driver if thats ever been possible with ATI products. Windows autmatically falls back.


    Scanned with various security software i use comodo internet security as my main thing, specially installed MSE, which didn't find nothing like everything else i tried (as in spybot s&d)

    So how do random things like that happen, I really didn't install other software except that silverlight update (i removed silverlight, no result) and Defender updates. Not that there are other vectors though.
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
  3. 7piiiiiiin

    7piiiiiiin New Member

    Joined:
    Jun 8, 2010
    Messages:
    8
    Likes Received:
    0
    Well that's excellent will be bookmarking these.

    But I can't run the Modder, same thing as these guys:
    ATI Mobility Modder crasches

    UAC disabled, frameworks xml parsers etc everything seems in place.
    (still getting the black screen)
     
  4. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Are you running x86? If so, I'll make a custom driver for you. I'll need your hardware info.

    Open device manager. Right click on the video card. Properties. Details tab. Now change the dropdown to hardware ids. Copy and paste the results to here.

    If you're running x64, you will have to permanently disable Driver Enforcement permanently or use f8 eacj time to choose to do so to start the machine. Permanent disabling is not hard to do.
     
  5. 7piiiiiiin

    7piiiiiiin New Member

    Joined:
    Jun 8, 2010
    Messages:
    8
    Likes Received:
    0
    Wait wait, UAC in w7 aint like vista, i re-enabled uac, ran the modder it ran, modified the driver. SC2 ran (the beta had expired, nice reward for fixing everything :D)
    HL2 also ran.

    The spec in dxdiag isnt much different from when i removed what i had:
    Card name: ATI Mobility Radeon X1700
    Manufacturer: ATI Technologies Inc.
    Chip type: ATI Radeon Graphics Processor (0x71DE)
    DAC type: Internal DAC(400MHz)
    Display Memory: 1533 MB
    Dedicated Memory: 254 MB
    Shared Memory: 1279 MB

    Shows the same values as with the "x2500" id (like tutorials said it would) so I'm probably not losing any performance anyways.


    The catalyst doesnt want to run, on startup its displaying "stopped running" or whatever, retries twice and that's it, but thats the cli which i removed from startup.

    on the safe mode boot menu i selected "enable [or w/e it was] uncertified drivers [or w/e it was]" but that didn't fix it.

    So the duck tape approach worked (umm, right??)! thanks a bunch!!!


    BUT I dont see "ATI"-something anywhere in Device Manager?

    BTW, When i was using Vista this GPU was DX10 and ran super on DX10 games (well UT2007 anyway)
    But now Everest and HL games report the dx version as 9.0c (on vista in HL i could choose to use 9.0c or 10 now this menu is disabled with "9.0+" being selected)

    Any way to re enable its DX10 capabilities?
     
    #5 7piiiiiiin, Jun 8, 2010
    Last edited: Jun 8, 2010
  6. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    You're welcome.

    You must have misunderstood the Vista with regards to DirectX. That video solution is only a 9.0c one and you're using it well to its abilities now.

    Vista reports DX10 because its a DX10 OS.

    7 reports DX11 because it is a DX11 OS.

    Hope this link helps ya understand:

    ATI Mobility Radeon™ X1700 - Specifications
     
    7piiiiiiin and (deleted member) like this.
  7. 7piiiiiiin

    7piiiiiiin New Member

    Joined:
    Jun 8, 2010
    Messages:
    8
    Likes Received:
    0
    Riiight, i thought it will be something like that, cheers.
     
  8. shark666

    shark666 New Member

    Joined:
    Jul 16, 2011
    Messages:
    2
    Likes Received:
    0
    Risolto il problema dello schermo nero della morte...adesso vi spiego cosa fare:formattate il pc,appena fatto disattivate tutti gli aggiornamenti di windows update...adesso riavviate e premete il tasto F3 di continuo vi apparirà una schermata nera con scritto windows 7,al centro un messaggio ke indica altre opzioni,premete F8 e andate in fondo all'ultima riga...c'è scritto:disattiva controllo driver senza firma digitale,cliccateci sopra e il pc si riavvierà in automatico...avrete risolto tutti i proble<br>mi e potrete giocare tranquillamente...(shark666)
     

Share This Page

Loading...