Bluetooth issue with key being pressed down

Discussion in 'Windows 7 Help and Support' started by Forecaster, Feb 7, 2012.

  1. Forecaster

    Forecaster New Member

    Joined:
    Feb 7, 2012
    Messages:
    6
    Likes Received:
    0
    I have a Deltaco USB bluetooth adapter that I want to use to connect a wiimote to my computer to play games with.

    But when I plug the adapter in, the computer acts as if the up arrow-key is being constantly pressed down, making it scroll upwards or flip through options constantly. Nothing short of unplugging the USB-adapter makes it stop.

    This is terribly annoying. When I was using a evaluation version of Blue Soleil this problem went away when I fiddled with the wiimote.

    Now I'm using Toshibas Bluetooth Stack for Windows though, and it wont go away at all. The wiimote works, but I can't do anything on the computer at all due to this.

    I would really appreciate a solution to this as my searches have been fruitless.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You seem to indicate plugging in the Bluetooth adapter causes the problem. Do you mean it is reading the Wii or is it just the adapter?

    It would not seem the Wii is constantly transmitting, but you could take it out of the area (or remove batteries) to see. Any other devices that might be effecting the operation? WiFi can interfere with Bluetooth in certain circumstances.

    And speaking of batteries, have you changed them lately. My satellite remote starts doing strange things when the batteries are low.
     
  3. Forecaster

    Forecaster New Member

    Joined:
    Feb 7, 2012
    Messages:
    6
    Likes Received:
    0
    It starts as soon as the USB-adapter is plugged into the computer. It has nothing to do with the wiimote.

    Although when using BlueSoleil it would stop after a connection with the wiimote had been established. But using Toshibas program it doesn't stop there.
    It's as if the computer is receiving a false constant input simulating the up-arrow being held down.

    While we do have wi-fi the closest source is far away in the oppsite side of the house and I have no devices that uses it in this room.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Since it doesn't appear the adapter is receiving a signal to cause the problem, my best guess would be the driver. Plugging the adapter into a different port should load drivers again, so if you haven't tried that..

    Did you load any adapter specific drivers, or let Windows find them?

    I pretty much gave up on Bluetooth. I tried running a keyboard and mouse, but after a while, the keyboard input would become unresponsive and put out numerous inputs for only one keystroke. I am not suggesting you give up, but maybe removing the adapter from device manager and starting over would help.

    What make and model is the Bluetooth adapter?
     
  5. Forecaster

    Forecaster New Member

    Joined:
    Feb 7, 2012
    Messages:
    6
    Likes Received:
    0
    I have tried changing ports and I've let windows install the drivers. I don't know what model it is. It only says "DELTACO" on one side and "CLASS 1" on the other and they don't seem to carry it anymore at Deltaco. I suppose it might be time to buy a new one.
     

Share This Page

Loading...