Bluetooth Port Assignment

I have used Add a Device to connect W7-64 to my BT GPS. No problem really.

However, I want to use it with some ships navigation software which only uses COM 4. The device gets its COM service hooked to COM 3 automatically, and I see no way to change it. The Bluetooth Setup on XP allowed both automatic and manual assignment of the port, so my software worked fine under XP.

Ain't life grand ? The Lord Gates giveth with one hand and taketh away with the other !!

Anyone who can help ??? Urgently, as I hope to go for a sail tomorrow with my nav software working again :razz:


Excellent Member
Microsoft Community Contributor
Is there anything in your Bios you might need to turn on for the Com Ports?

Is there an update for the software to allow for the other port?

Sorry I don't run bluetooth so maybe something in that setup would allow for Com 4..

Hmm, I dont think that the BIOS is involved in this. Actually, the connecton of the BT adapter causes W7 to install the BT device driver for BT. At that stage, it automatically assigns COM4 to the BT adapter, so it has to assign something else to use with any BT device discovered. All this was under user control (if the appropriate button was clicked for CUSTOM setup) in XP, but now W7 seems to be too clever and does it all with no option for custom settings of anything.

I am surprised that no-one has come up with a solution for me, as I cannot be the first to come across this problem. I have read a lot of threads about people having difficulty with their phones or computers communicating on BT, but they all seem to be about just getting the communication going, rather than wanting control over COM port assignment.


Excellent Member
Microsoft Community Contributor
You might check the Help and Support area for setting up a bluetooth device, it seems to say there is a control panel that would allow such a thing.

Look under "Choose a com port for a bluetooth enabled device".

I think it may help if I re-state the problem.

This is re-assignment problem, not a simple assignment or choice problem.
  • Before adding a BT adapter, there is nothing available to work with in Control Panel or elsewhere - BT protocol hasn't been installed, no BT service is running...
  • Now I add a BT adaptor. As usual W7 notices this, and installs a device driver for the adapter (see Note 1 below), and at that time W7 assigns a COM port (but to what?).
I put 'to what?' as that is part of the problem. Obviously, installing the driver is where COM3 gets assigned, but not clear to what. A search of the various bth***.inf files - where I would expect to find the port assignment, and what it is assigned to - reveals nothing. I think that finding the right .inf file might enable me to push the automatic assignment away from COM3.
  • Now I come to add a BT device, and the device wizard can be used in AUTO or CUSTOM mode. The CUSTOM mode allows a choice of AVAILABLE ports but the one needed has already been assigned by W7 to the adapter, when installing the device driver for the BT adapter. So that port is not available. Since the port I require has already been assigned to the device driver end of the communication, during driver installation - I am looking for a way to reassign that port to something else, so that it IS available for my external device.
Your reference to 'Choose a com port...' is selecting a port as described above, and does not allow any reassignment of already allocated ports.

NOTE 1: Some software requires a BT driver with a bit more flexibility designed-in for a specific device - say a DELL computer or a mobile phone, these normally have the driver on a CD coming with the computer or phone. It is known that such BT drivers can then cause problems for other BT devices. Heads they win, Tails you lose!!


I am old enough and wise enough to not worry about eating my hat. As a result of your suggestions, I had to go into the BT settings to be sure you were totally wrong. I managed to find a way to make BT reserve the port I wanted before installing the adapter, as a result I could then use it for my device. I couldn't do it the way you were suggesting, but I created COM4 first, then W7 used COM3 for itself, then I deleted COM4 and added my device and lo and behold it worked. I would not have done that without your suggestions.

So... I am enjoying this fine old hat !!

Good luck and thanks for being a persistent guesser.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.