Boot problem

#1
Hello, please, thanks, bye !

I install CentOS in dualboot with Windows 8.1, problem, GRUB don't have Windows 8.1 Entry, so i insert a DVD of Windows and i run the cmd fo repair boot, i do "
bootrec /fixmbr" and "bootrec /fixboot", i rebbot and after the BIOS image i have a
flashing dash in infinite, what a should do ?
 


#3
What I like to do and a few others as well, if on a PC and you have spare HDD's, is to install on OS on separate hdd's and and boot up, using the F12 or F8 key to get the boot order menu and select the hdd we want to use at that time. This keeps the MBR and the Grub, if using a Linux distro, separate from each other and then there's no issue of MBR failure or corruption. It just keeps it clean.

Just google dual boot on separate hdd's and you find a list of info of "how to" ..... the key is to pull the power/data cable of the primary drive so there's no chance at all for dual source MBR/Grub installs. Takes some time but it's well worth it.
 


#4
The tutorial don't work
[email protected]:~$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xe0488701

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 718847 358400 7 HPFS/NTFS/exFAT
/dev/sda2 718848 934086655 466683904 7 HPFS/NTFS/exFAT
/dev/sda3 954566656 976771119 11102232 7 HPFS/NTFS/exFAT
/dev/sda4 934086656 954566655 10240000 5 Extended
/dev/sda5 934088704 935112703 512000 83 Linux
/dev/sda6 935114752 936138751 512000 83 Linux
/dev/sda7 936140800 954566655 9212928 8e Linux LVM

Partition table entries are not in disk order

Disk /dev/mapper/centos_pc--portable-swap: 4177 MB, 4177526784 bytes
255 heads, 63 sectors/track, 507 cylinders, total 8159232 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/centos_pc--portable-swap doesn't contain a valid partition table

Disk /dev/mapper/centos_pc--portable-root: 5255 MB, 5255462912 bytes
255 heads, 63 sectors/track, 638 cylinders, total 10264576 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/centos_pc--portable-root doesn't contain a valid partition table
[email protected]:~$ sudo apt-get update && sudo apt-get install syslinux
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140522) utopic InRelease
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140522) utopic/main Translation-en_US
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140522) utopic/main Translation-en
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140522) utopic/restricted Translation-en_US
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140522) utopic/restricted Translation-en
Ign http://archive.ubuntu.com utopic InRelease
Ign http://security.ubuntu.com utopic-security InRelease
Ign http://archive.ubuntu.com utopic-updates InRelease
Get:1 http://archive.ubuntu.com utopic Release.gpg [933 B]
Get:2 http://archive.ubuntu.com utopic-updates Release.gpg [933 B]
Get:3 http://archive.ubuntu.com utopic Release [215 kB]
Get:4 http://security.ubuntu.com utopic-security Release.gpg [933 B]
Get:5 http://archive.ubuntu.com utopic-updates Release [62.0 kB]
Get:6 http://security.ubuntu.com utopic-security Release [62.0 kB]
Get:7 http://archive.ubuntu.com utopic/main i386 Packages [1,325 kB]
Get:8 http://security.ubuntu.com utopic-security/main i386 Packages [87.7 kB]
Get:9 http://archive.ubuntu.com utopic/restricted i386 Packages [12.6 kB]
Get:10 http://archive.ubuntu.com utopic/main Translation-en [769 kB]
Get:11 http://archive.ubuntu.com utopic/restricted Translation-en [3,315 B]
Get:12 http://archive.ubuntu.com utopic-updates/main i386 Packages [120 kB]
Get:13 http://archive.ubuntu.com utopic-updates/restricted i386 Packages [8,424 B]
Get:14 http://archive.ubuntu.com utopic-updates/main Translation-en [55.9 kB]
Get:15 http://archive.ubuntu.com utopic-updates/restricted Translation-en [2,268 B]
Get:16 http://security.ubuntu.com utopic-security/restricted i386 Packages [8,424 B]
Get:17 http://security.ubuntu.com utopic-security/main Translation-en [40.9 kB]
Get:18 http://security.ubuntu.com utopic-security/restricted Translation-en [2,268 B]
Fetched 2,778 kB in 2s (948 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
syslinux-common
The following packages will be upgraded:
syslinux syslinux-common
2 upgraded, 0 newly installed, 0 to remove and 1152 not upgraded.
Need to get 1,012 kB of archives.
After this operation, 109 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu/ utopic/main syslinux-common all 3:6.03~pre18+dfsg-1ubuntu1 [871 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ utopic/main syslinux i386 3:6.03~pre18+dfsg-1ubuntu1 [141 kB]
Fetched 1,012 kB in 1s (738 kB/s)
dpkg: considering deconfiguration of syslinux-common, which would be broken by installation of syslinux ...
dpkg: yes, will deconfigure syslinux-common (broken by syslinux)
(Reading database ... 174703 files and directories currently installed.)
Preparing to unpack .../syslinux_3%3a6.03~pre18+dfsg-1ubuntu1_i386.deb ...
De-configuring syslinux-common (3:4.05+dfsg-6+deb8u1) ...
Unpacking syslinux (3:6.03~pre18+dfsg-1ubuntu1) over (3:4.05+dfsg-6+deb8u1) ...
Preparing to unpack .../syslinux-common_3%3a6.03~pre18+dfsg-1ubuntu1_all.deb ...
Unpacking syslinux-common (3:6.03~pre18+dfsg-1ubuntu1) over (3:4.05+dfsg-6+deb8u1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Setting up syslinux-common (3:6.03~pre18+dfsg-1ubuntu1) ...
Setting up syslinux (3:6.03~pre18+dfsg-1ubuntu1) ...
[email protected]:~$ sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sda
dd: failed to open ‘/usr/lib/syslinux/mbr.bin’: No such file or directory
[email protected]:~$
and i have a laptop, your suggestion is imposible..
 


#5
I figure it was a laptop and my suggestion wouldn't work for separate HDD install booting. As for you issue, try contacting CentOS forums and see what they have to fix it.
 


#6
Man, i just want to boot into windows, you dont have anything ?
 


Trouble

Noob Whisperer
#7
so i insert a DVD of Windows and i run the cmd fo repair boot, i do "
bootrec /fixmbr" and "bootrec /fixboot",
Try again and perhaps consider adding
/RebuildBcd
to your bootrec commands and see if that helps.
SOURCE: http://support.microsoft.com/kb/927392
 


#8
So i do

bootrec /fixmbr
bootrec /fixboot
/rebuildbcd

?
 


Trouble

Noob Whisperer
#9
Sounds like a plan to me.
Read the link included in my earlier post.
 


Trouble

Noob Whisperer
#11
AND?????
Did that resolve anything?
I cannot interpret that image but it looks like the three steps were successful??
If not Bassfisher6522 included a couple links in this post here http://windowsforum.com/threads/easydcd-messed-up-my-booting.202626/#post-626941
Which maybe helpful if you can boot from a live distro.
Have a look and see if either of those two links might help you.
 


#12
0 OS detected, so no...
 


Trouble

Noob Whisperer
#13
That particular message is not particularly reliable. Did you reboot after and see if the computer would boot.
Did you reference the two links in Bassfisher6522's post to see if either of those might help you?
 


#14
The first link don't work, after rebbot flashing dash...

And now i try the second link
 


#15
The second link don't work too...
 


Trouble

Noob Whisperer
#16
Sorry to hear that. I've pretty much exhausted my knowledge of what might help you recover from your particular issue.
Unless someone else has another suggestion.....
I would recommend that you use your Live Distro to boot and then backup all your critical data to an external resource (USB Drive).
Then use your laptops recovery partition to boot and restore your laptop to factory condition.
Hopefully your Linux Install didn't hose that particular resource as well.
If that is the case then you'll probably need to contact the manufacturer for a set of "Recovery Media" if available.
 


#17
The recovery partition have some bug, so don't work, i don't have strorage with enough place for the moment to save critical files, and the recovery have Vista x) and i'm in 8.1, thanks for help
 


ussnorway

Windows Forum Team
Staff member
Premium Supporter
#18
Assuming the windows partition isn’t corrupt now… There is one last trick:

Grab | make a windows install disc or usb and boot the system from that… all windows installs have a system repair option which should be able to scan and detect the windows install then repair the damage you did by installing an out-dated grup.
 


#19
Yeah but if the disc don't detect windows, it's difficult, if i don't have UEFI bios, i can't install UEFI OS ? So i have a Legacy windows ?
 


#20
UEFI and BIOS are one in the same...basic input output system, the firmware on the chipset. UEFI is the latest standard is all. There is no such thing as a UEFI OS. If you have a system with UEFI BIOS you can turn that off and turn on the legacy BIOS but it's different for each mobo vendor or retail PC vendor.

Where did you get your copy of windows 8.1 from? If a legitimate copy you should have a physical DVD with product key. With that, just load DVD into DVD drive, reboot, get into BIOS change boot order to boot from DVD drive, reboot and just do a clean install of windows 8.1. This will format the HDD and and remove anything and everything but at least you'll be up and running.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.