Bootmgr is missing. I've tried several things, still can't get it to work...

#1
"Bootmgr is missing".
I compressed my entire C drive. When I rebooted I got the error "Bootmgr is compressed"


I don't have a optical drive, so I made a bootable USB drive using YUMI 0.2.3 and added the windows 7 recovery ISO. The USB drive boots and I can enter the recovery console, etc.


It couldn't auto-repair the problem so I tried enterinng the following in the command prompt code:


c:
expand bootmgr temp
attrib bootmgr –s –r –h
del bootmgr
ren temp bootmgr
attrib bootmgr –a +s +h +r




I guess "ren" didn't work or something, because now the error is "Bootmgr is MISSING".


Still, the recovery disk cannot auto-repair.


i tried entering the following in the command prompt (from bootable USB):
bootrec /fixboot


It said the operation has completed successfully. I took the USB drive out and rebooted. bootmgr is still missing.


I also tried:
bootrec /rebuildbcd


Total identified windows installations: 1
Add installation to boot list? yes<y>no<n>all<a>


I selected yes, it said "The requested system device cannot be found".


On that note, I am stuck. How can I restore bootmgr?
 


Elmer

Extraordinary Member
#2
This has worked for some others. It may or may not work for you. I've stuck my BOOTMGR (64bit) up on MediaFire, download and drop it in your C: Drive. It's enabled the majority of the 50 plus downloaders its had to get into their system.
 


Last edited:
#3
Elmer, thanks for the reply. I extracted the file onto my C drive. Same error - BOOTMGR is missing, press ctrl-alt-delete to continue
 


Elmer

Extraordinary Member
#4
The only other thing I can think of is the Start up repair. It may need 2 or 3 runs though.

Apart from that, sorry dude, I'm lost!! :(
 


kaos

Senior Member
#5
3 commands to try when u have booted from disc

bootrec.exe /fixboot
bootrec.exe /fixmbr
bootrex.exe /rebuildbcd


these do fix the missing MBR as i have had the same error before on a friends pc that i repaired. Try from the disc and the repair option
 


kaos

Senior Member
#6
i mean from USB do them commands
sorry lol
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#7
OK, explain exactly what you did when you compressed the drive. I will try to duplicate.

Since I do not know what such an operation actually does, maybe it compressed more than just the bootmgr. But my first inclination would be to use the expand utlility from the WinRE boot. Did you try just expanding, and could you tell any difference? How does Bootmgr show when it is compressed?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top