BOOTMGR is missing

Discussion in 'Windows 7 Help and Support' started by Dane, Nov 10, 2011.

  1. Dane

    Dane New Member

    Nov 10, 2011
    Likes Received:
    BOOTMGR is missing but it's not the same as the other threads

    My computer is now useless.

    I had windows XP, and recently decided to upgrade to 7, skipping Vista. I have all my important files backed up, and I intend to reformat the hard drive and start fresh. I put in the Windows 7 disk, clicked through the various "customize" and "advanced" tabs on the screen where I select a drive to install to, selected the drive I wanted, and hit "format", and verified that I really meant to do that. Nothing appeared to be happening, so I got up and made some lunch, and when I came back nothing still appeared to be happening. I assumed that it might format the drive during the next step. I am still not clear whether this is the case or not.

    I selected the drive and proceeded with the installation. It said it was copying the files from the disk, then expanding the files, but it remained at 0% files expanded for several minutes before informing me that the files were missing, and the installation could not continue. It took me back to the first screen, and I tried all the prior steps again, twice, both with and without selecting format and had identical results. I decided to restart and try again, which I did by closing the installation window and verifying the restart, only to have more identical results.

    Frustrated, I decided to simply upgrade the XP installation to 7 and then manually delete the chaff from the HDD when the process was finished. I restarted again, this time selecting upgrade from the menu, where it informed me that I had to open this option while running my previous version of Windows. I restarted yet again, this time not booting from the DVD, and saw "BOOTMGR is missing, Press Ctrl+Alt+Del to restart".

    Getting pretty sick of restarting repeatedly and getting nowhere (it keeps going downhill from here), I nonetheless tried again, to be greeted with the same message. I finally resorted to firing up my trusty Compaq laptop slab from 2001 (where I am writing this right now) and Googling the error, and came up with two possible fixes to try.

    Rebooting to the DVD, I selected "repair your computer" instead of install, but the list of existing operating systems was empty. I hit "use recovery tools (yadda yada)" anyway, opened the terminal, and tried startup repair, which said it could not fix my problem. Then, I opened the terminal and tried bootrec.exe /fixboot (successful), bootrec.exe /fixmbr (successful), and bootrec.exe /rebuildbcd (0 windows installations identified). Restarted, got same error. Thinking that the empty existing operating systems list and the rebuildbcd message meant that something was wrong with my XP install now, I dug out my dusty old XP disk and tried to use it to repair or reformat the drive in a desperate bid to regain some usefulness from my machine.

    It BSoD'd before geting to any options, and continues to do so if I restart and try again.

    So, to recap:
    Can't finish windows 7 installation, it can't find the files it just copied.
    Can't open previous XP installation, it can't find the bootmgr.
    Can't upgrade XP to 7, it requires me to be in XP first.
    Can't fix the bootmgr, it doesn't think the XP install is there.
    Can't install fresh XP, it BSoDs.
    Can't do anything with my computer anymore, see above.

    How do I proceed?

    EDIT: Ah, forgot the hardware. Knew I was going to ramble on for pages and forget something crucial.

    Processor: Intel Core2 Quad, 8 GB RAM, GeForce GT120, 1.5 TB HDD.

    EDIT2: Might as well post updates as I slog through this. Have decided that, rather than the entire XP install being faulty, it may just be the THEM SOFTWARE THINGS WOT MAKE HARDWARE THINGS GO GOOD for the chipset, which, on checking nvidia's site, seem to have separate versions for 2000/xp and vista/7. These include the SATA controllers, which could mean that the 7 disk is inconsistently reading the contents of the entire drive, not just the XP files. My theory is this would explain most of my problems: 7 won't install because it can't read the files it just wrote, and its boot manager can't be fixed to deal with the XP install because it can't read the hard disk it's on.

    Current problem: the chipset FILES FOR TELLING COMPUTER BITS HOW TO WORK HARD from nvida are packaged in an installer .exe, which obviously doesn't register on the 7 disk as being THIS WORD ALSO MEANS PEOPLE WHO STEER CARS AROUND. I can't install the MORE OF THEM ONES AND ZEROES on the computer that needs them because it isn't working, and I can't install the THIS IS A GOLF WORD TOO on this working laptop (to port over afterwards) because it doesn't need them. Why is it packaged like this? Do I really have to find another, already-functional computer with the same motherboard? I'm assuming this was Gateway's way of making sure you couldn't do anything with their computers. I'm going to keep mucking through Google in the hopes that I will somehow find the I AM NOT GOOD AT GOLFS files intact and free of their obstinate and unnecessary .exe wrapper, but this seems unlikely. I may have to just replace the motherboard.

    EDIT3: apparently a common and relevant word has been filtered out on this forum, in what I must assume is a concerted effort to stifle clarity. Previous edit has been altered accordingly, now you can all rest easy.

    EDIT4: I found partial success upon trying to install the VROOM VROOMS on my laptop, then renaming the folder it unpacked the files into before it got to the part in the installation where it told me they wouldn't work with my computer and deleted the files. Unfortunately the resulting folder is quite large. I've trial-and-errored most of the files that would seem most likely to be the correct ones but haven't found anything yet. Not sure how to proceed if this proves fruitless.
    #1 Dane, Nov 10, 2011
    Last edited: Nov 10, 2011
  2. Medico

    Medico Senior Member

    Sep 20, 2011
    Likes Received:
    Re: BOOTMGR is missing but it's not the same as the other threads

    Originally instead of formating you probably should have installed directly over the XP partition. This would have accomplished a couple of things:

    1) there would have been an OS there to allow the installation to install over

    2) A folder would have been created on the root directory (C Drive) called windows.old which contained the entire old OS. You could have opened this folder and dragged much of your data to the new OS (pics, music, favs, contact, etc)

    Note: I put these couple items in for others that might read this post while attempting the same thing you are trying.

    Because you chose format the HD, I believe Win 7 was confused. I suspect your Win 7 disk was the upgrade media, not full install media. There is an approved method to clean install on a new HD (when you formated your HD essentially became a new HD) using the upgrade media. A Google search shows many sites that outline this process. I implicitly trust How To Geeks, Windows Supersite and a few others listed there.

    This is what I suspect in your case. I would check the sites for the method and try using that to see what happens. I hope this works for you. Good Luck.
    #2 Medico, Nov 10, 2011
    Last edited: Nov 10, 2011
  3. Dane

    Dane New Member

    Nov 10, 2011
    Likes Received:
    Re: BOOTMGR is missing but it's not the same as the other threads

    Thank you for the reply. However I assure you that my disk is the full installation disk and not simply an upgrade. I will, however, follow the instructions you provided simply for the sake of completeness. I did not want to leave remnants of the old OS specifically because it would make a windows.old folder, cluttering the drive with useless and possibly virus-laden files. I was aware of the two options and chose the one with the behavior I preferred.

    But, if the issue is that the windows 7 disk "got confused", what could I have done to prevent this confusion? I explicitly told it I would like the drive formatted, and the new OS installed on the clean drive. I don't understand how that would lead to the installer consistently:
    1) copying the files from the disk to the hard drive
    2) saying it will begin unpacking those files
    3) aborting several minutes later at 0% because it can't find the files that it just copied.

    So, I have isolated the files from the nvidia installer that should by all rights be my...let's just call them "muffincakes" from now on (in case there was any confusion, this word is standing in for another word I am not allowed to type, which starts with d, ends with s, and has river in the middle). I've put them and all their associated files on a thumb drive and tried to load them from the Load Muffincakes menu found after clicking repair when booting from the 7 install disk. However, selecting these prompts a leprechaun* which says that these files do not describe hardware. They should be the .inf files, yes? Not that there are any that I haven't tried, but I am just making sure.

    *EDIT: Seriously? Another word that should be common, blocked? I don't understand. Henceforth e double-r oh r will be replaced with leprechaun. Part of me feels bad trying to undermine the word filter here, but I'm really just confused about what purpose blocking those words on a tech support forum could possibly serve. Lots of people need help with leprechauns in their muffincakes.

    EDIT 2: After reading through Ted's link I think there must be some sort of fundamental misunderstanding that I need to clarify. The problem has nothing to do with whether the installation will activate or not, I am nowhere near that point yet. The problem has to do with it not installing, period. I cannot attempt any of the three methods outlined in the link, they require that I actually have something functional to start with.

    EDIT 3: Again, I get REALLY CLOSE here, but no cigar yet. Using the "load muffincake" option on the drive selection screen, I was able to get it to recognize my muffincakes as such. I browsed to them on the thumb drive, selecting their parent folder even though nothing appeared inside, and the muffincakes in the folder turned up on the list! I excitedly selected next, only to receive a leprehaun that says "To continue installation, use the Load Muffincake option to install 32-bit and signed 64-bit muffincakes. Installing an unsigned 64-bit device muffincake is not supported and might result in an unusable Windows installation."

    The muffincakes in question were downloaded directly from nvidia's site. I don't know anything about digital signing. Can someone please explain?
    #3 Dane, Nov 10, 2011
    Last edited: Nov 11, 2011
  4. Trouble

    Trouble Noob Whisperer

    Nov 30, 2009
    Likes Received:
    Re: BOOTMGR is missing but it's not the same as the other threads

    We do not block the driver or error on the site. They are however used as part of the site's advertising to generate revenue to be able to maintain the site. Maybe you are having trouble with some locally installed software (ad-blocker) that is producing your issues with those keywords. Sorry for any inconvenience.
  5. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    May 1, 2008
    Likes Received:
    Re: BOOTMGR is missing but it's not the same as the other threads

    I would suggest that the message regarding missing files, may be caused by a loss of path to the DVD. Try this. On another partition/HD, create a folder called, for example, setup. Copy the entire contents of the DVD to the folder and run the setup manually from there.
  6. Drew

    Drew Banned

    Mar 25, 2006
    Likes Received:
    Re: BOOTMGR is missing but it's not the same as the other threads


    Forgive me if I seem to be oversimplifying this as I can feel your frustration @ this point. Also, please, excuse, if I mention anything you already know. That said...

    1. You said you have a Full Version Win7 DVD. But, I wish I knew (???) if it's a retail box disc or a burnt copy from an ISO. Never the less...
    2. Take the HDD to which you are wanting to install 7, put it on (connect it to) a running machine & format it; put it back in the machine where you want to load 7.
    3. We already know the intended machine will support 7, right?
    4. One cannot migrate XP to Windows 7 except, via "Custom Install"... upgrade (path) is out of the question.
    5. Now, assuming we have a healthy Win7 disc & a computer that is happy to load Win7 from said disc & the CD ROM reads properly...
    6. Put the Win7 disc in the Optical Drive as you 'cold' start the PC
    7. Should get (might need to set 1st Boot (order) to CD ROM in the BIOS) "Press any key to boot from CD", do so
    8. Select "Custom Install"
    9. IF, the HDD has been already externally formatted, otherwise, hit format (no advaced options stuff), then NEW
    10. Either use the entire drive /partition desired or here you can set the drive/partition size.
    11. Highlight the drive/partition desired & NEXT/OK
    12. It, now, should install.

    There will be no Windows.old folder after the above steps/process.

    If not there is some hadrware issue in that Gateway box.

    Good luck. Anxious to hear how it goes.


Share This Page