BOOTMGR problem

#1
A friend gave me Windows 7 on a USB disk. I created a new 16GB partition on my hard drive because i wanted to keep XP as a backup, then ran it from the USB. The installation ran fine, but now when I try to start the computer, all I get a message saying
Code:
BOOTMGR is compressed
Press Ctrl+Alt+Del to restart
I've know you can fix it by uncompressing it from within a command prompt, but my computer is a Compaq and it didn't come with CDs, just a recovery partition. When the computer powers up, I've tried to get into recovery to get to the command prompt there, but it won't load into recovery, so i don't know what the commands are and i don't have a way to get to a command prompt anyways.
 


SIW2

New Member
#2
Download the 7 recovery disc - get the right bit version.

http://neosmart.net/blog/2009/windows-7-system-repair-discs/

Boot the cd - windows loads files - select language and keyboard - Next.

A screen saying Install Now appears - don't click that. Underneath it say Repair My Computer - click that.

After it finds the installed o/s - click Next, select command prompt.

Type

Notepad

when notepad pops up, click File then Save.
Select All files in the dropdown - click on Computer - rt click the drive > Properties, untick Compress this drive, Apply, OK.

Hope it helps.
 


Last edited:
#3
even if i did that, i don't have a DVD drive.
 


#4
even if i did that, i don't have a DVD drive.
IMHO, you should get a USB DVD Drive. You will have to repair Win7 at some point and you won't be able to use Win7 the way you sit now.
 


SIW2

New Member
#5
Have you still got that usb stick ? Boot from that to get to command prompt - same as with the dvd.
 


#6
on second thought, can't i just mount the iso as virtual drive and copy the contents to my USB drive, booting from there? Its the same way i installed 7 in the first place.

EDIT: Sorry didn't see your above post, but that was exatly what i waz thinking
 


Last edited:

SIW2

New Member
#7
Yes, that should work fine. Very lucky Mahmoud has posted those recovery discs up.
 


#8
Thank You. I resolved the problem by opening the command prompt and typing

Code:
bootrec /fixboot
bootrec /fixmbr
 


SIW2

New Member
#9
Thanks for the update.

Good idea to get the recovery disc on usb - you never know when it might be a lifesaver.
 


#10
okay. Ive been getting the same issue as the guy above. Every time i try and boot my computer i get the error:

BOOTMGR image is corrupt.

I downloaded the windows recovery listed above and burned it as a image dvd at x1 speed. When it finished loading the windows bar i got this screen...

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

1. insert your windows installion disc and restart your computer.
2. choose your language settings, and then click "next".
3. Click "repair your computer"

If you do not have the disc, contact your system administrator or computer manufacturer for asistance.
file : \windows\system32\config\system
status : 0xc0000098
info : windows failed to load because the system registry file is missing or corrupt.

any ideas?
 


#11
i tried to do it a second time and it went right back to the screen

bootmgr image is corrupt


any way this could be a hardware issue?
 


#12
Presumably you installed 7 from dvd in the first place?
 


#14
The recovery booted, I take it?

The contents should load into RAM. Select language and keyboard, click Next - you get a screen Install Now. At the bottom of that screen clikc Repair My Computer.

Sounds as if the cd didn't boot and bios tried to start windows from the HD.

If you have the 7 dvd - you have the same system recovery options on there already - try booting that and see if you can get to Repair My Computer.
 


#15
the problem is i cant get to the repair my system screen. if the cd goes pastthe loading windows files screen it goes to that error report. and 3/4 of the time it wont even load the windows files it just will directly goto bootmgr image is corrupt.
 


#16
I saw the other thread you have going - you seem unable to load any o/s boot disc?

That's curious.

You may need to completely delete the partitions on the drive and start again.

See if you can boot and load a Linux based - disc - try this freebie - you may want to transfer your Files off with the File Transfer Wizard before trying anything drastic:

http://www.paragon-software.com/home/rk-express/

Try this one as well - see what it says about the drive and partitions :

http://www.partitionwizard.com/download.html
 


Last edited:
#17
sry my ps3 froze.,

yea i cant load anything. from different builds of windows 7 or windows xp. it just keeps giving me the same error and if it doesnt and goes to loading windows files it gives me a whole new error
 


#18
i havent tried linux yet... not sure if that would make a difference or not
 


#19
Have you tried booting the ones I linked in my previous post?

Also - do you have any external devices connected - if so - remove them .

Then see if you can load 7 dvd properly.
 


#20
i dont care about anything on my pc. my main concern is just getting it up and running. its becoming a pain in the ass to have to goto the school library to write all my papers
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.