BSOD after idling. ( ntoskrnl.exe )

#1
Well I've been getting BSOD after I goto sleep. I know this because when I wake up, my computer has restarted and is now at a login screen for XP (alt OS)
I never seem to get this blue screen while I'm using my computer

I've done some "analyzing", and I see that they are having to do with ntoskrnl.exe, I'm not sure why but I just assumed Hard drives, I do have an HD start is going bad (smart status), but I unplugged that, and it still happens.
I also saw a recent post, about this dealing with memory, possibly overclocked or bad?
Well, My memory is overclocked a little bit, but this problem didn't start up till a few days ago (no idea why).
System restore is not an option.

Anyways, I'm attaching everything the sticky posts told me to attach, crash dumps ect...., Please help.
(also there are probably 1 or 2 crash dumps in there, relating to tcpip.sys, that is unrelated to this incident, but If you could help me find out why I get those, it would also help me)

cpuid.jpg
 


Attachments

Captain Jack

Extraordinary Member
#2
Hi there,

Seems like spuv.sys is causing the system to crash. Go to C:\Windows\System32\Drivers and rename spuv.sys to spuv.old and reboot the system. Then see if that works. Uninstall any Virtual drive software as well. Then Download Malwarebytes and login to Safe Mode and run a complete scan. Also update your chip set drivers as well.

Code:
DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: ffffe4801851de80, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffffa8004dd2eaa, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800052c60e0
 ffffe4801851de80 

CURRENT_IRQL:  2

FAULTING_IP: 
+1a7952f009adfdc
fffffa80`04dd2eaa ??              ???

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0xD1

PROCESS_NAME:  System

TRAP_FRAME:  fffff880031fba90 -- (.trap 0xfffff880031fba90)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa8004dd2c80 rbx=0000000000000000 rcx=fffffa8004dd2c60
rdx=fffffa8004dd2c60 rsi=0000000000000000 rdi=0000000000000000
rip=fffffa8004dd2eaa rsp=fffff880031fbc28 rbp=fffffa8004b24578
 r8=fffffa8004dd2c80  r9=0000000000000000 r10=fffffa8004b246e0
r11=fffff80005099c0c r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffffa80`04dd2eaa ??              ???
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000508dc69 to fffff8000508e700

STACK_TEXT:  
fffff880`031fb948 fffff800`0508dc69 : 00000000`0000000a ffffe480`1851de80 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`031fb950 fffff800`0508c8e0 : 00000000`00000000 00000000`00000000 fffff880`031fbb80 fffff800`0508a307 : nt!KiBugCheckDispatch+0x69
fffff880`031fba90 fffffa80`04dd2eaa : fffff880`00d828d3 00000000`0000002a 00000000`00000000 fffff880`031d3180 : nt!KiPageFault+0x260
fffff880`031fbc28 fffff880`00d828d3 : 00000000`0000002a 00000000`00000000 fffff880`031d3180 00000000`00000000 : 0xfffffa80`04dd2eaa
fffff880`031fbc30 fffff880`01068c7e : fffffa80`03cd4000 fffffa80`00000000 fffffa80`04b24500 fffff880`031fbcc8 : storport!RaidpAdapterDpcRoutine+0x53
fffff880`031fbc70 fffffa80`03cd4000 : fffffa80`00000000 fffffa80`04b24500 fffff880`031fbcc8 00000000`00000000 : spuv+0x45c7e
fffff880`031fbc78 fffffa80`00000000 : fffffa80`04b24500 fffff880`031fbcc8 00000000`00000000 fffffa80`03cd536d : 0xfffffa80`03cd4000
fffff880`031fbc80 fffffa80`04b24500 : fffff880`031fbcc8 00000000`00000000 fffffa80`03cd536d fffff880`031d3180 : 0xfffffa80`00000000
fffff880`031fbc88 fffff880`031fbcc8 : 00000000`00000000 fffffa80`03cd536d fffff880`031d3180 fffffa80`04b244b0 : 0xfffffa80`04b24500
fffff880`031fbc90 00000000`00000000 : fffffa80`03cd536d fffff880`031d3180 fffffa80`04b244b0 fffffa80`04b24578 : 0xfffff880`031fbcc8


STACK_COMMAND:  kb

FOLLOWUP_IP: 
storport!RaidpAdapterDpcRoutine+53
fffff880`00d828d3 ff442448        inc     dword ptr [rsp+48h]

SYMBOL_STACK_INDEX:  4

SYMBOL_NAME:  storport!RaidpAdapterDpcRoutine+53

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: storport

IMAGE_NAME:  storport.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4a5bcace

FAILURE_BUCKET_ID:  X64_0xD1_storport!RaidpAdapterDpcRoutine+53

BUCKET_ID:  X64_0xD1_storport!RaidpAdapterDpcRoutine+53

Followup: MachineOwner
---------
 


#3
Thanks, I'll do all that, and then post back tomorrow if my PC restarted in the night.
 


Captain Jack

Extraordinary Member
#4
No problem. Report us back
 


#5
I just searched, and I do not have an spvu.sys file in my windows folder or any subfolders, searched, also checked drivers folder, not one in there; should I get one?, If that has to do with the SPTD driver, I used the uninstaller, and uninstalled that yesterday, MY pc rebooted last night again.

I also noticed in the error report mention of RaidpAdapter. When my hard drive was failing I tried getting a pci sata adapter (which shows up in windows as raid adapter (as it can be used for raid as well)), and it did not help,

As of right now, the failing hard drive is still unplugged.
The PCI sata card is still in my computer, with nothing plugged into it.

I've attached a copy of my latest BSOD (from last night
which I don't think I've seen before, mentioning win32k.sys

Also one more thing before I go, I've uninstalled all virtual driver programs, but when I open up IMGburn, I get a message saying
"Duplex Secure's SPTD driver can have a detrimental effect on drive performance."
Does this mean it's still installed?

I used the SPTD uninstaller, and it still shows up.
Could that SPTD be causing a problem as well?

But as still, you don't need to reply until tomorrow. I did everything you said. We'll find out tonight
 


Attachments

#6
It restarted again, attached is the latest BSOD.

Also before It restarted I found out how to disable that SPTD driver.
The driver file was already gone, but SPTD was still being loaded at startup, so I followed another forum and set the SPTD reg entry to disabled at startup, and now imgburn does not give me a warning.

Also, before it restarted again, I changed my memory settings back to original and double checked that the failing HD (smart status BAD) was still unplugged.

But im using an online crash dump analysis site, and I don't know exactly what is going on, but
MODULE_NAME: hardware_disk = HD right? If so should I follow the instructions from these posts?
http://www.sevenforums.com/crashes-...has-crashed-lot-lately-mem-dump-enclosed.html
and
http://www.sevenforums.com/crashes-debugging/153337-bsod-can-happen-any-time-hard-restart.html

I mean should I run seatools and chkdks on all my drives?

PS.
My computer last night also crashed 3 times (not idle) without mini-dump files, at least they never show up in the folder.
once while converting a video
once right after I clicked the restart button in windows 7
and once about 2 minutes after typing in my PW at login screen (computer hadn't started explorer yet, HD activity light solid)

I know this is a BSOD only section, I'm just trying to be as thorough as possible with information, and also looking stuff up on my own in case it can help
 


Attachments

Last edited:

Captain Jack

Extraordinary Member
#7
Hi there,

SPTD.sys is notorious for BSOD there is an uninstaller which you could use to remove it. You could run a Hardware Diagnostic Hardware Diagnostic | Captain Debugger and see all the Hardware is correct.
 


#8
Thanks, I already removed SPTD with the uninstaller. I will continue to run the diagnostic utilities, but is there anything specific my latest bluescreen (from last night) describes?

Hi there,

SPTD.sys is notorious for BSOD there is an uninstaller which you could use to remove it. You could run a Hardware Diagnostic Hardware Diagnostic | Captain Debugger and see all the Hardware is correct.
 


Captain Jack

Extraordinary Member
#9
Nope. It's pointing to Windows Kernel since it couldn't find the real cause.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.