BSOD and crashes to desktop when gaming

mfrost

Well-Known Member
#1
Hi folks,

This forum looks like a brilliant resource for this kind of problem!

I've been having what seem like random BSOD and crashes to my desktop for over a month whenever I run anything that uses the graphics card a significant amount (the majority being games it seems).

Now i've tried using the debugging tools for windows and there are several things that, to me, point towards graphics card/drivers being faulty ("VIDMM_PROCESS_HEAP","dxgmms1.sys" and "VISTA_DRIVER_FAULT" appearing a few times) but other things that point at what could be the RAM. I was hoping someone could take a quick look as it's probably really obvious to somebody else!

My Computer Specs are as follows:

  • Asus P6X58D-E Motherboard
  • i7 950
  • GeForce GTX 480
  • OCZ Vertex 2E 120gb SSD
  • 12GB 1600mhz Patriot Viper Tri-channel Memory
  • Corsair 850Watt PSU
I have tried to note as much things as I can below to help diagnose this:

I have run Memtest86+ for ~18 hours without an error, and also the built in windows 7 memory testing program with no errors either.

I do have a modest overclock on my system currently (procesor running at 3.6ghz rather than 3.07 - RAM and graphics card are running at stock speeds), which runs completely stable when stressing it with a Prime95 overnight - I get BSOD's without the overclock also.

I have on very rare occasions seen slight graphics distortions in games, it's hard to explain but certain parts of things will extend far further than they should or go on forever. (I may have a screenshot of this from a game if you would like to see this)

Temperatures seem fairly safe while gaming (max temps i've recorded CPU:65'c, GPU:79'c).

I've re-installed PhysX drivers as a colleague said I should try. As far as I know all of my drivers are up to date.

I have attached a bunch of my minidumps.

Thanks ever so much for any help you may be able to give me!! :) I really appreciate it.

Mathew Frost
 


Attachments

#2
Hey there, welcome.

Uninstall CoreTemp to remove this pre-RTM driver which could be giving troubles:

ALSysIO64 ALSysIO64.sys Sun Apr 19 15:41:04 2009

To update the following driver, install from my attachment:

ASACPI ASACPI.sys Sun Mar 27 22:30:36 2005

Otherwise, the overclocking is the cause. Revert to default settings and see how it goes.
 


Attachments

mfrost

Well-Known Member
#3
Thanks TorrentG! I installed the file you attached and i've gone 2 days without a BSOD so far with pretty heavy use. I hope i dont have to revive this thread anymore!

brilliant!
 


#4
Glad to hear it. Thank you and you're welcome. :)
 


mfrost

Well-Known Member
#5
Well, i'm afraid i'm back! :frown:

It seems that I managed to go a good 14 days without a blue screen but then i've had a BSOD 3 days on the trot.

My computer is now running at stock (the default X.M.P. profile), and CoreTemp has been removed.

I had another look at the crash dumps from this time and they have the VISTA_DRIVER_FAULT message in common. Considering I dont run windows vista, this worries me.

I've attached the last 3 minidumps that i've had. (The last 3 days)

Any more ideas? :eek:

Thanks a lot!

Mathew
 


Attachments

#6
These aren't causing crashes, but should update:

1) NVIDIA video driver:

nvlddmkm nvlddmkm.sys Fri Jul 09 17:15:58 2010

NVIDIA

2) Realtek HD Audio driver:

RTKVHD64 RTKVHD64.sys Fri Jan 29 01:48:35 2010

RtkHDAudio


--------

All of your drivers are fine. You do have some form of memory (RAM) issue, regardless of testing results. (If you really did remove the overclocking already.)

I would use CPU-Z to find the exact model number of the RAM you're using. Then visit the manufacturer's site for the vdimm (voltage) and timings. Set the motherboard bios accordingly. If that doesn't help, then set the motherboard bios to failsafe defaults and see how it goes.

If none of that helps, replace the RAM.

Code:
Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [E:\Temp\Rar$DI00.071\103010-8736-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows 7 Kernel Version 7600 MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Machine Name:
Kernel base = 0xfffff800`0305d000 PsLoadedModuleList = 0xfffff800`0329ae50
Debug session time: Sat Oct 30 05:28:08.360 2010 (UTC - 4:00)
System Uptime: 0 days 0:38:36.391
Loading Kernel Symbols
...............................................................
................................................................
................................
Loading User Symbols
Loading unloaded module list
....
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 1A, {41201, fffff6800012d600, d3800001cb743867, fffffa800ee2e730}

Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+13bb2 )

Followup: MachineOwner
---------

2: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

MEMORY_MANAGEMENT (1a)
    # Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 0000000000041201, The subtype of the bugcheck.
Arg2: fffff6800012d600
Arg3: d3800001cb743867
Arg4: fffffa800ee2e730

Debugging Details:
------------------


BUGCHECK_STR:  0x1a_41201

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

PROCESS_NAME:  Wow.exe

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from fffff8000312bb3e to fffff800030cd740

STACK_TEXT:  
fffff880`0aab79b8 fffff800`0312bb3e : 00000000`0000001a 00000000`00041201 fffff680`0012d600 d3800001`cb743867 : nt!KeBugCheckEx
fffff880`0aab79c0 fffff800`0309bb6e : fffff900`c2421c30 fffff880`0aab7ca0 00000000`00000000 d3800001`cb743867 : nt! ?? ::FNODOBFM::`string'+0x13bb2
fffff880`0aab7a00 fffff800`0309b80a : fffffa80`0ee2e730 fffffa80`0e8d9720 fffffa80`0e8d9720 00000000`25ac0000 : nt!MiQueryAddressState+0x2ae
fffff880`0aab7a50 fffff800`033b4c38 : 00000000`00000004 00000000`25ac1000 fffffa80`0ee2e730 00000000`00000000 : nt!MiQueryAddressSpan+0xaa
fffff880`0aab7ac0 fffff800`030cc993 : ffffffff`ffffffff fffffa80`0e87bb60 fffff900`c063d770 00000000`0014dea8 : nt!NtQueryVirtualMemory+0x386
fffff880`0aab7bb0 00000000`7708ff8a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0014de88 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7708ff8a


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt! ?? ::FNODOBFM::`string'+13bb2
fffff800`0312bb3e cc              int     3

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt! ?? ::FNODOBFM::`string'+13bb2

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4c1c44a9

FAILURE_BUCKET_ID:  X64_0x1a_41201_nt!_??_::FNODOBFM::_string_+13bb2

BUCKET_ID:  X64_0x1a_41201_nt!_??_::FNODOBFM::_string_+13bb2

Followup: MachineOwner
---------
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top