Bsod - driver_power_state_failure

#1
Lately, I've been experiencing a BSOD with the message "DRIVER_POWER_STATE_FAILURE" whenever my computer tries to go into hibernation mode or attempts to shut down after a long period of use (When it shuts down, the "Shutting down" screen stays stuck for about 10 min, then the BSOD happens).

I encountered the same problem in February, but a system restore appeared to fix it. That is, until now. I attempted a new restore last weekend, but to no avail this time.

I did a lot of research on the subject, but this problems seems to pop up on lot of different systems, and in a lot of different ways, so I couldn't find anything that fit exactly to my situation.

About my computer:
-Gateway FX6801, Intel Core i7 CPU, 920 @ 2.67GHz (8 CPUs), 12288MB RAM, Nvidia GE Force GTX 285 graphics card. Factory spec, no new hardware whatsoever.

-Running on Windows 7 Home Premium 64 bits (French version) Had previously been running on Vista with same specs until last December.

-All drivers appear to be up and running, up to date (I checked thoroughly, no red Xs or any other error message).

-Running Norton 360 Premier Edition 4.0 with latest updates. Yeah. I know. Saw a lot of things being said about Norton/Symantec, but this has been a costly (if not ill-advised) purchase and therefore removing it is not an option unless it DEFINITELY is the culprit (or until my subscription is over). Free antiviruses aren't an option either, ever since Norton found a bunch of viruses on old backup DVDs that had been deemed "safe" by the free antivirus on my previous computer.

Today's minidump is included below (I don't have any other ones, they appear to have been erased after my latest system restore, and I've been shutting down my computer manually before getting a BSOD in the last few days. I can always wait for the BSOD to happen again and include a few more dumps if needed.)

Thank you kindly for any help, this is driving me nuts!
 


Attachments

#2
means the driver is unable send pwr-state information to Windows 7 - suggest a repair install from DVD as that may help for a while.

You overclock and that may have a negative impact on your system's stability - just make sure all drivers are current especially chipset drivers as well.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#3
Since I don't read dump files, have you tried the powercfg commands.

If you run this, close all open programs you can then open an administrative command window.

Type the command and wait for it to finish. Make note of where the resulting file is stored.

powercfg -energy

If you type powercfg /? it will show other possible options.
 


ickymay

New Member
#4
the driver power state failure error message is almost always a driver that needs updating or a device that uses drivers that just isnt supported , and in your case windows debugger failing to load the image for RTSTOR64.SYS suggests this could be the culprit ?
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 1000009F, {4, 258, fffffa800914d040, fffff80004671510}

Unable to load image \SystemRoot\system32\drivers\RTSTOR64.SYS, Win32 error 0n2
*** WARNING: Unable to verify timestamp for RTSTOR64.SYS
*** ERROR: Module load completed but symbols could not be loaded for RTSTOR64.SYS
Probably caused by : usbccgp.sys

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver is causing an inconsistent power state.
Arguments:
Arg1: 0000000000000004, The power transition timed out waiting to synchronize with the Pnp
subsystem.

Arg2: 0000000000000258, Timeout in seconds.
Arg3: fffffa800914d040, The thread currently holding on to the Pnp lock.
Arg4: fffff80004671510

Debugging Details:
------------------


DRVPOWERSTATE_SUBCODE: 4

IMAGE_NAME: usbccgp.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 4a5bcc15

MODULE_NAME: usbccgp

FAULTING_MODULE: fffff88004fde000 usbccgp

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0x9F

PROCESS_NAME: System

CURRENT_IRQL: 2

STACK_TEXT:
fffff880`035704a0 fffff800`0307d752 : fffffa80`0914d040 fffffa80`0914d040 00000000`00000000 00000000`00000000 : nt!KiSwapContext+0x7a
fffff880`035705e0 fffff800`0307f8af : fffffa80`0f23dab0 fffffa80`0a2d1290 fffffa80`00000000 fffffa80`0f23d960 : nt!KiCommitThreadWait+0x1d2
fffff880`03570670 fffff880`04e9a94d : fffffa80`0f23da00 fffffa80`00000000 fffffa80`0a2d1000 fffffa80`0a2d1200 : nt!KeWaitForSingleObject+0x19f
fffff880`03570710 fffffa80`0f23da00 : fffffa80`00000000 fffffa80`0a2d1000 fffffa80`0a2d1200 fffff880`03164180 : RTSTOR64+0x494d
fffff880`03570718 fffffa80`00000000 : fffffa80`0a2d1000 fffffa80`0a2d1200 fffff880`03164180 fffff800`0338d3b4 : 0xfffffa80`0f23da00
fffff880`03570720 fffffa80`0a2d1000 : fffffa80`0a2d1200 fffff880`03164180 fffff800`0338d3b4 00000000`00001ffc : 0xfffffa80`00000000
fffff880`03570728 fffffa80`0a2d1200 : fffff880`03164180 fffff800`0338d3b4 00000000`00001ffc fffffa80`091359e0 : 0xfffffa80`0a2d1000
fffff880`03570730 fffff880`03164180 : fffff800`0338d3b4 00000000`00001ffc fffffa80`091359e0 fffff8a0`00001890 : 0xfffffa80`0a2d1200
fffff880`03570738 fffff800`0338d3b4 : 00000000`00001ffc fffffa80`091359e0 fffff8a0`00001890 00000000`00001ffc : 0xfffff880`03164180
fffff880`03570740 fffff800`03075853 : fffffa80`0914d040 fffff880`03570810 00000000`00000030 fffff880`03570998 : nt!ObpCloseHandle+0x94
fffff880`03570790 00000000`00000017 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`00060001 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x17


STACK_COMMAND: kb

FOLLOWUP_NAME: MachineOwner

FAILURE_BUCKET_ID: X64_0x9F_4_RTSTOR64_IMAGE_usbccgp.sys

BUCKET_ID: X64_0x9F_4_RTSTOR64_IMAGE_usbccgp.sys

Followup: MachineOwner
---------
although usbccgp.sys is mentioned this is actually a windows driver and would be more likely the symptom not the cause.

I would say all these drivers are old and need updating including
sfhlp02.sys fffff880`0187d000 fffff880`01885000 0x00008000 0x449023fe 14/06/2006 15:58:06
GEARAspiWDM.sys fffff880`04bf4000 fffff880`04bfd000 0x00009000 0x47fbc46f 08/04/2008 20:15:59
gwfilt64.sys fffff880`05de4000 fffff880`05df2000 0x0000e000 0x47fdcdcd 10/04/2008 09:20:29
e1y60x64.sys fffff880`04b9e000 fffff880`04be7000 0x00049000 0x48a9ed61 18/08/2008 22:45:05
RTSTOR64.SYS fffff880`04e96000 fffff880`04eab000 0x00015000 0x4934cf44 02/12/2008 07:01:40
sfhlp02.sys is something to do with StarForce Protection Helper Driver (version 2.x) to protect software from being copyrighted ?
GEARAspiWDM.sys suggest google that as it can be many things such as cd dvd filter or Norton ghost etc ..............
gwfilt64.sys Thu Apr 10 04:20:29 2008 - RealTek High Definition Audio Codecs Drivers
e1y60x64.sys Mon Aug 18 17:45:05 2008 - Intel network driver
RTSTOR64.SYS is a driver for your Realtek USB 2.0 Card Reader

I suggest update these drivers and monitor for crashes let us know how it goes and upload any more bluescreen .dmp files if you crash ?
 


#5
Thanks all, I'll try to update those drivers and will let you know if this resolves the crash issues (They don't happen systematically, so it might take a few days to verify without any doubt)
 


#6
UPDATE - Problem solved! RTSTOR64 was indeed the culprit, and a mean one at that.

Updating that driver turned out to create a far more annoying BSOD that would randomly happen on startup and would prevent Windows from launching, thus forcing me to perform a system restore.

I finally removed the driver altogether, and everything has been running smoothly ever since.
 


#7
excellent glad to hear it's solved :D
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top