BSOD featuring nvstor.sys

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by Rick S., Sep 11, 2008.

  1. Rick S.

    Rick S. New Member

    Joined:
    Sep 11, 2008
    Messages:
    14
    Likes Received:
    0
    You can see rig specs below. I am using a legal copy of Vista Ultimate 32 bit SP1. I wiped a new drive then installed said OS. Before upgrading to SP1, I could not update at all. I was receiving some strange error that nobody and I mean nobody had a solution for, not even the wonderful people at microsoft/support. I decided to download and install SP1 on its own hoping it would fix the problem. It did, sort of. Everthing went as it should and after a quick reboot I was now running SP1. I decided to check if the update through vista was working now. Everything looked great so I decided to try to download and install a few of the "optional" updates that are available. It now gets to about 25% of the install before kicking me to the BSOD which states:
    DRIVER_IRQL_NOT_LESS_OR_EQUAL​

    ***Stop: 0x000000D1 (0x00000000, 0x00000002, 0x00000000, 0x80737395)​

    ***nvstor.sys - Address 80737395 base at 80733000, Datestamp 40671a61​

    then it does the memory dump and I have to do a manual restart. This happens if I am trying to download 1 or 20 "optional" updates, it makes no difference how I select or try at this. I had no issues running XP Pro SP2 nor have I seen this BSOD before. It did not do this prior to installing SP1. Any ideas? :confused:
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,852
    Likes Received:
    1,569
    Hi Rick,
    nvstor.sys is part of an nvidia driver, are yours up to date? If so, try googling nvstor.sys and check out the links... One solution was to reduce an overclock others were replacing drivers.
    Hope this helps.. :)
    Oh and welcome to the forum...
     
  3. Rick S.

    Rick S. New Member

    Joined:
    Sep 11, 2008
    Messages:
    14
    Likes Received:
    0
    **Update**
    Okay so I found out that nvstor.sys is an nvidia storage driver having to do with Serial ATA. From what I learned SP1 does not like certain drivers and this just happens to be one. I went to the nvidia site and tried to get the updated driver but it failed to install. So I went to my motherboards support page and tried to get it that way. About 3/4 of the way through the install, Vista froze up on me. A quick reboot later I was face to face with a screen telling me that a crucial file was missing and that I should put in my Vista cd, pick my language, and choose to repair. The repair failed. It then asked me if I wanted to revert to a restore point. The restore failed as well. So, a short 9 hours later I am happy to anounce that I wiped my drive, reinstalled Vista and was able to update all without a hickup and everything seems to be working fine. (knocks on wood) ;)
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,852
    Likes Received:
    1,569
    Hi Rick, glad you got things sorted..:)I was going to suggest a reformat and then immediately applying the SP1 service pack (this is the best way to install service packs) followed by system drivers.
    It looks like you've beat me to it though!
     
  5. Rick S.

    Rick S. New Member

    Joined:
    Sep 11, 2008
    Messages:
    14
    Likes Received:
    0
    **Update Part Duex**

    Okay so as above statements will tell you, all was going well with my fresh Vista intall. This morning, I went to install a legal copy of Crysis and everthing was going as it should. Then a window popped up that talked about it unpacking windows c++ 3.0 or something of the like. It loaded about 75% of the way and then just hung there for over 3 hours. I then moved the mouse and the whole screen froze. So I went for a quick reboot. Upon loading the page after the bios screen it said:

    DMI Data Pool Updating.......Success

    A Disk Read Error has occured, press CTRL+ALT+DEL to restart

    Is Crysis so awesome it fried my drive?!?!?!? ;) It is not the SATA cable as I used the same cable to load my second disk with XP Pro on it (thats how I am posting this) and I even tried a different SATA port on my motherboard to no avail. Ideas? :cool:
     

Share This Page

Loading...