[BSOD] Impossible computer (dmp files included)

#1
Hi people,

I've built a computer for a mate of mine and it seems to be producing awkward problems over the long run. Even after assembling it myself (I've assembled many computers), it seemed to be working fine after a few restarts. I then took it to his home and it decides to blue screen and not boot the first time I get it hooked. I then run a checkdisk and realise a whole bunch of file system errors appearing...odd. I check every piece of hardware and nothing seems to be at fault. I then blamed it on the OS and did a clean reinstall using my clean copy (obviously with his licence key).

I leave and realise that a couple months down the track, I receive a call about the computer. Apparently it's freezing, blue screening, mouse is disapearing etc. I now have the computer with me and I can say that it had many file system errors once more.

1st culprit: HDD.
I run a full long test using Seatools and it passes. I also check the drive with 2 other third party programs and it checks out ok...then it can't surely be the hdd.

2nd culprit: Memory/CPU.
I run 4-6hr burn-in tests with Memtest and Gold memory (or something). No faults! I then boot into windows and run a stress test using Orthos. It's been running for 24+ hrs now with no errors.

3rd culprit: PSU.
The voltage rails in BIOS seem fine. I also manually check with a cheap PSU tester (one with the green LEDs for each rail) and it seems fine.

4th culprit: Mobo?
How do I test this? If there was a problem with the motherboard, wouldn't it fail one of the other tests above?

To those experts out there. How could I fix this issue? I've tried everything in the books and I grow impatient. I thought the RAM may have been at fault since it's Patriot branded (I've had a bad experience with them in the past). Also, it seems like the problem just appears randomly when booting up. I checked the Event Viewer and it mentioned some "Bug Check" which, according to google searches, may relate to RAM problem. But the RAM still hasn't failed any tests.

What could it be people? What tests should I run?

The BSODs I get are bugcheck related. I have attached 2 of the dump files from the computer. Hope you guys can decipher it and tell me what it might be :) View attachment Dmp files.zip
 


Captain Jack

Extraordinary Member
#2
Hello and Welcome !

I think it could be RAM itself. Follow this article and run a Memory Diagnostic not the Windows one. Hardware Diagnostic !! Make sure you run atleast 7 to 8 passes.

Download this application SF Diagnostic Tool v4 run all the options and attach the files.

Bugcheck:
Code:
PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: fffff6800100e140, memory referenced.
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
Arg3: fffff80002e912e2, If non-zero, the instruction address which referenced the bad memory
    address.
Arg4: 0000000000000002, (reserved)

Debugging Details:
------------------


Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800030b50e0
 fffff6800100e140 

FAULTING_IP: 
nt!MiAgeWorkingSet+1c2
fffff800`02e912e2 488b19          mov     rbx,qword ptr [rcx]

MM_INTERNAL_CODE:  2

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x50

PROCESS_NAME:  svchost.exe

CURRENT_IRQL:  0

TRAP_FRAME:  fffff880033167a0 -- (.trap 0xfffff880033167a0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000007ffffffff8 rbx=0000000000000000 rcx=fffff6800100e140
rdx=0000000000000001 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002e912e2 rsp=fffff88003316930 rbp=000000000100e146
 r8=0000000000000001  r9=fffffa8005b7bac8 r10=0000000000000005
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe cy
nt!MiAgeWorkingSet+0x1c2:
fffff800`02e912e2 488b19          mov     rbx,qword ptr [rcx] ds:fffff680`0100e140=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002efc8f2 to fffff80002e7d740

STACK_TEXT:  
fffff880`03316638 fffff800`02efc8f2 : 00000000`00000050 fffff680`0100e140 00000000`00000000 fffff880`033167a0 : nt!KeBugCheckEx
fffff880`03316640 fffff800`02e7b82e : 00000000`00000000 00000980`00000000 00000000`00001000 fffff800`02fb1bfe : nt! ?? ::FNODOBFM::`string'+0x40ec0
fffff880`033167a0 fffff800`02e912e2 : 00000000`000004af 00000000`00000001 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x16e
fffff880`03316930 fffff800`02effa5e : fffffa80`05b7bac8 fffff880`00000001 00000000`00000001 fffff880`03316bb0 : nt!MiAgeWorkingSet+0x1c2
fffff880`03316ae0 fffff800`02e91ee2 : 00000000`000027f3 00000000`00000000 fffffa80`00000000 00000000`00000001 : nt! ?? ::FNODOBFM::`string'+0x496d6
fffff880`03316b80 fffff800`02e92173 : 00000000`00000008 fffff880`03316c10 00000000`00000001 fffffa80`00000000 : nt!MmWorkingSetManager+0x6e
fffff880`03316bd0 fffff800`03121c06 : fffffa80`0356cb60 00000000`00000080 fffffa80`034e99e0 00000000`00000001 : nt!KeBalanceSetManager+0x1c3
fffff880`03316d40 fffff800`02e5bc26 : fffff880`009e8180 fffffa80`0356cb60 fffff880`009f2fc0 ffffffff`7affffa8 : nt!PspSystemThreadStartup+0x5a
fffff880`03316d80 00000000`00000000 : fffff880`03317000 fffff880`03311000 fffff880`03316820 00000000`00000000 : nt!KxStartSystemThread+0x16


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt!MiAgeWorkingSet+1c2
fffff800`02e912e2 488b19          mov     rbx,qword ptr [rcx]

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  nt!MiAgeWorkingSet+1c2

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

DEBUG_FLR_IMAGE_TIMESTAMP:  4c1c44a9

IMAGE_NAME:  memory_corruption

FAILURE_BUCKET_ID:  X64_0x50_nt!MiAgeWorkingSet+1c2

BUCKET_ID:  X64_0x50_nt!MiAgeWorkingSet+1c2

Followup: MachineOwner
---------
Hope this helps,
Captain
 


#3
Before testing memory, you can post a screen shot of CPU-Z spd tab and memory tab for us to look at.

Remove AVG in safe mode with the special tool, reboot and install MSE.

Update Realtek lan driver:

Rt64win7 Rt64win7.sys Thu Mar 04 08:42:52 2010

RTL8111
 


#4
Thanks for the response.

I did as TorrentG suggested then decided to boot up memtest and you're not going to believe it...errors half an hour in. How come they didn't appear when I had it running for 1-2days straight last week?

Dropped the computer off at the supplier now to have it looked at. I did detail them my analysis so that that RMA the RAM (unintended anagram haha).
 


#5
The bios probably was set wrong, and if you would have posted the CPU-Z screen shots, we could have easily fixed it.

Anyhow, best of luck with it.
 


#6
The BIOS was set to the recommended settings. I can't imagine how a particular PC component would require special settings. Also, if it makes any difference, I do recall reading in CPU-Z that the RAM was set at 1T. It's a DDR3 2x2GB Patriot kit (1333).
 


#7
I can't imagine how a particular PC component would require special settings.
The entire world couldn't imagine how the world was round instead of flat, once upon a time. heh heh
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.