BSOD on normal start up, none for safe mode

#1
Hi,

My computer was working fine until it started getting a BSOD after i changed the Language for non-Unicode programs from English to Japanese. And now i am only able to get on my computer in safe mode while starting it up normally causes it to get a BSOD as soon as i finish loading the desktop. I'm running on Windows 7 Pro. Any help would be appreciated.
 


Attachments

#2
Hey ya. Welcome. Let's see what we can do here.

1) Boot to safe mode + networking. Download and run this installer/uninstaller this remove sptd.sys. Do not update while using it as there is a choice:

DuplexSecure - Downloads

2) Navigate to C:\Windows\ and delete this driver:

gdrv gdrv.sys Thu Mar 12 23:22:29 2009

3) Download and run the AVG removal tool while still in safe mode from the sticky link in this section of the forum.

4) Boot to normal mode and update your Realtek lan driver:

Rt64win7 Rt64win7.sys Mon Mar 22 05:57:14 2010

RTL8111

5) Uninstall Daemon Tools normally. This is why you removed sptd.sys.

PowerISO is an excellent and 100% stable replacement. The disc emulation part of the software is free forever:

PowerISO - Create, Edit, Compress, Encrypt, Split, Mount, Extract ISO file, ISO/BIN converter, Virtual Drive

6) Install MSE for the antivirus.

7) Update your NEC USB 3.0 driver from the motherboard manufacturer's website.

8) Update your video card driver:

atikmpag atikmpag.sys Tue May 04 21:23:24 2010

Drivers & Support | GAME.AMD.COM

9) Update your Realtek HD Audio driver:

RTKVHD64 RTKVHD64.sys Tue Apr 06 06:17:30 2010

Run the installer once, reboot, then run it again:

Realtek

10) Uninstall the utility from Gigabyte (probably Easy Tune 6) that we deleted the driver gdrv.sys for.
 


#3
I have a problem, in the first step when i try to install it, it asks to reboot for the changes to take effect, but it doesn't actually install it. I tried running it as administrator as well. And also whenever i delete gdrv file it comes back after i restart my pc
 


Last edited:
#4
It's not supposed to install it. It removes it, if you told it to do so.
 


#5
It says that there is No SPTD version was detected when i run it. So followed the rest of the instructions but i still am getting the BSOD when i try to run it in normal mode at step 4.
 


Last edited:
#6
Do step 10 first, then the rest of what's left and if you still have a problem, then post new crash dumps.

Uninstall EasyTune and/or EnergySaver from Gigabyte.
 


#7
I could uninstall EnergySaver but not Easytune. When i try to uninstall easytune from the control panel, program/features and click uninstall i get an Error1719 and i don't see any uninstall app inside the main folder of the program. Should i just delete the folder then?
 


Last edited:
#8
Yes, delete the folder, then manually delete the driver again.

Type services.msc in the start menu then press enter. Disable all Gigabyte, Energy Saver and/or EasyTune services.

Reboot again to normal mode + networking to download and install Ccleaner. Use it to clean the registry.

Try rebooting to normal mode and carry on with anything you haven't done yet.
 


#9
When i checked the services.msc there were no Gigabyte, Energy Saver and/or EasyTune services that i saw to disable. So i just tried to run in normal mode but i still got the BSOD.
 


Attachments

#10
Sptd.sys has been updated and not removed, as I was warning about.

Use the installer/uninstaller again to completely remove it:

sptd sptd.sys Tue Aug 24 02:13:12 2010

You could always check in C:\Windows\System32\drivers that it is gone.

-----------

Uninstall Daemon Tools in safe mode in the normal method, if it lets you do so.

After, try to boot to normal mode.
 


#11
When i run the program from DuplexSecure - Downloads i get a pop up that says " No SPTD version was detected, select action to be performed" and 3 boxes below it. Install, Uninstall(grayed out), and cancel. I don't see any remove option for sptd sptd.sys. And you told me not to install so i'm somewhat confused at what to do.
 


Last edited:
#12
Follow this from their faq:

"Step 1. Boot in safe mode and press ESC key when you see on bottom line of display: "Press ESC to cancel loading SPTD.sys". This will abort loading of SPTD layer.
Step 2.
Find "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\sptd" registry key in REGEDIT and set DWORD Start value to 4 (i.e. disabled).
Step 3.
Reboot again in normal mode and check if your issue is solved. To reenable SPTD restore the DWORD Start value back to '0' and reboot your computer."


After step 2, you can manually delete sptd.sys at C:\Windows\System32\drivers
 


#13
I managed to delete sptd.sys but i'm still getting the BSOD sadly.
 


Attachments

#15
Hmm for some reason when i start the program, a little bit later i start getting the BSOD. I'll try again. I've also tried to run it as administrator as well just in case.

Ya it keeps doing it.
 


Attachments

Last edited:
#16
First, remove all USB sticks and/or external hard drives. Then open a command prompt. Run this command by typing it then press enter:

chkdsk /r

Follow the instructions and let it complete. If you have other hard drive partitions than C: then also too run the command for them like this with the appropriate driver letter. Here is an example for D:

chkdsk /r D:

----------

That will be some time, so when it's done, run the Avira removal tool again and see how it goes.

You're having NTFS errors. The above should fix it.
 


#17
I finished doing chkdsk /r and tried to run the avira cleaner but i still get a BSOD.
 


Attachments

#19
Well i managed to run some tests but i don't know what i'm supposed to do know that i've done it. The website given doesn't tell me what happens/what to do when running tests. Only how to burn the program to a cd/usb and about harddrive checking which i did also. Is there anything else i should do?
 


#20
Before testing, it is very much more likely that you have an incorrect bios settings. So please download and run CPU-Z.

Post a screen shot here of each the memory and spd tabs.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.