BSOD - System Service Exception tdx.sys - please advise

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by Titoos, Aug 28, 2012.

  1. Titoos

    Titoos New Member

    Joined:
    Aug 28, 2012
    Messages:
    14
    Likes Received:
    0
    Hello,

    First, my config:

    Processor: AMD Phenom II x4 945 AM3
    Motherboard: Gigabyte GA-790FXTA-UD5 AM3, BIOS F2
    RAM: DDR3 Mushkin 996776 4x4 GB (16GB)
    graphics: Gigabyte Radeon HD 7950 GV-R795WF3-3GD
    Disks: - SSD Crucial m4 128GB
    - WD Caviar Black 1TB WD1002FAEX
    - Samsung F3 HD103SJ 1TB
    - Samsung F3 HD103UJ 1TB
    DVD - LG Blu-Ray (DVD+/-RW + Blu-ray) BH10LS38
    Sound Blaster X-Fi Elite Pro

    PSU: Enermax Modu87+ 900W

    OS: Windows 7 Ultimate 64bit


    Here's a problem.

    SSD, Radeon HD 7950 and Mushkin ddr3 are the newest parts. But I'm experiencing random BSODs (ntoskrnl.exe). There were also BSODs related to dwm.exe, but they disapeared when I installed Catalyst 12.8. Sometimes there are hardlocks without BSODs - ctrs+alt+del doesn't work here so I have to do a hard reset.

    First I thought it might be related to Radeon 7950 and compatibility problems - F2 (2009) is the latest BIOS for my motherboard (there is also F3J but still beta). Now it seems to be ok after I installed Catalyst 12.8.

    Then I thought that the SSD connected to Marvell controller is the problem. Well, there is a problem cause BIOS sometimes cannot see this SSD. Now Im thinking of buying a newest motherboard... unfortunately. I updated Marvell Controller drivers, still the same.

    Next thing - I ran memtest86+ ver. 4.20 to check memory. Pass 0 (Modulo 20, Random pattern) - there's only one error:

    Test 8, Pass 0, Failing address 00080073468 - 2048.4mb
    Good: e17e40c8
    Bad: e17e00c8
    Err-Bits: 00004000
    Count 1

    Next pass - no error. I let Memtest complete 6 passes. I got only this one error.

    BIOS settings:

    tCL: 9
    tRCD: 9
    tRP: 9
    tRAS: 24

    Ram voltage - 1.635v

    I asked on Mushkin Forums, set memory voltage to 1.650V. First MemTest pass - no errors. Second pass also completed. I think that all four sticks are ok. I can't say it's overheating. I'd say the memory is getting warm (even not so warm), but not hot. Third MemTest pass also was completed. No lock ups. Probably too low voltage could generate errors.

    Today I got another BSOD:

    2012-08-28 19:38:20 SYSTEM_SERVICE_EXCEPTION 0x0000003b 00000000`c0000005 fffff880`0404a609 fffff880`0b98e9b0 00000000`00000000 tdx.sys tdx.sys+3609 x64 ntoskrnl.exe+7f1c0 C:\Windows\Minidump\082812-36504-01.dmp 4 15 7601 276 112

    I'd really appreciate any suggestions. I attached everything in one zip file.

    Thank you!

    Robb
     

    Attached Files:

  2. usasma

    usasma Fantastic Member
    Microsoft Community Contributor

    Joined:
    Mar 22, 2010
    Messages:
    3,048
    Likes Received:
    83
    SSD's on Marvell controllers aren't advised. Too many problems seen with them - even with updated drivers (yours date from Oct 2009).
    I'm not familiar with your mobo - but it seems like you have AMD and/or JMicron controllers also. Hook up the SSD to one of those instead.

    Have you updated the firmware on your SSD? That (along with storage controller driver updates) are the most important things to ensure that the SSD functions properly.

    Even though you have SP1 installed, it seems as if you're missing Windows Updates. Please run the following command from an elevated (Run as administrator) Command Prompt:
    Code:
    systeminfo.exe >%userprofile%\desktop\systeminfo.txt
    Then please upload the systeminfo.txt file from your Desktop with your next post

    AMD OverDrive (AODDriver2.sys) is either a stand-alone application, or a component of the AMD VISION Engine Control Center. This driver is known to cause BSOD's on some Win7 systems.
    Sometimes the driver remains and continues to cause BSOD's. If this is the case for you, post back and we'll give further instructions for safely removing it.

    If overclocking, please stop and return the system to stock (standard) values while we're troubleshooting. Feel free to resume the overclock once the system is stabilized.

    Only one memory dump in the uploaded report. We'll need all memory dumps. They're located in C:\Windows\Minidump. Please zip them up and upload them with your next post.

    Your I: drive is overfull and that can cause problems with Windows' internal operations. Please ensure that all drives have 15% free space on them (this means removing approximately 13 gB from the I: drive).

    The "trick" for ruling out the SSD is to install Windows on a platter based hard drive and see if it works without issues on your system. There's no need to activate it as you'll only be leaving it on long enough to test.

    Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable! :
    CTEDSPSY.DLL Mon Mar 5 02:45:31 2007 (45EBCA9B)
    HP Creative Sound Blaster X-Fi Audio
    http://www.carrona.org/drivers/driver.php?id=CTEDSPSY.DLL

    ctac32k.sys Wed Jul 2 04:38:22 2008 (486B3E7E)
    Creative Audio Driver
    http://www.carrona.org/drivers/driver.php?id=ctac32k.sys

    000.fcl Fri Sep 26 09:11:22 2008 (48DCDF7A)
    CyberLink FCL Driver
    http://www.carrona.org/drivers/driver.php?id=000.fcl


    There aren't any errors in the WER section of MSINFO32 and there are other issues with your OS installation. Please validate your OS install here (and let us know the results): Genuine Microsoft Software

    Finally, this is a networking error - and I don't see any networking problems with the system. The choices are:
    - there's a driver problem
    - there's a hardware problem
    - or there's a Windows problem

    If the above steps don't fix things, please run Driver Verifier according to these instructions: Driver Verifier Settings


    Analysis:
    The following is for information purposes only.
    Code:
    [font=lucida console]**************************Tue Aug 28 13:36:35.993 2012 (UTC - 4:00)**************************
    Loading Dump File [C:\Users\John\_jcgriff2_\dbug\__Kernel__\082812-36504-01.dmp]
    Windows 7 Kernel Version [B]7601 [/B](Service Pack 1) MP (4 procs) Free x64
    Built by: [B]7601[/B].17835.amd64fre.win7sp1_gdr.120503-2030
    System Uptime:[B]0 days 1:36:50.132[/B]
    BugCheck Code: [B]BugCheck 3B, {c0000005, fffff8800404a609, fffff8800b98e9b0, 0}[/B]
    Probably caused by :[B]tdx.sys ( tdx!TdxSendDatagramTransportAddress+289 )[/B]
    BugCheck Info: [B]SYSTEM_SERVICE_EXCEPTION (3b)[/B]
    DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT
    BUGCHECK_STR:  0x3B
    PROCESS_NAME: [B]Skype.exe[/B]
    FAILURE_BUCKET_ID: [B]X64_0x3B_tdx!TdxSendDatagramTransportAddress+289[/B]
      BIOS Version                  F2
      BIOS Release Date             12/03/2009
      Manufacturer                  Gigabyte Technology Co., Ltd.
      Product Name                  GA-790FXTA-UD5
    ¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
    [/font]


    3rd Party Drivers:The following is for information purposes only. Any drivers in red should be updated.
    Code:
    [font=lucida console]**************************Tue Aug 28 13:36:35.993 2012 (UTC - 4:00)**************************
    [COLOR=RED][B]CTEDSPSY.DLL                Mon Mar  5 02:45:31 2007 (45EBCA9B)[/B][/COLOR]
    [COLOR=RED][B]ctac32k.sys                 Wed Jul  2 04:38:22 2008 (486B3E7E)[/B][/COLOR]
    [COLOR=RED][B]000.fcl                     Fri Sep 26 09:11:22 2008 (48DCDF7A)[/B][/COLOR]
    amdsata.sys                 Tue Apr 28 19:33:25 2009 (49F79245)
    amdxata.sys                 Tue Apr 28 19:33:27 2009 (49F79247)
    AtiPcie.sys                 Tue May  5 11:00:22 2009 (4A005486)
    nusb3hub.sys                Fri Sep 25 09:58:23 2009 (4ABCCC7F)
    nusb3xhc.sys                Fri Sep 25 09:58:31 2009 (4ABCCC87)
    jraid.sys                   Wed Oct  7 07:26:03 2009 (4ACC7ACB)
    mvxxmm.sys                  Thu Oct  8 04:36:51 2009 (4ACDA4A3)
    mv91xx.sys                  Fri Oct  9 06:00:53 2009 (4ACF09D5)
    amdiox64.sys                Thu Feb 18 10:17:53 2010 (4B7D5A21)
    emupia2k.sys                Wed May  5 08:57:27 2010 (4BE16B37)
    ctsfm2k.sys                 Wed May  5 08:57:33 2010 (4BE16B3D)
    ctoss2k.sys                 Wed May  5 08:57:46 2010 (4BE16B4A)
    ha20x2k.sys                 Wed May  5 08:59:10 2010 (4BE16B9E)
    ctaud2k.sys                 Wed May  5 08:59:48 2010 (4BE16BC4)
    ctprxy2k.sys                Wed May  5 08:59:51 2010 (4BE16BC7)
    CTEXFIFX.SYS                Wed May  5 09:01:21 2010 (4BE16C21)
    CT20XUT.SYS                 Wed May  5 09:01:28 2010 (4BE16C28)
    Rt64win7.sys                Tue Sep 27 10:50:33 2011 (4E81E2B9)
    AODDriver2.sys              Tue Mar  6 04:55:00 2012 (4F55DEF4)
    AtihdW76.sys                Fri May 11 04:25:40 2012 (4FACCD04)
    atikmpag.sys                Fri Jul 27 21:14:47 2012 (50133D07)
    atikmdag.sys                Fri Jul 27 21:48:09 2012 (501344D9)
    aswFsBlk.SYS                Tue Aug 21 05:04:55 2012 (50334F37)
    aswMonFlt.sys               Tue Aug 21 05:05:00 2012 (50334F3C)
    aswTdi.SYS                  Tue Aug 21 05:05:01 2012 (50334F3D)
    aswrdr2.sys                 Tue Aug 21 05:05:16 2012 (50334F4C)
    aswSP.SYS                   Tue Aug 21 05:05:54 2012 (50334F72)
    aswSnx.SYS                  Tue Aug 21 05:05:56 2012 (50334F74)
    [/font]
    http://www.carrona.org/drivers/driver.php?id=CTEDSPSY.DLL
    http://www.carrona.org/drivers/driver.php?id=ctac32k.sys
    http://www.carrona.org/drivers/driver.php?id=000.fcl
    http://www.carrona.org/drivers/driver.php?id=amdsata.sys
    http://www.carrona.org/drivers/driver.php?id=amdxata.sys
    http://www.carrona.org/drivers/driver.php?id=AtiPcie.sys
    http://www.carrona.org/drivers/driver.php?id=nusb3hub.sys
    http://www.carrona.org/drivers/driver.php?id=nusb3xhc.sys
    http://www.carrona.org/drivers/driver.php?id=jraid.sys
    http://www.carrona.org/drivers/driver.php?id=mvxxmm.sys
    http://www.carrona.org/drivers/driver.php?id=mv91xx.sys
    http://www.carrona.org/drivers/driver.php?id=amdiox64.sys
    http://www.carrona.org/drivers/driver.php?id=emupia2k.sys
    http://www.carrona.org/drivers/driver.php?id=ctsfm2k.sys
    http://www.carrona.org/drivers/driver.php?id=ctoss2k.sys
    http://www.carrona.org/drivers/driver.php?id=ha20x2k.sys
    http://www.carrona.org/drivers/driver.php?id=ctaud2k.sys
    http://www.carrona.org/drivers/driver.php?id=ctprxy2k.sys
    http://www.carrona.org/drivers/driver.php?id=CTEXFIFX.SYS
    http://www.carrona.org/drivers/driver.php?id=CT20XUT.SYS
    http://www.carrona.org/drivers/driver.php?id=Rt64win7.sys
    http://www.carrona.org/drivers/driver.php?id=AODDriver2.sys
    http://www.carrona.org/drivers/driver.php?id=AtihdW76.sys
    http://www.carrona.org/drivers/driver.php?id=atikmpag.sys
    http://www.carrona.org/drivers/driver.php?id=atikmdag.sys
    http://www.carrona.org/drivers/driver.php?id=aswFsBlk.SYS
    http://www.carrona.org/drivers/driver.php?id=aswMonFlt.sys
    http://www.carrona.org/drivers/driver.php?id=aswTdi.SYS
    http://www.carrona.org/drivers/driver.php?id=aswrdr2.sys
    http://www.carrona.org/drivers/driver.php?id=aswSP.SYS
    http://www.carrona.org/drivers/driver.php?id=aswSnx.SYS
     
  3. Titoos

    Titoos New Member

    Joined:
    Aug 28, 2012
    Messages:
    14
    Likes Received:
    0
    Thank you,

    Yes, there are JMicron controllers (JMB362), SATA2 in fact, and that's why I connected my SSD to Marvell SATA3. (Anyway, I'm planning to change this mobo soon, because there is no new BIOS from manufacturer - I have the latest from F2)
    BIOS sees SSD when connected to JMicron controller.

    Systeminfo.exe - attached with my post.

    AMD OverDrive - this application caused some problems. First I installed Catalyst 11.2 that was included on a CD sold with graphics card. I removed it, and installed newest Catalyst 12.8, but I still could see AODDriver4.01 in DeviceManager (installed, but notified missing file), and AODDriver4.2 (with yellow exclamation). There were some errors, but they're gone when I removed AODDriver4.01 from DeviceManager (as you posted). Now I have only AODDriver4.2 (no exclamation), but no error reports. Though, I have a problem with removing remains of AODDriver4.01 from windows registry (LEGACY...).

    Overclocking - I am not doing this. No need :). The only thing I did was proper memory settings in BIOS. Mentioned error that showed during only first MemTest pass gone when I raised memory voltage from 1.635V to 1.650V, as Mushkin support team advised. I think that too low voltage here could be the main reason of earlier BSODs (IRQL_NOT_LESS_OR_EQUAL mainly). My fault - I didn't uncheck memory dumps in CCleaner, and I lost them :frown: But when they happen again I will post.
    Lockups also gone.

    In your analysis I see "PROCESS_NAME: Skype.exe". You said that that can be network error. I didn't update Skype, and the older version I have reported some problems. Maybe this was a reason here.

    Tried sfc /scannow - did not found any problems.
     

    Attached Files:

    #3 Titoos, Aug 29, 2012
    Last edited: Aug 29, 2012
  4. usasma

    usasma Fantastic Member
    Microsoft Community Contributor

    Joined:
    Mar 22, 2010
    Messages:
    3,048
    Likes Received:
    83
    Systeminfo report looks OK

    All versions of AMD Overdrive must be removed. Un-install all AMD stuff, then use this procedure to install the DRIVERS ONLY: ATI video cards - DRIVER ONLY installation procedure

    I have to wonder about the memory simply because it had errors when it was set "normally" in the BIOS (which means, to me, it's either the memory or the motherboard that's at fault). Although I'm not a memory tweaker, I have seen positive results when people adjust these settings - so give it a try!

    I said that it was a network issue because the file blamed (tdx.sys) is named TDI Translation driver - and TDI translation is a function of the networking stack. TDI = Transport Direct Interface This is a driver that other drivers inteface with (such as firewall drivers) - so it's possible that Skype is interfacing with it. The test it to remove Skype and see if that fixes things. If it does, then try updating Skype to the latest version to see if that works for you.
     
  5. Titoos

    Titoos New Member

    Joined:
    Aug 28, 2012
    Messages:
    14
    Likes Received:
    0
    I removed AMD Overdrive, also updated Skype.

    Regarding bad RAM suspicion, I'm using XMP settings in BIOS (but had to set them manually)

    tCL: 9
    tRCD: 9
    tRP: 9
    tRAS: 24

    I am not a memory tweaker too, so I was a bit afraid cause 1.650v (it's recommended by RAM producer) is marked "red" in BIOS... So I set 1.635v, and MemTest found errors, well - just one error during first pass only. So I raised voltage to 1.650v as Gigabyte staff and Mushkin support team told me to do so, because there is no danger setting 1.650v on an AMD system.

    I ran MemTest again. First pass - no errors. Second pass also completed. I think that all four sticks are ok. Probably too low voltage could generate errors and system lock ups with no BSODs and without memory dumps also.

    Hope it will be OK now. We'll see.


    How can I safely remove AODDriver legacy entries from Windows registry? Anyway, do I need to do this?
     
  6. usasma

    usasma Fantastic Member
    Microsoft Community Contributor

    Joined:
    Mar 22, 2010
    Messages:
    3,048
    Likes Received:
    83
    No need to muck about in the registry unless there's a problem that can't be fixed in other ways.
    Best way is to un-install all ATI video stuff, then use my DRIVERS ONLY installation method.
    If AMD OverDrive remains, then we have other ways to get rid of it (depending on where the remnants may lie).
     

Share This Page

Loading...