C:\Users Visible via CMD command line, But Not In Explorer

Discussion in 'Windows 7 Help and Support' started by schemaman, May 2, 2010.

  1. schemaman

    schemaman New Member

    Joined:
    May 2, 2010
    Messages:
    14
    Likes Received:
    0
    Hi all,
    I have a problem I've never encountered in any version in Windows. My C:\Users directory has disappeared from Explorer, but I *can* open CMD and use the command line to get to it (cd c:users\userid\..... etc.). I have set folder options to show hidden files and folders, but I still don't see it.

    Hopefully, I am just having a massive case of operator headspace and it's simple to fix, but I am stuck.
     
  2. schemaman

    schemaman New Member

    Joined:
    May 2, 2010
    Messages:
    14
    Likes Received:
    0
    OK, I found out what it was, but I'm not thrilled with the solution. I had to uncheck "Hide Protected Operating System Files" and the directory became visible in Explorer again. I say reappeared because I could see it and other files in the Users directory (such as Default User) before and hadn't altered that settting, so I don't know what changed. It's almost like it wasn't set as a system file and I could see the directory's contents, but then something changed that caused it to become a system file and became hidden due to the folder options. Anyhow, note the Hide Protected Operating System Files option is in addition to the option to view hidden folders, so there were 2 ways to influence what can be seen in Explorer.

    I used to be a sys admin, so I know this is going to sound like secret code for "I'm about to tell a whopper", but I honestly didn't change anything and didn't execute any system commands (at least knowingly) that should have changed this directory's state but something happened that I can't explain. With that as the background, I'd like to reframe the question in a few parts:

    *) Is c:\users supposed to be a system file?
    *) If not, how do I changed it back?
    *) If so, can I/should I change it to not be a system file so I can hide system files in Explorer again without problems?

    I am happy with Windows 7 and know there's new things to learn, but this one was a bit of a surprise to me. Thanks for your help
     
    #2 schemaman, May 2, 2010
    Last edited: May 2, 2010
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    No, it is supposed to be a normal folder.

    Who do you show as owner of the folder?
     
  4. schemaman

    schemaman New Member

    Joined:
    May 2, 2010
    Messages:
    14
    Likes Received:
    0
    Thanks for the quick response Saltgrass. I am not near that computer today, but will check it out tomorrow and let you know what it says. I am simultaneously relieved and anxious to find out it's not supposed to be that way.

    Thank you again. I will let you know when I get on that computer.
     
  5. schemaman

    schemaman New Member

    Joined:
    May 2, 2010
    Messages:
    14
    Likes Received:
    0
    As it turns out, I was able to get the answer after all. The ids listed in the permissions box had everything except special permissions checked and were my id, Home Users, System and Administrators. The other thing I noticed is that the "Hidden" box is checked but greyed out, so I couldn't change it right there. I am not sure how or even if I should change that setting.

    Thanks again for helping.
     
  6. schemaman

    schemaman New Member

    Joined:
    May 2, 2010
    Messages:
    14
    Likes Received:
    0
    Hi all,
    Anymore ideas about this given the owners listed previously? Does it makes sense to change the directory type so it isn't system or is that a bad thing?

    Thanks.
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I need to get straight in my head the exact situation so I can investigate.

    The Show System files is another step up from Show Hidden files. If I read your post correctly, the Users folder does not appear until you select Show System files, even though you have show hidden files enabled.

    I have been going through the security tab and permissions to see if I could set up a hidden system file from a normal file, but it seems to be a little complicated. So if you can, you might pick a normal file on your system and try to get the Users folder the same. Pay close attention to the inherited check boxes.

    I will keep playing with this to see if I can finish..
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    OK, more testing. Using this page, I checked the attributes of the Users folder and a System folder, like boot.

    The system folder shows attributes of SH and my Users folder just shows R

    So, open an administrative command window and type following:

    attrib C:\Users

    If it shows something other than R you will probably need to add or remove attributes with the + or -. Since there are folders in your user folders, you may need to add a switch to change them as well, depending on how your system got messed up. My user folder shows no attributes when I check it.

    I tried this with an empty test folder and it seems to work.
     
  9. schemaman

    schemaman New Member

    Joined:
    May 2, 2010
    Messages:
    14
    Likes Received:
    0
    Thank you Saltgrass. I will give this a whirl when I get back to my place and let you know how it goes. I appreciate the help!
     
  10. schemaman

    schemaman New Member

    Joined:
    May 2, 2010
    Messages:
    14
    Likes Received:
    0
    That was a good article - thanks. I checked attrib on a Vista machine's user\userid (where userid is a username) and, oddly enough, my user dir there shows S & H but not R, which is opposite of what you found. That's weird because it differs from what you've found on your own machine but is the case on both of mine that I checked.

    I tested with empty files like you suggested and think I will run attrib -s /S /D c:\users\userid\* to make the users\userid folder and its subfolders on the first machine not system files.

    I will give it a shot later today and post the results.
     

Share This Page

Loading...