Can access \\IPaddress\share but not \\computer\share

Discussion in 'Windows 7 Networking' started by jimbo45, Feb 3, 2009.

  1. jimbo45

    jimbo45 New Member

    Joined:
    Jan 20, 2009
    Messages:
    1,208
    Likes Received:
    41
    Hi guys -- further to the Lan problem I can access the computers on the Lan from the W7 X-64 computer if I give it an IP address for example \\192.168.2.2\D
    Then I get password prompt -- and it's fine

    BUT I can't access via \\BLACKDOG\D

    DNS problem ??? Any network guys out there -- this is outside my area of competance I'm afraid.

    Finally fixed.

    1) in Elevated mode (Run as administrator) ipconfig /flushdns
    2) Properties of the network card -- added the default gateway (192.168.2.1 - my router) in theory I shouldn't have to do this but it worked -- I still left obtain IP address automatically via DHCP etc.
    3) Disable and re-enable the network card

    Works fine now.

    What a piece of BULL trying to get simple Networking to function as it should -- This is not a W7 problem but just seems a Windows general problem. I've had Linux Networks where "NetLin" or "Nethood" just shows entire network - no probs. OK to get file sharing via SAMBA is a bit more complex but it seems to work logically.

    Sometimes it sems things can get fixed in Windows with no rhyme or reason --why on Earth should I have to add default gateway in the network card properties of just 1 Computer in the network. Anyway it works now so that's that.

    At least I didn't have to Registry hack, assign a fixed IP or switch off IPV6.
    Cheers

    Jimbo
     
    #1 jimbo45, Feb 3, 2009
    Last edited: Feb 3, 2009
  2. rl2k05

    rl2k05 New Member

    Joined:
    Jan 9, 2009
    Messages:
    84
    Likes Received:
    0
    After reading through tons of threads, the problem is pointing to IPV6 IMHO.
     
  3. jimbo45

    jimbo45 New Member

    Joined:
    Jan 20, 2009
    Messages:
    1,208
    Likes Received:
    41
    This whole IPV6 stuff is really a red herring.

    If this is true why is it only the W7 X64 computer that has a problem and not W7 X32. IPV6 is enabled on both machines.

    Actually I tried disabling it more in hope than in expectation -- made 100% NO DIFFERENCE. Tried also various registry hacks I've seen in networking blogs. Also no difference.

    Anyway it's working now (with the gateway added as posted.

    The whole area of Networking is actually doubly frustrating as every problem seems totally different - its almost impossible to replicate the same problem on another machine making solutions really difficult even if at the end the solution is simple.

    (Maybe it's why those guys are paid more than the others. :razz::razz:).

    Cheers
    jimbo
     
  4. chad

    chad New Member

    Joined:
    Aug 5, 2009
    Messages:
    8
    Likes Received:
    0
    DNS is the problem

    Hello, the reason why you are unable to access your machine name is because you do not have a DNS Server on your network, and why should you? You are probably at home. IPv6 has nothing to do with at all. IPv6 just has more fields than IPv4.

    DNS stands for Domain Name Resolution. Think of it like you and me having a conversation. It would go like this:

    Hi, do you know of a computer named CHAD?
    Yes, I do.
    What is CHAD's IP Address?
    It is 192.168.0.5.
    Thanks.

    I know that you have already fixed this, but another way you can fix this is by editing your hosts file. You can open the folder containing the hosts file by putting this in the Search Bar that appears when you hit the Windows button:

    %windir%\System32\drivers\etc\

    Hit enter, and this will bring up the folder. Now, if you know the IP Address, and the machine name, enter this into the hosts file, and save it:

    192.168.0.5 CHAD

    Now, when you try to map your network drive, it should work.
     
  5. zebedeeboss

    zebedeeboss Honorable Member

    Joined:
    Jul 7, 2009
    Messages:
    16
    Likes Received:
    0
    Only problem with doing this is when your router decides to give each computer on your network a diff ip than that in the host file.

    Ok so now we get into making sure your router doesn't do that, but that's for a diff thread I believe.
     
  6. chad

    chad New Member

    Joined:
    Aug 5, 2009
    Messages:
    8
    Likes Received:
    0
    You are correct. This is an issue with this. I suggest you look into the Administrator interface of your router, and you should be able to reserve an IP address for a machine. For times when I use this, I reserve that IP address for that machine. That should clear it up.
     

Share This Page

Loading...