Windows 7 Can not set ANY wallpaper background except solid collor

#1
Hey guys, I got a desktop wallpaper issue. I can't set any picture as my desktop background wallpaper, I can only choose from solid colors. When I try to apply desktop background picture I get black solid and thats it. I think this issue is related to copy protection, everything was working fine until today, and coincidentally today is 30 days since I have installed W7600. I have, of course, activated it with Orbit 30 W7 Activation Tool 1.8, in properties it says that W7 is activated and genuine, I don't get any warnings that my copy is not "genuine", but this issue just appeared out of nowhere. Is there any work around this stupid copy protection? I tried registry entries edits, but those are for Vista (Vista has similar issue), no tweak works, any help?
 


reghakr

Essential Member
#2
When you right-click and choose Personalize and click on Desktop background, does the drop-down menu say Windows Desktop Backgrounds.

Can you use the Browse button and navigate to the c:\windows\web\wallpaper directory?
 


#3
Everything is working as it should, nothing is grayed out, there are no error messages. Right click menu displays correct options, personalize menu looks correct, all themes and wallpapers are there, I can select them, I can select slideshow images in check boxes, but when I hit Apply and OK, nothing happens, the BG stays solid black. I can chose from solid colors, they do change, but I cant select images, even when I apply selected wallpaper from context menu it wont change, I even tried through 3rd party image viewers like ACDsee, Windows Live photo gallery (not really a 3rd party app), Fast stone image w, Picasa 3...Nothing. I consider myself as an advanced user, this is not a simple issue, there is probably something blocking wallpapers from registry, I tried accessibility options, too. I would hate to reinstall W7 just because of this issue...Will try to patch it again.
 


#4
Won't really solve anything (unless you want to migrate) but at least it will answer some questions, try a different user account. At least you'll know if it's a problem in HKLM or HKCU.
Any reason to expect an infection of some kind perhaps an online scan at trendmicro is in order, in XP one would often find that infections had so modified the registry. UAC should prevent this in Vista/Seven though.
 


reghakr

Essential Member
#5
Go to Start > Run, and type Regedit.

Choose Edit > Find and type in NoChangingWallPaper.

If you find it and it's value is 1, change it to a 0, then restart your computer.

Scrap that idea, it completely greys out the link to change the wallpaper.
 


Last edited:

RAK

Extraordinary Member
#6
Have you altered anything in the "ease of access" centre?
Try this first:
Open control panel go to ease of access center
Last item - choose "Make it easier to focus on tasks"
Under "Reading" see if "Remove background images" box is checked.
If it is, uncheck it and that might get your desktop wallpaper back.
 


#7
Guys, I'm not stupid, I know what I'm doing...Ease of access is the Accessibility option that I have mentioned, I have checked that, I have tried nochangingwallpaper, too, and a different user even before I posted this topic.
But there are news, I have solved the issue, it was indeed the windows activation/copy protection, I have removed all cracks and patched the OS again with a new key and new genuine activation, it seems that it was not working correctly the first time because I have installed additional language packs and I do regular windows updates, don't know if these are the reasons why my first patching malfunctioned. Anyway, thanks for trying to help, all is good now, have a beautiful wallpaper on my desktop :D!
 


#8
hi

i'm having the same problem with 1010

i cannot change the desktop background and when i'm trying to change it with photo viewer or any 3rd party software an error message shows, it says "This image can't be set as wallpaper. An internal error occured."

i've tried all steps above except the windows activation/copy protection (like the one 1010 did)... maybe there are another solution?

my W7 is evaluation copy build 7100

thx b4

EDIT: problem solved, i can change my desktop wallpaper via firefox... but still this is troublesome...
 


Last edited:

sefo

New Member
#9
I have the same problem. I use Windows 7 Professional 64bits.

I don´t know how solve it.
 


sefo

New Member
#10
I have solved my problem. In C:\Users\USER\ i had all AppData subdisr hidden, I only made visible its and now i can change my wall :O.

Salutes.
 


#11
I have solved my problem. In C:\Users\USER\ i had all AppData subdisr hidden, I only made visible its and now i can change my wall :O.

Salutes.
This also worked for me and I registered just to confirm that a hidden User folder on your OS drive will cause this problem and to say thank you for both figuring it out and taking the time to post it!
 


#12
FIRST SOLUTION: Follow this link is ur only problem is you just see 1 color in background Remove Background Images (where available) - Windows 7 Forums.


SECOND SOLUTION:Ok i figured out how to fix it. what you need to do is first follow the steps of Remove Background Images (where available) - Windows 7 Forums. but when you get to Hide color most likely the box will not be checked, check the box. then go into personalization and change the color of your background and save it. then go to theme and change theme to an older windows theme. then go back and uncheck the box for hide color and put whatever background you were trying to do. What happened is when you did system restore it froze your last picture on your background. and what this does is removes and trace of anything and solves it for you.
 


#13
I have solved my problem. In C:\Users\USER\ i had all AppData subdisr hidden, I only made visible its and now i can change my wall :O.

Salutes.
Well, i wanted to thank you for figuring this out along with this problem. *registering in this forum juz for thanking u*
thanks so much. now my problem fixed. xD.
 


#14
I was skeptical, to be honest, but going in and unclicking Hidden in the AppData folder did it for me too. Thanks!
 


Sonny

Excellent Member
#15
Welcome to the forum Jessica. I am glad you found the answer to your problem.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.