Can not set system protection on a drive

#1
I'm running Windows7 Ultimate 64-bit. I went in to the control panel/System Protection to turn on Protection on the drive that contain my documents so I could use the "Restore Previous versions". When I attempted to do so I got an error stating "Could not apply settings for the following reason: THe Filename, directory name, or valume label syntax is incorrect"

How do I find the syntax problem?
 


#2
Are you using the "&" character in the filename, directory name, or volume label?

the filename, directory name or volume label syntax is incorrect
I found the reason for it and a workaround... it appears that you cannot create a project within a path that has an ampersand (&) in it, which my original projects path did. In Tools/Options/Projects and Solutions/General, I selected the "Show advanced build configurations' option. This allows me to select the project build location on creation of a project, and I am now able to ensure it does not try to create in the path with the ampersand in it.
This may also be relevant.
Error - The filename, directory name or volume label syntax is incorrect. (0x8007007B), when exiting system restore

Is it the 0x8007007B error code you are receiving?
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.