Can only connect to internet with static ip

#1
I have been googling about this problem that I have been having for over 2 hours, but to no avail. Ever since I upgraded my previously windows vista computer up to windows 7, I have been having severe problems connecting to my home internet. Now, I cannot change any of my routers settings since they are my stepfathers ,and he has a set username and password that I am not allowed to know. All other device in our house will connect just fine to our internet, and my laptop can connect to all other routers fine, this one is the only one I have problems with. What happens is that I get a "connected with limited access" error, and am completely unable to gain any internet access. I managed to set some static IP settings that allow me internet access, yet make things run more slowly and I am unable to connect with people properly in game, such as hosting a terraria server and other things like it.
These are my computer specs:
Windows 7 Ultimate Service Pack 1
AMD Athlon(tm) X2 Dual-Core QL-65 2.10 GHz
3.00 GB RAM (2.75 GB usable)
32-bit operating system

when I type in Ipconfig /all, I get this:

Windows IP Configuration

Host Name . . . . . . . . . . . . : Gary-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8102E/RTL8103E Family PCI-E Fast Ethernet NIC (NDIS 6.20)
Physical Address. . . . . . . . . : 00-1E-33-CB-33-27
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8187SE Wireless LAN PCIE Network Adapter
Physical Address. . . . . . . . . : 00-24-D2-9D-FF-6E
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::2cf0:1df8:4c99:cf96%21(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 335553746
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-B9-34-78-00-1E-33-CB-33-27
DNS Servers . . . . . . . . . . . : 4.2.2.2
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Hamachi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Hamachi Network Interface
Physical Address. . . . . . . . . : 7A-79-05-91-5F-6B
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2620:9b::591:5f6b(Preferred)
Link-local IPv6 Address . . . . . : fe80::8581:204:be25:41fc%17(Preferred)
IPv4 Address. . . . . . . . . . . : 5.145.95.107(Preferred)
Subnet Mask . . . . . . . . . . . : 255.0.0.0
Lease Obtained. . . . . . . . . . : Wednesday, June 27, 2012 10:40:13 PM
Lease Expires . . . . . . . . . . : Thursday, June 27, 2013 10:42:20 PM
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 5.0.0.1
DHCPv6 IAID . . . . . . . . . . . : 310016441
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-B9-34-78-00-1E-33-CB-33-27
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 11:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{D3E3AEAB-68E9-4E07-B4C2-7DD0F643DC81}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{F6242BA9-E6F0-4510-98AE-5EE2E0EB93B6}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Also, here is the static IP settings: staticipsettings.JPG

I have attempted uninstalling and reinstalling the network drivers, and when I troubleshoot problems when I'm not using the static IP, it says there is a problem but gives little to no information, while being unable to automatically solve the problem.
Let me make it clear that when I was on windows vista, my connection was fine, and I still connect to every other network I try fine without the static IP.
I have attempted to use ipconfig /remove and ipconfig /renew also to no avail, and I am really not sure what else I can do.

The static IP allows me connection to the internet, but I am tired of it being slow and giving me trouble with connectivity.

Could anyone help? I have posted on forums about my problem, but nowhere have I managed to find any REAL help.
 


johnny quid

Well-Known Member
#2
Hi Gary,
just a late night shot in the dark here- why don't you hit the reset button a few times on the router you can't access then log on using. Its defaults ?
Maybes you'll get lucky.
Regards. Jq72
 


helpifIcan

Extraordinary Member
#3
Try turning off IPV6 in your adapter settings.
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#4
That dns server address looks unusual. Is it set statically or by dhcp? I'd try setting the dns server address to automatic - I would expect it normally to be the address of the router - in this case 192.168.1.1.
 


#5
Hey, I know that my response is late, very late, but I am still having this same problem, and still need to resolve it. I cannot connect to internet without a static IP, dhcp doesn't work. I've had to swap to a new static IP from before as that one stopped allowing internet access out of the blue.
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#6
Chrck your ipconfig from a command prompt. If you have problems running or interpretingit get back to us.
 


#7
Here are the results of another ipconfig.

Windows IP Configuration

Host Name . . . . . . . . . . . . : Dddrgn-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8187SE Wireless LAN PCIE Network Adapter
Physical Address. . . . . . . . . : 00-24-D2-9D-FF-6E
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.200(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
4.2.2.2
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8102E/RTL8103E Family PCI-E Fast Ethernet NIC (NDIS 6.20)
Physical Address. . . . . . . . . : 00-1E-33-CB-33-27
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Hamachi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Hamachi Network Interface
Physical Address. . . . . . . . . : 7A-79-19-46-9A-A2
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2620:9b::1946:9aa2(Preferred)
Link-local IPv6 Address . . . . . : fe80::3428:5a2d:222d:5b72%16(Preferred)
IPv4 Address. . . . . . . . . . . : 25.70.154.162(Preferred)
Subnet Mask . . . . . . . . . . . : 255.0.0.0
Lease Obtained. . . . . . . . . . : Tuesday, February 19, 2013 2:18:08 PM
Lease Expires . . . . . . . . . . : Wednesday, February 19, 2014 2:20:15 PM
Default Gateway . . . . . . . . . : 2620:9b::1900:1
DHCP Server . . . . . . . . . . . : 25.0.0.1
DHCPv6 IAID . . . . . . . . . . . : 259684842
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-E4-1E-F1-00-1E-33-CB-33-27
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:c79:1e24:9d17:ce33(Preferred)
Link-local IPv6 Address . . . . . : fe80::c79:1e24:9d17:ce33%13(Preferred)
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{EC0EFBDA-6994-45F4-9827-04BA442E2D38}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{D6507161-D630-491A-96EF-DF15A23F4112}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


No other devices in my house have any problem connecting to my router, and I have found other routers that my computer is reacting like this too as well, so it shouldn't be a problem with the router. Because of being unable to connect properly to my router, I get constant ping spikes that make internet browsing and gaming very difficult.
 


helpifIcan

Extraordinary Member
#8
The only thing I see that is unusual, may not be a problem, is having 2 different locations one is the router the 192.168.1.1 and the 4.2.2.2 that is external, if you are entering them manually try removing one and see if that helps if not try removing the other one.
This is mine and it works fine for all my devices,2 desktops 2 laptops, tablet , and phone. I have my DNS set in the router so the external DNS is supported through the router. I have my PC's set for automatic DNS.

ipall.gif
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#9
Assuming your router is running DNS you should try setting both IP address allocation and DNS server address allocation to automatic via DHCP and see what ipconfig shows then. (I assume it is the wireless adapter you are trying to connect with.)
 


#10
okay, I did an ipconfig/all with everything set to dhcp. Like before, it won't allow me connection to my router.


Windows IP Configuration

Host Name . . . . . . . . . . . . : Dddrgn-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8187SE Wireless LAN PCIE Network Adapter
Physical Address. . . . . . . . . : 00-24-D2-9D-FF-6E
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IPv4 Address. . : 169.254.18.52(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8102E/RTL8103E Family PCI-E Fast Ethernet NIC (NDIS 6.20)
Physical Address. . . . . . . . . : 00-1E-33-CB-33-27
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Hamachi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Hamachi Network Interface
Physical Address. . . . . . . . . : 7A-79-19-46-9A-A2
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2620:9b::1946:9aa2(Preferred)
Link-local IPv6 Address . . . . . : fe80::3428:5a2d:222d:5b72%16(Preferred)
IPv4 Address. . . . . . . . . . . : 25.70.154.162(Preferred)
Subnet Mask . . . . . . . . . . . : 255.0.0.0
Lease Obtained. . . . . . . . . . : Wednesday, February 20, 2013 4:30:09 PM
Lease Expires . . . . . . . . . . : Thursday, February 20, 2014 4:32:15 PM
Default Gateway . . . . . . . . . : 2620:9b::1900:1
DHCP Server . . . . . . . . . . . : 25.0.0.1
DHCPv6 IAID . . . . . . . . . . . : 259684842
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-E4-1E-F1-00-1E-33-CB-33-27
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{EC0EFBDA-6994-45F4-9827-04BA442E2D38}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{D9276F9F-9804-4FF9-8EAA-1C7D63384E90}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{D6507161-D630-491A-96EF-DF15A23F4112}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#11
On the report for your wireless connection:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8187SE Wireless LAN PCIE Network Adapter
Physical Address. . . . . . . . . : 00-24-D2-9D-FF-6E
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IPv4 Address. . : 169.254.18.52(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

It shows that DHCP is enabled on your pc - this means that IP address, efault gateway and DNS server address may be requested from your router. It also shows that autoconfiguration is enabled - this means that in the absence of any address allocations from the router IP configurations will be automatically assigned. The fact that they have not been assigned and therefore autoconfiguration has been implemented is confirmed by the IP address 169.254.18.52 having been assigned. Any address starting with 169 is an autoconfiguration address which cannot be used for internet connection. There is also no default gateway or DNS server address assigned.

All of this points to your router failing to assign addresses, probably because it has been configured to not respond to DHCP requests. If, as you say, you have no control over the router then you need to manually assign the addresses which are not being provided. I suggest you try the following config on your wireless adapter:

Set both IP addresss and DNS Address to manual/static and set the following values:

IP address: 192.168.1.120
subnet mask: 255.255.255.0
default gateway: 192.168.1.1
preferred dns server: 192.168.1.1
alternate dns server: 192.168.1.1

You also seem to have a VPN installed (Himachi) - do you know what that is installed for?
 


#12
Yeah, I know why Hamachi is installed. I have messed with it in the past, but the problem has been exactly the same even when it wasn't installed. I use it to play minecraft with friends who can't port forward to host servers, so it lets us host without doing that. I'll try the settings you have suggested, I'll replace my current static IP with them.

I managed to connect to my router using the settings you gave me. Hopefully this will fix the slow internet speeds I have been getting. Still, while you are here, I have another question that is somewhat related. Whenever I go to my adapter settings, it says that my Local Area Connection "network cable unplugged". I cannot connect to anything via lan, do you know what this means?
 


Last edited:

patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#13
"Network cable unplugged" is most likely indicating one of three things:

Failure of connectivity at the router end, failure at the pc end or failure of the conncting ethernet cable. First try a different cable (ensuring that the cable you try is wired appropriately - in this case "straight through".)
 


#14
Alright, I get what it means now. So far, I haven't had any of the internet lag spikes that I have had so often, so I think the new static IP is working. Thanks for the help!
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#15
Good to hear - thanks for the feedback.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.