Can see, but can't access external HD connected to Win7 comp from XP comp

Discussion in 'Windows 7 Networking' started by skidave, Dec 8, 2009.

  1. skidave

    skidave New Member

    Joined:
    Dec 8, 2009
    Messages:
    10
    Likes Received:
    2
    Apologies for this, as I know this has probably been covered multiple times. I have read everywhere, but cannot get this to work.

    Here's the set up:

    I have a WD MyBook connected to my new Win7 notebook. I right clicked on the drive and selected advanced sharing. I called the shared name 'Media' and allowed 'everyone' 'full access'.

    I can see this folder (the external HD shared name 'Media') from my XP machine, but for some reason I can't access it.

    Here's the prob. I could access the external HD connected to the Win7 machine when it was in its original FAT32 state, but I formatted it this morning to NTFS (so I could put larger movie files on it). I set it up the same, but as I said - I can now only see the external HD connected to the Win7 machine from my XP machine, but it won't let me access it. I get the standard '... you do not have permission to access this network resource' error.

    I have spent 4+ hours trying to resolve this, so any help would be much appreciated.
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Welcome to the forum, Skidave ! :)


    Have you tried:

    Control Panel > Administrative Tools > Computer Management > Disk Management > Right click on the drive > Properties > Security > Advanced > Owner > Edit > change the ownership to yourself ?
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Since it is now an ntfs volume, you'll want to check your ntfs permissions (not just share permissions) check under the security tab (where you set ntfs permissions that impact network sharing) and make sure that they are set like you want them to be. Also is the MyBook attached using a built in ethernet connection or usb. If ethernet, I know it probably doesn't support NTLMv2, although that shouldn't impact the XP machine has more to do with vista and Win7. Keep us advised as to your progress
     
  4. skidave

    skidave New Member

    Joined:
    Dec 8, 2009
    Messages:
    10
    Likes Received:
    2
    Wow! Thanks for the quick replies guys.

    Cybercore - I will give that a go tonight.

    Trouble - it is attached through USB. Can you elaborate more on where I change the settings you described please?

    Also - as a follow up. If I create a folder on this drive, and set up normal sharing on it, I can see and access this fine from my XP machine. Seems the problem is getting access to the root of the drive....
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Sure
    When you right click on the drive and choose properties, in the properties dialog box you will see a buch of tabs at the top. One that says "Sharing" where you configure sharing and share permissions (usually full control to everyone works here) click on the advance sharing button, check the box that says share this folder at the top and give it a share name (something practical and intuitive like "My_Book" (No spaces, quotes or special characters, except underscores)...now under the security tab choose the edit button somewhere near the center on the next dialog box choose add, on the next box click advanced and on the next click find now...this is where you can get as specific or as wide open as you wish...most people simply choose everyone and give them full control and there off to the races....however this is not a good idea...you can use it now for testing but I would suggest that if you have a user that exists on both machines and has the same password, then perhaps select that user (you can also choose multiple users and or groups...later explanation) and grant him or her the ntfs permissions you choose. Try to work through this using this explanation and if you run into a road block post back and we'll go step by step. Post back anyway and let us know if you got it working.
     
    skidave and (deleted member) like this.
  6. skidave

    skidave New Member

    Joined:
    Dec 8, 2009
    Messages:
    10
    Likes Received:
    2
    Cybercore! Awesome, that did the trick. Thank you, thank you, thank you!
     
  7. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Thank you, my sheer pleasure to help. :)
     
  8. skidave

    skidave New Member

    Joined:
    Dec 8, 2009
    Messages:
    10
    Likes Received:
    2
    Actually, it was more Trouble's help that final sorted me. Nonetheless, thanks both of you :)
     
    Trouble and (deleted member) like this.
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Actually:
    I'm sure we are both quite glad to have been of some small help....and right back at you for not giving up and hanging in there. Hang around this forum, share your experience, I'm sure you'll be able to help others with what you've gone through.
    Randy
     
  10. skidave

    skidave New Member

    Joined:
    Dec 8, 2009
    Messages:
    10
    Likes Received:
    2
    Absolutely. You guys have made this a pleasant experience - and one of the better forums I've visited in my time.

    Thanks again.
     

Share This Page

Loading...