Cannot access NAS folders


I have an LG N2A2 NAS box with a wired connection into my router. I then have two laptops that are generally connected to the router wirelessly but sometimes via cable, if I am transferring a large amount of data. The main laptop is running Win 7 Pro (64 bit) and the other one is running Vista Business.

Until a couple of weeks ago the NAS would show up under computers in Windows Explorer on the Win 7 laptop, and the shared folders could be accessed. At that point I connected the other laptop via cable to the router. Since then (and maybe it's a coinicidence) the NAS has not been showing under computers in WE on the Win 7 laptop and I haven't been able to access the shared folders. The NAS is still showing as a media device and I can log in via IE - but I cannot get at the files directly or back up to a NAS folder. I have tried entering the device name and IP address in WE but I get the error message "Windows cannot access XYZ...". I ran the troubleshooter but it didn't help.

The NAS came with a NAS detector utility and sure enough this detects the NAS but when I click "Open Network Folder" nothing happens.

I have tried changing the IP of the NAS but this does not make any difference.

Would be grateful for any help!


Noob Whisperer
We have chased these types of issues time and again and it can be any number of things that are causing the issue. I'll give you the top three in no particular order
1.) You have changed your username and or password for your computer account and did not use the NAS's web interface to make the same adjustments to reflect the changes in access permissions, with respect to the shares on the device. Each NAS is a bit different but your documentation should provide some help with respect to what you might need to do.

2.) Some change or adjustment in the network adapter settings have changed and "Enable NetBIOS over TCP/IP is no longer checked under the WINS tab, within the properties of IPv4, in the properties of your network adapter. Or something has changed with respect to the relative services (services.msc) necessary to support file and printer sharing, so.....
into the search box and hit enter
confirm that the following services are started, consider setting the startup type to automatic
Computer Browser
Function Discovery Provider Host
Function Discovery Resource Publication
Network Connections
Network List Service
Network Location Awareness
Network Store Interface Service
SSDP Discovery
Also check the network and sharing center and confirm that your options are configured as to support sharing on both machines.
3.) Could be third party firewalls (ZoneAlarm, Comodo, etc.,) or any number of Internet Security Suites ( AVG, Avast, Avira, Norton/Symantec, McAfee, etc.,) try removing any such product by using the program uninstaller if available in the programs directory, or the Programs and Features applet in the Control Panel, follow that up with the vendor specific proprietary removal tool, a list of some can be found here Security Software | SingularLabs if yours is not present in the list, try googling for the removal tool.
Consider replacing any such product with the built in Windows Firewall and Spyware Protection | Free Spyware Protection | Microsoft Security Essentials

One final thing that sometimes helps with these types of issues regards the Local Security Policy
Click start and type
hit enter
See attachment

Thanks for those suggestions - tried them but no dice unfortunately.

There are no user accounts (except for the default administrator account) set up on the NAS. It is not possible to set up an account with the same credentials I am using on my Win 7 laptop because a longer username is required. Is there anything on the Win 7 side that would prevent me connecting to the NAS without credentials even if the NAS does not require any?


Noob Whisperer
Is there anything on the Win 7 side that would prevent me connecting to the NAS without credentials even if the NAS does not require any?
Nothing actually that comes to mind. Unless you have changed your local security policy regarding the Sharing and security model for local accounts from "Classic" to "Guest Only" and then have disabled the "Guest" account.
Note: If the Guest account is disabled and the security option Network Access: Sharing and Security Model for local accounts is set to Guest Only, network logons, such as those performed by the Microsoft Network Server (SMB Service), will fail.
Double check the properties of the network adapter you are using on either or both machines and confirm that IPv6 is unchecked and there is nothing checked that references any currently or formerly installed third party security suite's "Network Filter"

I would have suspected something more global had changed, maybe something specific to the router you are using. If it has a SPI component (Stateful Packet Inspection firewall component)check those settings if present regarding trusts, or something regarding either QoS (Quality of Service) or UPnP (Universal Plug and Play) maybe double check and make sure both are enabled on the router.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.