Cannot access shared folders from xp or vista

Discussion in 'Windows 7 Networking' started by Tadmen, Nov 9, 2009.

  1. Tadmen

    Tadmen New Member

    Joined:
    Nov 9, 2009
    Messages:
    6
    Likes Received:
    0
    I had a running network with XP being my main computer. After upgrading to Win 7 my shares are not accessible.
    There is one thing that I do on my home network I don't use any passwords for my user accounts. So if my main computer running vista has the main user/administrator called John, then I don't use any passowrd for that account.
    I have the same settings on all my other computers on the network. It worked on XP, as I could go to policy settings and set the rule "Allow only local login without a passowrd" to disabled and then I could log in across the network without any passwords to type in.
    Now I have created a couple of shares on Win 7 machine (set up sharing, permissions (full control), security, etc. I've added John (\\main\John) to the list giving him full control, etc. Yet, weh I try to access the Main computer I cannot do that. It shows in my network on Vista, I can click on main and can see the shared folders on Win7, but when I try to click on them I get the message that access was denied (actually the error # in advanced settings is 0x80070005)
    So my question is, can I have an administrator or user accout without a passowrd on win 7 machine and then connect to this computer's shared folders from xp and vista computers? If so what I'm doing wrong.
    I can print fine from vista and xp computers to the printers that are connected to Main and are shared (file and printer sharing is enabled)
    Any help would be appreciated
     
  2. Tadmen

    Tadmen New Member

    Joined:
    Nov 9, 2009
    Messages:
    6
    Likes Received:
    0
    Solved using gpedit.msc

    The setting to allow logging through the network without a passowrd is in the gpedit.msc.
    Everything works now
     
  3. stolsvik

    stolsvik New Member

    Joined:
    Dec 23, 2009
    Messages:
    4
    Likes Received:
    0
    Can you tell more specifically which part of the policy files (the "keys", so to speak) where this is found?

    I must have a weird problem, because I have specifically said (configured using that Vista/7 interface for this) that I want to allow non-password users to access, but I finally had to give the user a password to connect (I got "access denied" when trying via explorer, both browsing and map network drive, and "access denied, code 5" or something when using "net use"). So something else must be overriding.. And you apparently found it, but just pointing to gpedit.msc is a bit too coarse-grained for me!

    Thanks!

    (Btw, there is apparently a difference between different directories. Directories which I've made can be shared easily, and is also allowed to connect without password. For these directories, one get this simplified sharing GUI when "right-click -> Share..". But e.g. the User/Username directory, and the C:-drive itself, do not present this simplified GUI, and even when allowing whatever on both the dir, and on the share, it is still not possible to connect using a user without password)
     
  4. Tadmen

    Tadmen New Member

    Joined:
    Nov 9, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,
    Sorry for a late posting but here is what I can tell you:
    1. Run gpedit.msc and under Computer Configuration click Windows Stettings>Security Settings>Local Policies>Security Options.
    Then click on accounts: LImit Local Account use of blank passowrds or something by that name (2nd or 3rd entry from the top, I believe) and click Disable. By deafult it is enabled.
    2. You may also click under Local Policies on User Rights and then choose Access this computer from network and then add your login name, Authenticated Users, etc.
    3. In any Folder under Tools, click Folder Options>View and scroll down and uncheck Sharing Wizzard. It's supposed to simplify sharing but can prevent some sharing options from becoming available.
    4. Right Click on the folder you want to share, choose Share With>Advanced Sharing. Then under the Sharing Tab click button Advanced Sharing and check the sharing box. Then click Permissions and add your login name, authenticated users, users, everyone, etc.) and make sure you give all those people full rights or rights you think they need. You can start with full and if all works well take away some of them later and recheck connectivity.
    5. Last step in the same area where you clicked to share the specific folder click on Security tab and then on Edit button. You need to add users and groups (the same as in step 4) and give them the same rights as you did in step 4. When you click OK or Done it will reset those permissions and open all the data in the folder to the users on your network.
    Of course you have to do that sharing thing for all the folders you'd like to share (all the subfolders will be shared automatically with the same rules). And finally you need to do that blank password disable/enable trick on other computers on your network if you'd like them to be accessed from various computers. Then all the files no matter on what computer they reside will be accessible provided the shared folders on those computers have permissions set right.
    Hope it helps.
    Good luck!
     

Share This Page

Loading...