Cannot delete folders on a network drive from Windows 7

Discussion in 'Windows 7 Help and Support' started by jeryslo, Jul 24, 2011.

  1. jeryslo

    jeryslo New Member

    Joined:
    Mar 21, 2010
    Messages:
    10
    Likes Received:
    0
    Hello!

    I have a really strange problem. I am using Windows 7 Professional with SP1 installed. I have a My Book 500GB external hard drive connected to the network via Linksys E3000. Now in Windows 7 I am logged in as Admin. The network disk is configured in Linksys, that an admin group can r&w. Now I have added this settings to Credential Manager, where I have specified network address of disk, username and password. I have added it, because otherwise the Windows 7 would forget the username & password on restart of the system.

    Now the network disk is working without problems. I can access file, write files on it, delete files from it. The problem arises, if I want to delete folder, that contains other files or folders. Now here for some reason it displays this error:
    Error.

    I tried Try Again, does not help, so I clicked Cancel. Now what is really strange about this is, that the folder has gone missing! I will be able to see it again, if I reconnect the network disk, or restart the computer. Now I really don't understand about the permission thing, becuase I am already Admin. I have looked up under network disk properties -> security, and this is want I have found:

    Permission.

    As you can see, it seems the account Account Unknown is what controls what can be accessed. It only has Special permission allowed. So I tried to change it to allow everything (which probably would not make a diffrence, because it seems that under that Special permission falls almost everything, as I said I can do everything except delete folders, that contain other files or other folders). When I wanted to apply the Full control that I have selected it gave this error:

    Denied.

    It seems that I cannot change this permission. So I wanted to know who exactly is behind this permission, and I got this under Advanced -> Owner:

    AccountOwner.

    I guess the Linksys E3000 operates this permission. But as I have said in the first paragraph, I have setted the disk to adming group under Linksys E3000 setup (192.168.1.1), which means it has full r&w access.

    Now the strangest thing about this thing: I have also another computer, that has Windows XP SP3 installed on it. I also have the network disk added to the computer. The diffrence is, that there I am also able to delete folders, that contain files or other folders. It deletes them without any error. Also, I can see the folders, that I tried to delete from Windows 7 and have then gone missing (which is as I have said only until I disconect or restart system).

    I really don't understand why I am able to delete it from Windows XP, but not from Windows 7. The computer, that has Windows XP installed is connected through Linksys E3000 LAN via UTP cable just as is computer, that runs Windows 7. Please help me with my question and thanks for any anwears!
     

Share This Page

Loading...