Cannot enable wireless adapters.

#1
I was using a DWA 140 wireless dongle from D-Link on XP and it worked fine. However, after installing the drivers repeatedly in Windows 7, I cannot get it to work.
Looking in the device manager section, it shows up under its proper name. It's enabled. Properties reveals there are "no problems" with the device. However, when it comes to configuring wireless adapters from the Networking page in Control Panel, the item is greyed out and marked as "disabled". I double click and get a box that says "Enabling" then a couple of seconds later it changed to "Enabled" and goes away, but it's still greyed out and disabled.

I've searched for drivers and picked up the most up to date RAlink drivers for this chipset, and it still won't work.

So, exasperated, I tried my old WMP54G from Linksys. Installed, picked up and......exactly the same problem. Disabled and cannot be enabled.

This is an entirely new build on new hardware, not an upgrade from XP.
I just get the impression there a "Enable Wifi?" check box somewhere I need to tick, but I don't know where. Or how.

If anyone can help, I'll be eternally grateful.
 


#2
Okay...I sorted the problem out.

The original cause is a complete unknown, but after several hours of exasperation I simply reinstalled Windows with both the card and the dongle stuck in the system. It gave me the option for a wireless network during installation, which it then connected to fine and once installation finished it began updating. So far no problems.

So there's the answer. Reinstall Windows. First time I've had that as a legitimate solution rather than a glib statement.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.